BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   K75c speedo has stopped working Empty K75c speedo has stopped working on Thu Jan 28, 2016 11:02 pm

fatdog

fatdog
active member
active member
hi fellow K lovers
I have a 1988 K75c . The speedo has stoped working. the Tacko is still working, every thing else is still working fine. can any one make suggestions where I start looking. ?? are ther any other hidden fuses on the bike.
Any advise would be greatfull.

In the dog house
Yours
fatdog

    

2Back to top Go down   K75c speedo has stopped working Empty Re: K75c speedo has stopped working on Thu Jan 28, 2016 11:22 pm

RicK G

RicK G
VIP
VIP
Hi Ya Fatdog must be the only dog house in OZ with internet. K75c speedo has stopped working 177912

Probably best to start a new thread about the speedo but seeing you ask and we aren't like some forums.
Many problems with the speedo are from corroded conections and a build up of fine metal particles on the magnetic pickup on the rear drive (just behind the shockie mount). There has been a very recent thread on this if you go to the portal page and have a look through the last 50 topics you should find it and using the google search on the main forum page will find many threads on this topic


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1993 K1100 LT, 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki X 2 for now
    

3Back to top Go down   K75c speedo has stopped working Empty Re: K75c speedo has stopped working on Fri Jan 29, 2016 12:10 am

blaKey

avatar
Life time member
Life time member
Moved to electrical so that if someone is looking for speedo info, they'll find it.


__________________________________________________
Neil
K100RS 1986 RED!

Dress for the ride and the potential slide.
    

4Back to top Go down   K75c speedo has stopped working Empty Re: K75c speedo has stopped working on Fri Jan 29, 2016 12:52 am

duck

duck
Life time member
Life time member


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

5Back to top Go down   K75c speedo has stopped working Empty Re: K75c speedo has stopped working on Thu Feb 18, 2016 8:48 pm

fatdog

fatdog
active member
active member
Hi fellow k lovers
Your words of wisdom has done the trick. My fault was the one that valued advice sorted out. A corroded conector.
Thank you so much.
I am a much happyer dog
Very kind regards
Fatdog
Woof woof

    

6Back to top Go down   K75c speedo has stopped working Empty Re: K75c speedo has stopped working on Fri Feb 19, 2016 5:22 am

92KK 84WW Olaf

92KK 84WW Olaf
Life time member
Life time member
Glad you got sorted. As the guys said this is a great forum and everyone is so very helpful.

I suppose now we will hear a good bark from the exhaust?


__________________________________________________
1992 K100LT 0193214 Bertha Alaska Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 100,380 miles
1983 K100RS 0011171 Fricka 606 29,495 miles Damn K Pox Its a Bat outta Hell No 33,600 miles
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum