BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    ABS issue on K100 RS SE on Sun Feb 21, 2016 11:49 am

yetti.86

avatar
active member
active member
Hi folks.
I've bought K100RS ABS Special Edition 89. Bike is in average condition, after clutch repair with 120000 km on the clock. Everything working except ABS. Nevertheless I've performed several steps to repair ABS system and I've reached some results. Anyway it isn't still in 100% condition.
So current state is following:

1) When I turn the ignition on, the bulb monitor light and ABS light flashing alternately.
2) ABS error code is zero. Led connected to the middle pin of ABS diagnostic connector illuminates permanently.
3) When I ride several meters, lights stop flashing. Bulb monitor light goes off and ABS light remains lighting (without flashing).
4) When i tried braking on gravel, where is easy to block wheel, I felt that ABS on rear wheel is working. I did not tried this with front wheel because I was not brave enough. Smile.
5) When I pressed ABS switch on dashboard, nothing changed with warning lights (ABS light on, bulb monitor off), but when I tried to lock rear wheel again I felt that ABS system did not work.
6) Finally I wanted to check, that my diagnostic method of ABS brain is correct, so i disconnect rear sensor and after turning the ignition, I've seen four flashes of diagnostic led in the pin 2. of ABS diagnostic connector. So this ensured me, that ABS brain send me correct diagnostic pulses. After the reset of the unit, I've got the zero code again - no blinking, just continous light.

So, briefly:
- I'm pretty sure, that ABS system is working at least for rear wheel.
- ABS brain do not send me any fault code.
- ABS red warning light iluminates permanently during ride.

It will be very helpful for me to have a complete wiring diagram of K100RS ABS, because I've feeling that my ABS system is working, but problem is somewhere in the relays.
I think my bulb monitor unit is somehow ill. When I unplug both rear lamps, the bulb monitor light is not illuminate and this apply for the case, when ABS brain in connected to the bike as well as case when ABS brain is disconnected.

So can broken bulb monitor unit cause this behavior of ABS warning light? Or is there still a problem with ABS system?

What do you think? Regards Milan.

    

2Back to top Go down    Re: ABS issue on K100 RS SE on Sun Feb 21, 2016 12:12 pm

Chocolate

avatar
Life time member
Life time member
It doesn't matter if you THINK the ABS is working, the light must of and every working perfect.

Because! Either you brake with ABS or NOT, not being sure is dangerous!!!

Maybe this video can help.
BMW Service - Clearing a fault from BMW ABS I & ABS II systems


Link:
http://www.largiader.com/abs/absfault.html

Link:
http://bmwk10075abs1fix.web.fc2.com

Link:
http://www.motobrick.com/index.php?topic=538.0

Cheers

A CORRECT reset solves in 90% the problem
If the ABS Box in the tail section behind the seat is faulty, a good way to check is to find a other good working ABS bike with the same ABS 1 (1.5 or 2.5!!! writen on the box) put YOU ABS into well known bike and test, do not put the good working ABS Box into you bike, otherwise you'll have two bikes with a issue!!!


__________________________________________________
Only a few activities make me experience my senses in a way motorcycle riding does, it is like swimming in the nude in a river.
K75 BA/1992 ABS, K75 BA/1991 noABS, Ducati, Mobylette M1/1973
Pictures:Me my bike and I
    

3Back to top Go down    Re: ABS issue on K100 RS SE on Sun Feb 21, 2016 12:30 pm

duck

avatar
Life time member
Life time member
If your ABS is in fault mode then the ABS lamp should be flashing, not solid.

All the ABS switch will do when riding is keep the ABS lamp from flashing for a couple of minutes so it is not as annoying.

The ABS lamp is powered by a Green/Yellow wire from the ABS warning relay and has nothing to do with the BMU.

Sounds to me like you may have a bad warning relay.

Here's the K75/K100 ABS manual:
http://www.kbikeparts.com/classickbikes.com/ckb.tech/0.ckb.tech.files/Manuals/BMW%20K75K100%20ABS%20Manual%20scanned.pdf


__________________________________________________
Current stable:
86 Custom K100 (K75C fairing, K75 Belly pan, Ceramic chromed engine covers, 32/10 final drive)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
93 K1100RS
94 K1100RS
93 K1100LT
91 K1
93 K75S
http://www.ClassicKBikes.com
    

4Back to top Go down    Re: ABS issue on K100 RS SE on Sun Feb 21, 2016 1:22 pm

yetti.86

avatar
active member
active member
Thank you guys.

I've the same manual for ABS bike. I'm looking for wiring diagram for the ABS version.
So again. I think, reset was successful, or I don't know how to recognize "CORRECT reset". At the beginning of my work, my ABS brain gave me a fault no 7 and it was impossible to reset it. After resetting procedure, it gave me again 7. Then I've charged my battery properly, because the battery has 12.2V - probably because bike wasn't run from november.
With charged battery, it was possible to reset brain so I got no fault from it. To ensure, that brain is "OK", I tried to disconnect something, so I disconnect rear sensor and I've got fault 4. After restart procedure, ABS brain got me no fault again. So I think, that basically the brain seems to be OK, because I can reset it, and it can recognize a fault.

And about the relays. As I know, the ABS warning relay is the "simple" relay with one contact and one solenoid. The same relay is used for horn and fan. When I unplug the ABS warning relay there is no flashing light. Neither ABS or bulb monitor light. When i plug the relay back, I can hear the clicking and lights are flashing. I've tried to swap this one for fan or horn as well as I've measured the selenoid and contact of the relay and they are ok.

The piece to the puzzle which I don't know is "How is ABS warning relay connect to BMU". I suspect that malfunction of BMU can cause (for example) grounding (or connecting) the solenoid of ABS warning switch which results in continuous lighting of ABS light.

Hope I explain my thoughts correctly. Regards Milan.

    

5Back to top Go down    Re: ABS issue on K100 RS SE on Sun Feb 21, 2016 1:37 pm

Inge K.

avatar
VIP
VIP
mprihoda wrote:
And about the relays. As I know, the ABS warning relay is the "simple" relay with one contact and one solenoid. The same relay is used for horn and fan.

If you have the same relay as the one for horn, LSR etc. in the ABS warning relay socket...then this is the reason to your problem.
The ABS warning relay is a NC relay, the others is NO relays.
Also the ABS warning relay has a blue housing, the others is black.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

6Back to top Go down    Re: ABS issue on K100 RS SE on Sun Feb 21, 2016 1:46 pm

duck

avatar
Life time member
Life time member
The ABS system has two relays, one "normal" relay and a blue ABS-specific relay.

Here's an English labeled wiring diagram for an ABS K75. The ABS is identical to that on a K100. (This is a BMW wiring diagram, not third party.)

http://www.kbikeparts.com/classickbikes.com/ckb.tech/0.ckb.tech.files/kwiring/90onK75/k75abs_wiring.slp.bmp


__________________________________________________
Current stable:
86 Custom K100 (K75C fairing, K75 Belly pan, Ceramic chromed engine covers, 32/10 final drive)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
93 K1100RS
94 K1100RS
93 K1100LT
91 K1
93 K75S
http://www.ClassicKBikes.com
    

7Back to top Go down    Re: ABS issue on K100 RS SE on Sun Feb 21, 2016 5:08 pm

yetti.86

avatar
active member
active member
@Inge K. wrote:
mprihoda wrote:
And about the relays. As I know, the ABS warning relay is the "simple" relay with one contact and one solenoid. The same relay is used for horn and fan.

If you have the same relay as the one for horn, LSR etc. in the ABS warning relay socket...then this is the reason to your problem.
The ABS warning relay is a NC relay, the others is NO relays.
Also the ABS warning relay has a blue housing, the others is black.

Hi.
Excellent answer. According to ABS wiring diagram it seems you're right. It's NC relay. That is the point!

Thank you very much.

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum