BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


Motorbike Mike

avatar
Life time member
Life time member
Hello chaps,
Some of you will know already that I have a JJ Cobas replica. Last year it had an 8 valve 1000cc engine but it wasn't quite enough and cooling was marginal/ inadequate with only 90 BHP at the rear wheel.
For this year I wanted more but couldn't find a k1200 motor so I settled on an 1100 and breathed on it! The head has been skimmed for more compression, 1200RS cams, ports looked at with some internal lightening and other (secret) modifications.
Now, as the 1000 had trouble cooling I needed to improve that department but in order to keep the look of the copied bike I can't get a larger radiator inside the fairing so additional oil cooling seemed to be the way to go but, the 1200 oil/water pump doesn't go straight on to the earlier motor so my question is, has anyone managed to get the 1200 part onto an earlier K block and if so, would you share the solution?






It's just not enough!

Mike.

    

Motorbike Mike

avatar
Life time member
Life time member
I've discovered the issue.
There is a small intermediate drive shaft that goes from the end of the output shaft into the pump assembly. It's not shown on any diagrams I've seen but that's the part that had me troubled. When you pull the pump off the front of the motor (I'm told) the small shaft often stays with the output shaft as it has an O ring on the end and because you can't see that it's a separate part, it often gets left with the main block.



The shaft drives this 19t gear.
Does anyone have spare please?

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum