BMW K bikes (Bricks)


You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Light telltale malfunction? on Wed Mar 30, 2016 3:59 pm

Bikesmith

avatar
Silver member
Silver member
Hi everyone!
Thank you all so much for your help with all of the issues on my 1985 K100rs.

Here's the new issue: The rider's manual says that when I turn on the ignition and test both brakes the rear light telltale should start flashing. But mine just turns off. The manual says that indicates a fault, but all the lights are working perfectly. Is there something I'm missing? The manual is for a 94 and my bike is an 85. Does the telltale on an 85 work differently than a 94? Is there a problem with my bulb monitoring unit? If so, should I even care if all of the lights are working correctly?

Thanks!


__________________________________________________
Jon
Mechanically competent, electrically idiotic
------------------------------------
1985 BMW K100rs
1940 Royal Enfield WD/CO
1968 Honda CL125
    

2Back to top Go down    Re: Light telltale malfunction? on Wed Mar 30, 2016 4:09 pm

92KK 84WW Olaf

avatar
Life time member
Life time member
85 bike won't flash. The flashing was for Ks with ABS and that's not on yours.The red lightcomes on when you turn on the ignition but does not flash.

The red light goes out after touching the rear and the front brake. If it doesn't go out then a dodgy rear bulb. If it still doesn't go out it's likely to mean dodgy front or rear brake switch.If it stays on like thatyou will see the brake light only comes on for one and not the other.

Worth getting the right riders manual as they do differ significantly.


__________________________________________________
1992 K100LT 0193214 101,000 miles
1984 K100RT 0022575 Baja Red bought 36,000 now 89,150 miles
1997 K1100LT 58,645 now 60,500miles
    

3Back to top Go down    Re: Light telltale malfunction? on Wed Mar 30, 2016 4:10 pm

Avenger GT

avatar
Life time member
Life time member
Nope, that's normal for a 85 bike. The flashy light caper is for later bikes with ABS.

    

4Back to top Go down    Re: Light telltale malfunction? on Wed Mar 30, 2016 4:16 pm

Bikesmith

avatar
Silver member
Silver member
Cool! Thanks guys! One more item crossed off the list. I may actually get to ride this bike someday!


__________________________________________________
Jon
Mechanically competent, electrically idiotic
------------------------------------
1985 BMW K100rs
1940 Royal Enfield WD/CO
1968 Honda CL125
    

Sponsored content


    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum