BMW K bikes (Bricks)


You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Horn problems...... KIS on Tue Aug 23, 2016 11:04 pm

Crazy Frog

avatar
admin
admin
Yes, Keep It Simple!

My K100rt developed all the symptoms of having a bad angina or man flue (Yes Klompy...)
The 2 horns barely worked anymore.
First thing that I did was to open the left handlebar switch and generously sprayed a good squirt of Deoxit with no result. I then changed the horn relay with no more success. I was ready to remove the tank and start to check the ground and maybe overall the starter. However, the original test was giving me a full 12V at the horn connections.
I then plugged back the first horn and it was still barely vibrating. I unplugged it and plugged the second one and.... success! I got as loud Beeeeppp.
One bad horn was sucking all the power and the second one wouldn't work.

cheers


__________________________________________________
1986 k75, 1985 K100rt, 1985 K100rt/EML sidecar.
    

2Back to top Go down    Re: Horn problems...... KIS on Tue Aug 23, 2016 11:07 pm

duck

avatar
Life time member
Life time member
FYI: You can find the exact same FIAMM horns brand new from auto parts retailers - without The Fatherland's markup.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum