BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Fuel pump issues K100 RS on Tue Sep 13, 2016 4:30 am

andyldean

avatar
Silver member
Silver member
Recently purchased a k100 Rs which had been a none runner for the last few years.

Traced the problem to the fuel pump not receiving power from the relay.

added and additional wire from the rear of the relay direct to the pump and the bike runs and all is great. so I decided to renew the wire and rewrap the loom.

Only to discover that the wire in question runs to the back of the clocks and not direct to the relay as indicated in my wiring diagram.

What signal does the instrument panel send to the fuel pump to initiate start?

Its no good rewiring the fuel pump to the back of the relay when the signal sent by the clocks is the problem.

Does anyone have a wiring diagram that may help?

Could it be anything to do with the abs ? Thanks in advance.


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

2Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:30 am

duck

avatar
Life time member
Life time member
On a 4V K100RS the fuel pump relay is triggered by a ground signal to the blue/brown wire from the Motronic.

(Assuming the side stand is up and that switch is working. 12V+ to the fuel pump relay on the green/red wire.)


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

3Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:32 am

duck

avatar
Life time member
Life time member
Another possible cause of the fuel pump not getting power is a flaky connector for the fuel level sender.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

4Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:35 am

andyldean

avatar
Silver member
Silver member
the fuel level sender could be an issue as the tank was left for a long time with bad fuel in it.
The inside of teh tank is reasonably crapped up.


Is there a way to bypass this fuel level sender?


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

5Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:36 am

andyldean

avatar
Silver member
Silver member
the feed to the relay looks good its the output which looks like its at fault.


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

6Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:39 am

duck

avatar
Life time member
Life time member
andyldean wrote:Is there a way to bypass this fuel level sender?

You can run wires directly to the fuel pump through the gas cap. I had a guy come by my house once who had done that. Crude but it did work.

(The smaller terminal on the fuel pump is 12V+, the larger terminal is ground.)


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

7Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:42 am

duck

avatar
Life time member
Life time member


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

8Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:45 am

andyldean

avatar
Silver member
Silver member
no its not the tank connector its definetly at the instruments.
Does anyone have a pinout diagram for the fuel tank connector?


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

9Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:54 am

andyldean

avatar
Silver member
Silver member
the wire that feeds the pump from the connector under the tank is yellow and white.
this runs to the back of the instrument panel to the pin which looks like its labeled gear position indicator. also yellow and white.
cant see why none of this is illustrated on the wiring diagram.
It makes it hard to work around.


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

10Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 5:54 am

duck

avatar
Life time member
Life time member
FLS connector:
---------------------
Brown - ground
Green/white - fuel pump 12V+
White - to low fuel lamp in instrument cluster
Yellow - to fuel gauge


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

11Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 6:00 am

duck

avatar
Life time member
Life time member
andyldean wrote:the wire that feeds the pump from the connector under the tank is yellow and white.
this runs to the back of the instrument panel to the pin which looks like its labeled gear position indicator. also yellow and white.
cant see why none of this is illustrated on the wiring diagram.
It makes it hard to work around.

The fuel pump has nothing to do with the instrument cluster.

The only wire from the FLS to the cluster is a white wire for the low fuel lamp.

There are three wires for the GPI in the cluster:
yellow/white
yellow/black
yellow/blue
Those all come from the gear position switch on the back of the transmission.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

12Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 6:03 am

andyldean

avatar
Silver member
Silver member
very strange because the output from the relay has no continuity o any pin on the fuel tank connector


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

13Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 6:20 am

andyldean

avatar
Silver member
Silver member
Solved. The previous owner when trying to get it running must have mixed the two connectors around.
The tank connector was plugged into the gpi.
You made me think with the wire colours and I have just checked.

I thought it was odd when I took the tank off my rt and the connector pins disn't fit neatly.
Thanks again.


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

14Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 6:22 am

duck

avatar
Life time member
Life time member
The green/white wire from the 87 pin on the fuel pump relay goes to the FLS connector in order to power the fuel pump.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

15Back to top Go down    Re: Fuel pump issues K100 RS on Tue Sep 13, 2016 6:36 am

andyldean

avatar
Silver member
Silver member
yes all good now.
Its great being able to bounce ideas around on a forum.
As soon as you gave me the colours for the GPI my light bulb lit and I disapered into the shed with my multi meter. :-)


__________________________________________________
1987 K100RT (cafe racer)
1991 K100RS (soon to be my sons cafe racer)
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum