BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Speedo nonsense, on Tue Mar 21, 2017 3:52 pm

Johnser

avatar
Silver member
Silver member
Further to my speedometer woes, the speed reading is now behaving stupidly.

It has stopped working altogether while riding a couple times and read a bit erratically once or twice too.

So I've just tried cleaning the connection by the brake reservoir and the tip of the gearbox sensor.

Not road tested but it's now worse if anything. It is quite slow to respond to speed changes (bike running on centrestand) and if you pull the clutch and stop the back wheel, sometimes the Speedo creeps on up to about 40mph?!

I don't think it's the connection by the brake reservoir that I've checked, it is in great condition, i cleaned it up anyway. So I'm led back to the Speedo again or possibly the gearbox sensor.

Any ideas which? Or indeed anything else??

    

2Back to top Go down    Re: Speedo nonsense, on Tue Mar 21, 2017 6:08 pm

Crazy Frog

avatar
admin
admin
Could it be the speedo sensor on the FD?
Best way to check the speedo functionality is to use the Karamba software. It can be downloaded from the download page.


__________________________________________________
1986 k75, 1985 K100rt, 1985 K100rt/EML sidecar.
    

3Back to top Go down    Re: Speedo nonsense, on Tue Mar 21, 2017 6:11 pm

Johnser

avatar
Silver member
Silver member
Thanks, I'll check that out. I've narrowed it back down to the Speedo unit. Dismantled and with wires wiggled it will cut in and out. Resoldering the pin sockets may have helped but I won't be sure until i go for another ride.

    

4Back to top Go down    Re: Speedo nonsense, on Fri Apr 07, 2017 5:14 pm

Johnser

avatar
Silver member
Silver member
Sorted. Bought a replacement Speedo. The Speedo came back to life on the original when going around a nice corner anyway but it now all works as it ought to including the wavy rev counter. I even managed to diddle the odometer to within 100miles of the old one and I now have a clock.

New Speedo cam with a hefty aluminium bracket - from a k75?? The complete thing weighed over 2kg!!

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum