BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Battery keeps dying on me on Mon Sep 25, 2017 12:51 am

AndrewP

avatar
active member
active member
I have nearly completed my K100 project and had some hair tearing days and some awesome wins and learn't a great deal. A lot of electrical tips and some hardware have come from Robmack and I have to say Rob you have been so helpful and without it I reckon I would have rolled the bike to the nearest wrecker. Bike runs great, starts great and everything works as it should ( well almost all ) but I have this problem of the battery either being drained by a poor connection/earth ? , dying battery ( 3 and a half years old ) not holding a charge anymore ?
OR as another K100 rider suggested to me that there is a charging pin ? that needs to produce resistance for the alternator to charge the battery ? I would like to point out the battery starts the bike very easily and it takes a couple of rides before it eventually dies. Any help would be great. Andrew P

    

2Back to top Go down    Re: Battery keeps dying on me on Mon Sep 25, 2017 2:10 am

MartinW

avatar
Life time member
Life time member
Your on the right track apparently when removing the OEM cluster there is something that has to be done to keep the charging circuit functional. Somebody will have the answer, if I find it I'll post it.
Regards Martin.

    

3Back to top Go down    Re: Battery keeps dying on me on Mon Sep 25, 2017 3:57 am

charlie99

avatar
VIP
VIP
there is supposed to be a 3 watt globe ...off a switched positive wire ..that is in series with the alternator field wire (for want of a better term )

this excites the regulator and then the rotor , and also provides a voltage reference .
the rotor requires current (regulated by the regulator , who woulda thought ?!!)to generate a field that the statorabsorbs ,then rectifies back to dc

without the globe ...(or a good alternative ) the reference voltage is all over the place ..meaning it can be lower or higher voltage out of the alternator depending on loads and such .

the rotordoes carry a little bit of magnetism , and so will generate some voltage to the statorfor it to rectify as the revs build up ...but this is by no means adequate for a good charge or voltage reference

keep in mind that the regulator is basically a difference amplifier with a known (specified) top range reference of the battery and the charge out of the alternator .
so as the voltage of the reference approaches the charge voltage the regulator backs off the current through the rotor to maintain the voltage output ....look at your regulator it has a voltage stamped on it .

best advice ...install a small globe ...somewhere (seen or not ) in the field wire (blue ) to the alternator ,which is switched with the key .

if it is unswitched, it will drain the battery .

good luck hope this helps


when are going to show us your efforts ??


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

4Back to top Go down    Re: Battery keeps dying on me on Tue Sep 26, 2017 8:04 pm

AndrewP

avatar
active member
active member
Cheers Charlie99,

My electrical knowledge is very basic, robmack can attest to that Smile

Could you explain it in very very basic terms ? a simple drawing even ? Laughing

I don't even know what a globe is ??

Will do up a little photo diary in the cafe section soon to detail the highs and low's Laughing Laughing Laughing

    

5Back to top Go down    Re: Battery keeps dying on me on Wed Sep 27, 2017 12:08 am

bmwpyro

avatar
active member
active member
I could be wrong but I believe a globe is also known as a bulb...

    

6Back to top Go down    Re: Battery keeps dying on me on Wed Sep 27, 2017 3:34 am

charlie99

avatar
VIP
VIP
bulb - globe ...same thing just different terminology

ill do up a simple diagram for you Andrew

bit tired right now, after a huge day again (started at 3.30 am this morning ) yeah I know, insomniac heaven))

bit later huh ?


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

7Back to top Go down    Re: Battery keeps dying on me on Wed Sep 27, 2017 2:27 pm

charlie99

avatar
VIP
VIP
hopefully this might help

so I guess you have cut the wiring loom connector to the instruments to fit after market stuff ?

the green black wire is the switched positive (12 volt)

the blue wire is the alternator charge indicator

we are going to install a globe between these 2 wires
part numbers are on the diagram

should be able to get them from repco

soldered connections are always the best insulated with heat shrink or
crimp connectors




does this help ?


likely a good idea to place the globe somewhere where it wont get broken ...but able to be seen periodically when looking for it ?
perhaps cable tie the globe holder to some part of the loom
even perhaps put the globe in a small glass pill bottle to protect it and a bit of silicon to hold it all together at the top ( the globe should last for years and years if protected from too much vibration and impacts ) under the tank ?


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

8Back to top Go down    Re: Battery keeps dying on me on Thu Sep 28, 2017 2:26 am

club_c

avatar
Life time member
Life time member
You're a good man charlie99...


__________________________________________________
"There's never enough time to do it right, but there's always time to do it over."

1988 K100RS SE VIN 01477554
    

9Back to top Go down    Re: Battery keeps dying on me on Sat Sep 30, 2017 1:33 am

AndrewP

avatar
active member
active member
@charlie99 wrote:hopefully this might help

so I guess you have cut the wiring loom connector to the instruments to fit after market stuff ?

the green black wire is the switched positive (12 volt)

the blue wire is the alternator charge indicator

we are going to install a globe between these 2 wires
part numbers are on the diagram

should be able to get them from repco

soldered connections are always the best insulated with heat shrink or
crimp connectors




does this help ?


likely a good idea to place the globe somewhere where it wont get broken ...but able to be seen periodically when looking for it ?
perhaps cable tie the globe holder to some part of the loom
even perhaps put the globe in a small glass pill bottle to protect it and a bit of silicon to hold it all together at the top ( the globe should last for years and years if protected from too much vibration and impacts ) under the tank ?
Awesome, thank you Charlie99, sorry not responded sooner, been out riding round the hills of the Sunshine coast for a couple of days. Will go to repco or the like and get parts and give it a go, looks reasonably easy when I get a diagram Laughing Laughing Laughing will let you know how I go.

    

10Back to top Go down    Re: Battery keeps dying on me on Sat Sep 30, 2017 2:39 am

charlie99

avatar
VIP
VIP


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

11Back to top Go down    Re: Battery keeps dying on me on Wed Oct 04, 2017 2:01 am

AndrewP

avatar
active member
active member
Hi Charlie99,

Got the 3 watt bulb and holder and located the blue alternator charging wire,

Question: I have the black/green wire powering the Start enable card ( Robmack ) and the power to the Acewell 2853, is it ok to spur off for the 3 watt bulb too ?

Andrew P

    

12Back to top Go down    Re: Battery keeps dying on me on Wed Oct 04, 2017 3:37 am

charlie99

avatar
VIP
VIP
why not Andrew ...?

its only going to draw 250 milli amp (0.25 amps and decreases as charge happens ) , I think robs selector logic only draws less than 50-100 milli amps (0.1 amp )if there is relay outputs else far less

no problem as far as I see

good luck


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

13Back to top Go down    Re: Battery keeps dying on me on Sat Oct 07, 2017 1:24 am

AndrewP

avatar
active member
active member
Hi Charlie99,

All good, bulb illuminates when ignition switched on and turns off as she fires up, will take her for a run and hope she starts up again Laughing

    

14Back to top Go down    Re: Battery keeps dying on me on Sat Oct 07, 2017 3:57 am

charlie99

avatar
VIP
VIP
good luck

don't forget that lead acid type batteries ,,,require a good charge over many hours ....typically 6 or more hours

so if you have a medium to low side (say 4 amp charger ) a good 8 hours is what I would recommend

would be very pleased to hear if you can restart after a run , without issues

having just re- read your initial post ..I wouldn't be surprised if the battery is on its last legs being 3.5 years old

but I have found that a good charge cycle is a good thing ...but wont recondition the battery to the "new" capability ..


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

15Back to top Go down    Re: Battery keeps dying on me on Mon Oct 09, 2017 2:26 am

AndrewP

avatar
active member
active member
Hi Charlie99,

Worked a treat, I did put on a new battery to accompany the wiring mod to give myself a good start and yes did a few trips and started and restarted the bike at different intervals and no problem whatsoever.

Interesting that having a strong battery with good clean connections and being charged makes such a difference to the cleaner running of a bike.

Previously without the wiring mod the battery would be depleted but also a lot of popping through the exhaust which all but cleared up with the wiring mod and the new battery Smile

Thank you , onto the next bike. Laughing

    

16Back to top Go down    Re: Battery keeps dying on me on Mon Oct 09, 2017 5:17 am

charlie99

avatar
VIP
VIP
good point Andrew .

I have also noticed this ...with a weak battery ..popping farting and generally shit ooops

poor performance

ride well mate ..looks like your off to a flying start ???


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum