BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Beam light indicator permanently ON on Wed May 30, 2018 5:51 pm

ERasberg

avatar
Silver member
Silver member
Hi gurus,

having researched the topic without finding a similar case, I call upon your wisdom.

Home from work Friday, the beam light indicator (the blue light on the dashboard) suddenly came on and has stayed on since.
Switching on/off the beam lights makes no difference to the blue indicator, which stays on.
It does "focus" the beam when switching from "on" position vs "beam" position, however, doesn't really increase the intensity of the light much.

Did i pop a fuse or a light bulb ? Does the indicator light serve as a troubleshooting indicator as well ? (i don't find any such info in the manual)

I did a contact cleaning campaign (very successfully) 5 months ago just after buying the bike, when she was suffering from several gremlins (linked to speedo+odometer mainly). But since, all has been good....until now. I therefore don't immediately suspect contacts, but I did not undo the dashboard so there are still a few contacts I didn't clean yet.

Weather has been dry, but I did wash the bike with water/sponge (no pressure hose) a week prior to this.

Any input would be highly appreciated.


__________________________________________________
1988 K100 RS SE
97,000 km
VIN# 0146971K100RS
    

2Back to top Go down    Re: Beam light indicator permanently ON on Wed May 30, 2018 6:45 pm

robmack

avatar
Life time member
Life time member
There is a connection being made (possibly) between White and White/Yellow in the left hand switch cluster. There may be a stray wire inside the switch cluster shorting across those two contacts.

Q: Does the headlight and blue indicator go out when you turn the key to On and the light switch on the right hand switch cluster to the first position?

Q: With the key in On mode and the light switch on the right hand switch cluster to the first position, does the High beam and the blue indicator turn on when you press the Flash button on the left hand switch cluster (i.e. press the bottom of the Yellow high beam switch)?


__________________________________________________
Robert
1987 K75 @k75retro.blogspot.ca
2011 Moto Guzzi V7 Racer
http://k75retro.blogspot.ca/
    

3Back to top Go down    Re: Beam light indicator permanently ON on Wed May 30, 2018 7:10 pm

ERasberg

avatar
Silver member
Silver member
Hi Robmack,

Thank you for the quick response and for pointing to a potential short!

I will do the tests as per your instructions tomorrow morning (CET) and get back to you after work, as answering from memory is not going to be exhaustive nor accurate.

I didn't try the options you mentioned, especially with the parking light on and trying to flash the beam.

Best regards,
Einar.


__________________________________________________
1988 K100 RS SE
97,000 km
VIN# 0146971K100RS
    

4Back to top Go down    Re: Beam light indicator permanently ON on Wed May 30, 2018 7:26 pm

JR_K100RS

avatar
Life time member
Life time member
I think Robmack is on the right track , same thing happened to me , ended up being a a run of solder between two wire terminations , probably heated up the wiring from running with the headlight on all the time

John Re

Melbourne Australia


__________________________________________________
Diamond Grey ( 617 ) 1987 K100RS ( European Delivery ) Original owner
    

5Back to top Go down    Re: Beam light indicator permanently ON on Wed May 30, 2018 7:46 pm

ERasberg

avatar
Silver member
Silver member
John, thanks for sharing. sounds like this might be it.
I'll do the tests tomorrow, then looks like I have some work to do over the weekend.

I should be able to test for continuity between the two wires from the switch cluster plug.

E/


__________________________________________________
1988 K100 RS SE
97,000 km
VIN# 0146971K100RS
    

6Back to top Go down    Re: Beam light indicator permanently ON on Thu May 31, 2018 9:07 pm

ERasberg

avatar
Silver member
Silver member
@robmack wrote:There is a connection being made (possibly) between White and White/Yellow in the left hand switch cluster. There may be a stray wire inside the switch cluster shorting across those two contacts.

Q: Does the headlight and blue indicator go out when you turn the key to On and the light switch on the right hand switch cluster to the first position?

Q: With the key in On mode and the light switch on the right hand switch cluster to the first position, does the High beam and the blue indicator turn on when you press the Flash button on the left hand switch cluster (i.e. press the bottom of the Yellow high beam switch)?

@robmac

Question 1: yes
Question 2: yes, but only when pushing the flash button. In "permanent" mode no response.

What would be the next step in order to troubleshoot the problem ?


__________________________________________________
1988 K100 RS SE
97,000 km
VIN# 0146971K100RS
    

7Back to top Go down    Re: Beam light indicator permanently ON on Thu May 31, 2018 11:01 pm

robmack

avatar
Life time member
Life time member
So, those two tests verifies that the light controls on the right hand switch cluster are working properly, so the problem is most likely in the left hand switch cluster or its wiring. Do a thorough visual check of the switch cluster and its plug for obvious problems. Also disassemble the switch if you feel brave enough to check for something that might be shorting inside.

The source of power for both the dip and high beams is supplied by White/Yellow when the ignition is ON and the right hand light switch also ON. Since you have both dip and high beams illuminated simultaneously in the normal lefthand switch position, that indicates a problem in the lefthand switch cluster.



Last edited by robmack on Fri Jun 01, 2018 9:39 pm; edited 1 time in total


__________________________________________________
Robert
1987 K75 @k75retro.blogspot.ca
2011 Moto Guzzi V7 Racer
http://k75retro.blogspot.ca/
    

8Back to top Go down    Re: Beam light indicator permanently ON on Thu May 31, 2018 11:36 pm

duck

avatar
Life time member
Life time member
If you take the switch apart you're better off taking it off of the bike and working on it on a workbench. There are little screws and springs to lose.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

9Back to top Go down    Re: Beam light indicator permanently ON on Fri Jun 01, 2018 7:12 pm

Stumpy

avatar
active member
active member
Does the light go out when you turn the steering to right lock? Mine does this sometimes, my left switch has been hacked and a toggle switch added for high low flasher.

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum