BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


resepti

avatar
active member
active member
Hey everyone! Firstly Iīm new here and also new with K-bikes. I tried to find an answer from google and from this forum but couldnīt find so this is it. I have been driving my new 87 K100lt bike for about a month and roughly 1300km. Bike runs fine and everything sound great but there has been several times when Iīm turned my bike off fuel pump keeps going. First time I thought the sound was from radiator or something so I left my bike there and went home. Next morning battery was dead and that noise was obviously gone.

I bought a new battery and went for a long weekend trip. On that trip I realized that sound was coming from fuel pump. If I shut down the bike, pump keeps going. If I start up bike again and shut it down again, pump keeps going. I have been unskrewing battery ground to shut down that pump. And when I connect that battery ground again the pump starts immediately. And yeah itīs really annoying because you canīt never tell when this will happen. You could ride a week without any problems and then it happens three day in a row etc.

I think that the fuel pump keeps going if I donīt have like enough gas. I have been trying to keep my gasoline level really high and maybe this has helped. But then again I might be really wrong about this one. As I said earlier Iīm really new to this bike so I havenīt had enough time to open to see what kind of a mess those electronics are under the tank and a seat. So I have changed my battery and I also checked battery positive and ground for good contact.

So what to do? What to check first? Diods, relays, wiring, new fuel pump?



Last edited by resepti on Sat Aug 25, 2018 4:47 am; edited 1 time in total

    

D'Ecosse

avatar
active member
active member
Sounds like Fuel Injection Relay stuck
Give it a whack and see if it drops off (which will confirm the issue) - even if it does, you should replace it

    

resepti

avatar
active member
active member
I have been hitting that tank with no luck haha. Injection relay sounds about right! Seems to be easy and cheap fix. I will order right part tomorrow! Thanks!

Sent from Topic'it App

    

D'Ecosse

avatar
active member
active member
I meant to tap on the Relay - it is the one that front/left side of the box

It might be welded shut though and won't drop off - especially if it comes back on right away after you disconnect/reconnect your battery

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum