BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    K100rs 16v won't start on Tue Nov 20, 2018 4:50 pm

Dympo

avatar
active member
active member
Hi everyone,

I come here for a little help from you all..

Hey everyone.

I own a 1990 K100rs 16v (ABS, Motronic 2.1, European).

The other day, as I was going to work, the bike suddenly slowed down and eventually couldn't start again. Ignition would start, but there wouldn't be enough power to move anymore, until it stalled completely.

So back to the house, I opened it up and check the spark plugs. They were used but okay, but with a little test it showed that only 2 of them were working and giving a spark.

I got some hints from the web that the issue was coming from the HES. I changed both sensors, and though I now have 4 sparks (and the old sensors were working, having tested them), I still have the same issue..

Here is where I am after working on it for the whole weekend :

- Checked Hall Sensors + all the cables to Motronic box: everything OK
- Diagnosed Motronic box (2.1) : I get signal 1-1-3-3 which is the lower hall sensor, even though it is working.
- Checked all spark plugs : 4 sparks + they get wet
- Checked every fuse
- Checked all injectors : work indivudually, get proper electric signals
- Checked injectors+ramp with ignition : get 4 nice squirts of fuel

Still same symptoms : ignition works but coughs and blurts, air sounds + a tiny bit of smelly white smoke every now and then coming from somewhere around the injectors (?).

I am thinking : hall captors (so, timing) are OK until Motronic. Injection is OK. So sparks are supposedly happening at the right time, and fuel too. Could there be a problem coming from the air? Too much or not enough air going to the cylinders making the explosion impossible? Is there any sensor linked to this that could be the cause?

Or can the Motronic unit itself be the cause of my problems?

Ideas and explanations highly appreciated, as I am completely stuck now!!!

    

2Back to top Go down    Re: K100rs 16v won't start on Tue Nov 20, 2018 5:14 pm

Point-Seven-five

avatar
Life time member
Life time member
I think you could be on to something with the air flow into the cylinders.  The air signal for the mixture is from the throttle position sensor at the rear end of the throttle bodies.  Unlike the unit used with the Jetronic this one does not have on/off switches but is a potentiometer that reflects throttle opening. 

There is a procedure for setting and checking the closed position signal from the sensor.  If you have the fault code instructions, this test should be with them.  If I recall, it involves grounding a pin on the diagnostic plug and opening and closing the throttle while watching the temperature light on the instrument cluster.

It is also possible that something is causing the mixture to be too rich and flooding the engine.  If this is the case, cranking for about 5-10 seconds with the tank connector unplugged will cause the engine to fire once or twice as the excess fuel is pumped out and the plugs dry off enough to spark,


__________________________________________________
Present:
1994 K75RT
1994 K75S
1992 K100RS

Past:
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

3Back to top Go down    Re: K100rs 16v won't start on Wed Nov 21, 2018 7:28 am

Ringfad

avatar
Life time member
Life time member
I had a similar issue on mine and it turned out to be the ignition switch. I was able to short out the ignition switch (removed the ignition switch plug from the loom and shorted the two pins togeter that provde ignition power). Bike started straight away.


__________________________________________________


   ;BMW; K100RS Style Black 1987 105K Km     ;BMW; K1 Black 1993 51K Km     ;BMW; K1100RS Red 1993 70k miles  ;BMW; K100 16V Black (ex ElectricMonk)
    

4Back to top Go down    Re: K100rs 16v won't start on Wed Nov 21, 2018 9:29 am

Laitch

avatar
Life time member
Life time member
How long have you owned the moto? How many kilometers are on the odometer? When was its last tuneup? What is the condition of the crankcase breather connected to the air box? What are the compression values for the cylinders?


__________________________________________________
1995 K75T 68,000 miles
    

5Back to top Go down    Re: K100rs 16v won't start on Thu Nov 22, 2018 12:14 pm

Dympo

avatar
active member
active member
I have owned it for about 3 years now, have been all the way to Indonesia with it!

Around 78000 kilometers on the odometer, was tuned up at ~45000 kms. 

The breather seems to be alright, no sign of a crack or anything.

I just ordered the tools to check compression, will post next weekend or sometime next week!

    

6Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 6:18 am

Dympo

avatar
active member
active member
Alright guys, I tested the compression this morning, as well as TPS.

TPS is fine and properly set.

Compression on the other hand, is very strange :

Cyl 1 : ~60 PSI
Cyl 2 : ~80 PSI
Cyl 3 : ~150 PSI
Cyl 4 : ~110 PSI

We're onto something here, but I don't know what.. The engine is still quite young, and I would find it very weird that the valve clearances just all got wrong at the same time..

What could be the issue here? 

Thanks

    

7Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 6:50 am

Laitch

avatar
Life time member
Life time member
@Dympo wrote:
Around 78000 kilometers on the odometer, was tuned up at ~45000 kms.

Cyl 1 : ~60 PSI
Cyl 2 : ~80 PSI
Cyl 3 : ~150 PSI
Cyl 4 : ~110 PSI
What could be the issue here? 
Can you verify that the valve clearances were checked a 45,000 km?

There are several conditions that can produce readings like those—damaged valves or valve seats, failing valve seals, among others. A head gasket leaking between adjacent cylinders can give readings like those on cylinders #1 and #2. A flawed testing technique could produce inconsistent results like these, too. Describe exactly how you performed the compression test and the type of equipment used.


__________________________________________________
1995 K75T 68,000 miles
    

8Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 7:09 am

Dympo

avatar
active member
active member
Hmm apparently it was not checked at 45'000.

As for the compression test :

- Removed all the spark plugs and unplugged the coils
- Unplugged the fuel pump relay to avoid too much fuel being injected in the cylinders
- Used a compression kit, plugged in the spark holes one by one, ran the starter a few times (3-4 impulses) with throttle fully open

    

9Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 7:12 am

duck

avatar
Life time member
Life time member
Take the fuel filter out and see if you can blow through it in the direction of the arrow.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

10Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 7:52 am

Laitch

avatar
Life time member
Life time member
@Dympo wrote:- Used a compression kit, plugged in the spark holes one by one, ran the starter a few times (3-4 impulses) with throttle fully open
Does the compression gauge screw into the cylinder or must it be pushed into the opening then held in position during cranking?


__________________________________________________
1995 K75T 68,000 miles
    

11Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 8:35 am

Dympo

avatar
active member
active member
@duck wrote:Take the fuel filter out and see if you can blow through it in the direction of the arrow.

Will try next time I work on it. What's the thought behind it?

Does the compression gauge screw into the cylinder or must it be pushed into the opening then held in position during cranking?

It screws into the cylinders, same size as a spark plug so no loss of air here

    

12Back to top Go down    K100rs 16v won't start on Sun Dec 02, 2018 9:42 am

norton71

avatar
Silver member
Silver member
do a wet and dry compression test

    

13Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 9:51 am

Laitch

avatar
Life time member
Life time member
@Dympo wrote:It screws into the cylinders, same size as a spark plug so no loss of air here
Ok.

Right now, as norton71 indicates, you could repeat the compression test using a spray of oil in the cylinders to determine if piston rings are involved in these low numbers. You could check the valve clearances of C1 and C2. Tight exhaust clearances might indicate failing valve components are contributors to this problem. You could do a leakdown test attempting to locate the source of the problem.

Because it happened suddenly, because the compression is similarly low in adjacent cylinders compared with the others, and because difficulty in starting followed, I'm tending to believe a head gasket breach is causing this. That would be the most benign cylinder head condition to repair in terms of cost and labor. To my knowledge, it isn't a common failure in K engines.

Have you ever flushed the coolant system and replaced coolant? Have you had the temperature warning indicator glow intermittently during your travels or recently?


__________________________________________________
1995 K75T 68,000 miles
    

14Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 10:12 am

Dympo

avatar
active member
active member
Thanks for your insight, Laitch. I will try and check the valve clearances next week if I can... And try the spray of oil too.

What do you call a leakdown test? 

I have flushed and replaced coolant a couple of years ago when I changed the radiator, and never had the temperature warning indicator flash.

I've also had ABS issues for a long time now, light keeps flashing, but I don't think those issues are related : being running with ABS light on for at least 20000 kms now.

    

15Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 10:19 am

Laitch

avatar
Life time member
Life time member
@Dympo wrote:What do you call a leakdown test? 
This article was the first hit in a Google search for leakdown test. It sums up the procedure and its intent.


__________________________________________________
1995 K75T 68,000 miles
    

16Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 3:30 pm

MartinW

avatar
Life time member
Life time member
It is very important that you earth the spark plug leads while doing the compression test. Failure to do so can lead to damaging the ECU.
Regards Martin.


__________________________________________________
K75s Hybrid
    

17Back to top Go down    Re: K100rs 16v won't start on Sun Dec 02, 2018 6:14 pm

duck

avatar
Life time member
Life time member
@Dympo wrote:
@duck wrote:Take the fuel filter out and see if you can blow through it in the direction of the arrow.

Will try next time I work on it. What's the thought behind it?


The thought is that it's hard for a motor to run well if it's not getting enough fuel.

I can't tell you how many people I've come across who tear their hair out over a K not running well and then when I tell them to check and/or replace the fuel filter that clears everything up.

And since it's so easy to check it's a good diagnostic starting point for an engine that's not running well.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

18Back to top Go down    Re: K100rs 16v won't start on Wed Dec 12, 2018 2:42 pm

Dympo

avatar
active member
active member
Quick question, guys.

I've been pondering lately. I might be better off just getting a new engine, since I cannot seem to figure out what the issue is and I have seen pretty good deals not too far away from home (around 250 usd for a 50'000 kms engine).

How many different types of engines are there, and are they all compatible? I found a K100 '84 engine, could it fit my bike?

    

19Back to top Go down    Re: K100rs 16v won't start on Wed Dec 12, 2018 4:40 pm

duck

avatar
Life time member
Life time member
For a K100RS4V you need an engine from a K1 or another K100RS4V.

The 84 is a 2V motor with a different electrical system that runs on an ICU and L-Jetronic as opposed to the Motrtonic with no ICU that a K100RS4V runs on.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

20Back to top Go down    Re: K100rs 16v won't start on Wed Dec 12, 2018 5:07 pm

Laitch

avatar
Life time member
Life time member
@Dympo wrote:
. . . I cannot seem to figure out what the issue is . . .
Does this statement mean that you have done both the leakdown test and the valve-clearance check but results were inconclusive?


__________________________________________________
1995 K75T 68,000 miles
    

21Back to top Go down    Re: K100rs 16v won't start on Thu Dec 13, 2018 6:55 am

92KK 84WW Olaf

avatar
Life time member
Life time member
@Dympo wrote:Alright guys, I tested the compression this morning, as well as TPS.

TPS is fine and properly set.

Compression on the other hand, is very strange :

Cyl 1 : ~60 PSI
Cyl 2 : ~80 PSI
Cyl 3 : ~150 PSI
Cyl 4 : ~110 PSI

We're onto something here, but I don't know what.. The engine is still quite young, and I would find it very weird that the valve clearances just all got wrong at the same time..

What could be the issue here? 

Thanks

I am with the comments on head gasket between 1 and 2......but then 4 is also slightly low and makes me wonder.

But even before going into the head gasket be fully sure the compression test is correct, even to the point of getting someone else with different kit to do it. As it stands the readings don't give me confidence if that was my K that they were all correct, I would still have a second opinion on it.

Then go check the valve clearances as they can cause this too.

All being well a head gasket is not a major task, access is good.


__________________________________________________
1992 K100LT 0193214 Bertha Alaska Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 58,645 now 84,600 miles
1983 K100RS 0011175 Fricka 29,000 miles Damn K Pox
    

22Back to top Go down    Re: K100rs 16v won't start on Thu Dec 13, 2018 12:46 pm

Point-Seven-five

avatar
Life time member
Life time member
Did you shoot a few cc's of oil in the cylinders when you did the test, and then hold the throttle fully open while you cranked for about 4-5 seconds?  I always pull all the spark plugs when I do compression tests.  A little bit of oil helps to bring the compression up in engines that have been sitting idle for long periods.


__________________________________________________
Present:
1994 K75RT
1994 K75S
1992 K100RS

Past:
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

23Back to top Go down    Re: K100rs 16v won't start on Thu Dec 13, 2018 2:00 pm

mike d


Life time member
Life time member
@Point-Seven-five wrote:  A little bit of oil helps to bring the compression up in engines that have been sitting idle for long periods.

And if it doesn't then suspect a valve/valve seat issue.

Mike

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum