BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Clutch Lever not releasing all the way Empty Clutch Lever not releasing all the way on Tue Apr 02, 2019 10:58 pm

JDiggamus

JDiggamus
active member
active member
Hello all.

When I pull the clutch lever in and release it doesn't release all the way back to normal resting position. I can still shift gears.

I tried tightening the clutch cable knob and its as tight as it can be.

Any suggestions?

Thanks!


__________________________________________________
--------------------------------------------
1984 BMW K100RS
Los Angeles, CA
last 7 of VIN#0019268
;BMW;
    

2Back to top Go down   Clutch Lever not releasing all the way Empty Re: Clutch Lever not releasing all the way on Tue Apr 02, 2019 11:15 pm

nobbylon

nobbylon
Silver member
Silver member
Set upthe clutch cable pull and end play as per the manual.
Or try google k100 clutch adjust proceedure.


__________________________________________________
R1100GS Feb 1995
K100RS July 1989
R90s June 1975
R75/6 Feb 1976
F650GD May 2001
    

3Back to top Go down   Clutch Lever not releasing all the way Empty Re: Clutch Lever not releasing all the way on Tue Apr 02, 2019 11:25 pm

duck

duck
Life time member
Life time member


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

4Back to top Go down   Clutch Lever not releasing all the way Empty Solved on Wed Apr 10, 2019 1:34 am

JDiggamus

JDiggamus
active member
active member
Thanks, everyonefor your help. SO adjusted the clutch setting but it was still happening. I was riding it on Saturday and the clutch cable snapped. Well, I guess I found out what the problem was! the cable was old and worn. I replaced the clutch cable and no it works like a dream!


__________________________________________________
--------------------------------------------
1984 BMW K100RS
Los Angeles, CA
last 7 of VIN#0019268
;BMW;
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum