BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Sparking battery lug Empty Sparking battery lug on Sun Jul 07, 2019 4:07 am

parky

parky
active member
active member
Greetings, once again, from the antipodes. One hopes that this message finds all well and in good health.

So the K100rs 1991 battery, a Yuasa 53030 (circa 7 years old), was seeming getting long in the tooth and was required to be connected regularly to a tender overnight to provide a morning start for my daily commute.

Considering the age of the battery I figured a new one was in order so I ordered one and prepared to install it. I note this may have been alittle premature. But it's done.

During installation I heard a (very) brief (0.2ish sec) buzzing sound accompanied by a wee spark when when the negative lead was touch against the battery lug. It should be noted that the igniton key was in the off state.

I opened the fuse box cover and quietly tapped all the fuses; low and behold the spark and accompaning sound was no more.

I have attempted to replicate the problem but cannot. I suspect that I tapped the wee blue relay located in the upper left side of the fuse box first, although I cannot be certain. In addition I opened up the same blue relay and cleaned up the contacts which had very minor carbon deposits on them.

My question is could tapping any of the fuses have solved the problem? And if so which fuse should I suspect as being the main suspect. Once again the ignition was off and I do not know where else the load causing the spark and noise could be coming from. 

Cheers team,
Shaun


__________________________________________________
1991 BMW K100rs (16v)
    

2Back to top Go down   Sparking battery lug Empty Re: Sparking battery lug on Sun Jul 07, 2019 8:18 am

robmack

robmack
Life time member
Life time member
There's a motronic relay on the 16V models that is connected to unswitched 12V through the fuse block. It might well have been that component that made the sound since it's an unswitched source that does not go through the ignition circuit.


__________________________________________________
Robert
1987 K75 @k75retro.blogspot.ca
http://k75retro.blogspot.ca/
    

3Back to top Go down   Sparking battery lug Empty Thankyou Robmack on Sun Jul 07, 2019 8:53 pm

parky

parky
active member
active member
So I think you've gone quite someway to focussing in on the issue...

I removed the motronic relay, opened it up and gave it a quick wipedown. 

Now here's the thing ...having replaced the battery, and the relay, the radiator fan came on when I turned on the ignition key. I removed the motronic relay and it stopped, I reinserted the relay then tapped it. The fan stopped, the fuel pump charged and the bike fired up well.   

I'm considering replacing the relay, and certainly will do so if it is possible that they can intermittently fail.

Thanks again,

Regards,

Shaun


__________________________________________________
1991 BMW K100rs (16v)
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum