BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   k100 test temp sensor / coils  Empty k100 test temp sensor / coils on Sun Nov 17, 2019 7:44 pm

yankeeone

avatar
Platinum member
Platinum member
Hi, I am having trouble with my 86 k100. Hard start, rough running , white smoke, ect. 
I have tried all the stuff. Today I just tested the tem. sensor, # 10 pin and ground and got 2.14 ohms. Tested the coils on the spark plug sockets and got 9.76 k ohm.
How do those numbers sound ?
For some reason its 1 and 4 cylinders that seem to be hard to fire.

    

2Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Sun Nov 17, 2019 11:24 pm

RicK G

RicK G
VIP
VIP
White smoke can be the coolant leaking into the combustion chamber and those numbers are OK if the engine is at ambient temperature.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1993 K1100 LT, 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki X 2 for now
    

3Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 2:58 am

charlie99

charlie99
VIP
VIP
@yankeeone wrote:Hi, I am having trouble with my 86 k100. Hard start, rough running , white smoke, ect. 
I have tried all the stuff. Today I just tested the tem. sensor, # 10 pin and ground and got 2.14 ohms. Tested the coils on the spark plug sockets and got 9.76 k ohm.
How do those numbers sound ?
For some reason its 1 and 4 cylinders that seem to be hard to fire.

2.14 ohms ?....I hope you mean 2.14 k ohms ...and I hope the engine was cold when you took the measurement

at 2.14 ohms the fan should have been running for quite some time .... as it triggers the temp - fan relay  at about 100 ohms 

usually we measure the resistance to the temp sensor at the under seat ecu on pins 10 and 13 ....can make a difference , as this is what this ecu sees ...rather than a faulty path to ground , which is quite common ,,,and one of the faults with the temp sensor (corrosion between the temp sensor and the water stub housing ---in the threads , caused by dissimilar metals and the stuff in the radiator system creating a bad earth path )

don't forget that on all the early 2 valve k bikes  the temp sensor that controls the ecu is a double sensor within  the same device , the third contact is the water stub earth path .


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%Ok100 test temp sensor / coils  Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

4Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 9:44 am

yankeeone

avatar
Platinum member
Platinum member
Thanks guys, what should I expect to get for readings on the ecu connector on pins 10 and 13?
It seems most of the problem is on 1 and 4  , the exhaust pipe are cold , and when I can finally get some rps going they are cooler than 2 and 3.

    

5Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 10:43 am

Point-Seven-five

Point-Seven-five
Life time member
Life time member
First of all, if it was the temperature sender, ALL the cylinders would be giving you trouble.

Second, early K100 coils have a reputation for failing.  I suspect you have a bad one.  It may not be a bad idea to replace the coils with the later version. 

A test might be to swap your coils and see if the problem moves to the other cylinders.


__________________________________________________
Present:
1994 K75RT
1991 K100RS
1988 K100RS SE

Past:
1994 BMW K75S
1992 BMW K100RS
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

6Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 1:06 pm

Laitch

Laitch
Life time member
Life time member
@yankeeone wrote:I am having trouble with my 86 k100. Hard start, rough running , white smoke, ect. 
I have tried all the stuff.
Which stuff is that—Ambien, Excedrin, Cialis, Ecstasy? .75's coil swap seems sensible; a compression test might be useful, too.

    

7Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 3:30 pm

yankeeone

avatar
Platinum member
Platinum member
Stuff/
Switched computer under the seat with known working one
switched control unit under the tank with known working one
hall unit
valve check 
compression test 
switched coils with known working coils
tested fuel pump pressure
plug wires are new
do have spark on 1 and 4
switched air flow meter with known working one
removed injector rack and checked for fuel from injectors
checked for vacuum leaks
checked breather hose



Last edited by yankeeone on Mon Nov 18, 2019 5:02 pm; edited 1 time in total

    

8Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 3:48 pm

yankeeone

avatar
Platinum member
Platinum member
Point seven five, I agree with your assessment. I did swap coils ,but no help.

The bike was running great. Just rolling along at seventy five, then sudden loss of power.
When trying to start now, early cranking ,trying to start leaves 1 and 4 exhaust pipes cold, If can get some rpms up then they get hotter. but not as hot as 2 and 3

    

9Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 4:28 pm

MartinW

MartinW
Life time member
Life time member
Check the wiring to the coils.
Regards Martin.


__________________________________________________
K75s Hybrid
    

10Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Mon Nov 18, 2019 9:37 pm

Matthew-Brisbane

Matthew-Brisbane
Life time member
Life time member
Another easy check on the coil and leads is to remove  the coil cover and the spark plug cover plate and run the bike at night in the dark  and hopefully you don't see any blue  dancing lights


__________________________________________________
1986 K100 RS Motorsport
#### K100 RS Project 
2011 R1200 GS
    

11Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 4:37 am

charlie99

charlie99
VIP
VIP
or in this case hopefully you WILL see dancing sparks ,  enough to be able to identify issues

I might add , a set of  coils off a working bike  , doesn't mean that they are good in all respects , had a set recently that idles ok , with a struggle ...but broke down on acceleration and higher revs - only .....

removing the coil cover let me hear the jumping over of the high energy spark and identify the bad one , im as blind as a bat anyhow ...smile


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%Ok100 test temp sensor / coils  Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

12Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 6:01 pm

yankeeone

avatar
Platinum member
Platinum member
Thanks, I will try running the bike in the dark, it just got dark here. 
I think I will try a test for continuity on the harness side of hall sensor and coils.

    

13Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 8:28 pm

yankeeone

avatar
Platinum member
Platinum member
Solved --  spark plugs, particularly number one , they only have about 5 thousand miles on them , so looks like a failing coil as well.
Thanks for your help

    

14Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 8:49 pm

92KK 84WW Olaf

92KK 84WW Olaf
Life time member
Life time member
Anyone mentioning problems, 1 and 4 are on one coil, 2 and 3 on the other. Anything affecting 1/4 together or 2/3 together its most likely to be coil or coil wiring related. Swap coils and see if it changes with them. If it does then its coil. If not then its coil wiring which can include one of the two Hall sensors.


__________________________________________________
1992 K100LT 0193214 Bertha Alaska Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 100,380 miles
1983 K100RS 0011171 Fricka 606 29,495 miles Damn K Pox Its a Bat outta Hell No 33,600 miles
    

15Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 9:07 pm

Point-Seven-five

Point-Seven-five
Life time member
Life time member
@yankeeone wrote:Solved --  spark plugs, particularly number one , they only have about 5 thousand miles on them , so looks like a failing coil as well.
Thanks for your help
What did you see???  What is wrong with the spark plugs?  What was the coil doing??  I thought you swapped coils and the problem stayed on cylinders 1&4.


__________________________________________________
Present:
1994 K75RT
1991 K100RS
1988 K100RS SE

Past:
1994 BMW K75S
1992 BMW K100RS
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

16Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 9:19 pm

yankeeone

avatar
Platinum member
Platinum member
Like a lot of things that go wrong, it seems to be a series of little things that add up. 
I am thinking that due to a weak coil the plugs took on a lot of carbon, I did change coils but with one that was 
probably not much better, so it couldn't overcome the carbon plugs. 
I did test the spark on number one cylinder early on and when it was out it did spark , and they didn't seem 
bad visually, but apparently they were. 

 I will get new coils.

    

17Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 10:23 pm

92KK 84WW Olaf

92KK 84WW Olaf
Life time member
Life time member
What spark plugs have you? Do they have bobbins on them or do they show a threaded top?


__________________________________________________
1992 K100LT 0193214 Bertha Alaska Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 100,380 miles
1983 K100RS 0011171 Fricka 606 29,495 miles Damn K Pox Its a Bat outta Hell No 33,600 miles
    

18Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Tue Nov 19, 2019 10:24 pm

92KK 84WW Olaf

92KK 84WW Olaf
Life time member
Life time member
@Point-Seven-five wrote:First of all, if it was the temperature sender, ALL the cylinders would be giving you trouble.

Second, early K100 coils have a reputation for failing.  I suspect you have a bad one.  It may not be a bad idea to replace the coils with the later version. 

A test might be to swap your coils and see if the problem moves to the other cylinders.
This was the one to follow as an early test.


__________________________________________________
1992 K100LT 0193214 Bertha Alaska Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 100,380 miles
1983 K100RS 0011171 Fricka 606 29,495 miles Damn K Pox Its a Bat outta Hell No 33,600 miles
    

19Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Sat Nov 23, 2019 5:22 pm

yankeeone

avatar
Platinum member
Platinum member
Hi, Installed updated version of the coil. Runs great. I think a weak coil allowed the plugs to foul. when I put in new plugs she ran, and now with new coil she runs better then ever. 
It seems I will need new bigger screws for the cover and a little shimming of the coil spacing to get the old coil cover to work.
I bought the coil from Bobs BMW ,good price and got it in two days.Now I need to get another one for # 2 and 3

 Now I can continue on with the RT to RS conversion and repaint.



Last edited by yankeeone on Sat Nov 23, 2019 7:53 pm; edited 1 time in total

    

20Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Sat Nov 23, 2019 7:14 pm

charlie99

charlie99
VIP
VIP
that's a good result so far
good luck with the rest of it


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%Ok100 test temp sensor / coils  Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

21Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Sat Nov 23, 2019 8:20 pm

Point-Seven-five

Point-Seven-five
Life time member
Life time member
Thanks for the update.  Those early coils have caused a fair number of headaches.


__________________________________________________
Present:
1994 K75RT
1991 K100RS
1988 K100RS SE

Past:
1994 BMW K75S
1992 BMW K100RS
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

22Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Sat Nov 23, 2019 8:41 pm

yankeeone

avatar
Platinum member
Platinum member
It has some clean connections now too!

    

23Back to top Go down   k100 test temp sensor / coils  Empty Re: k100 test temp sensor / coils on Sun Nov 24, 2019 10:06 am

92KK 84WW Olaf

92KK 84WW Olaf
Life time member
Life time member
You discovered something I discovered.....to get the coil cover to fit you need either two old coils or two new type coils.....I found it doesn't fit if you mix the two types...I have both coil and cover types here. I needed to replace the coils in my new 83 RS and put one new one in...cover would not fit so I swapped the second one as well since I had them.


__________________________________________________
1992 K100LT 0193214 Bertha Alaska Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 100,380 miles
1983 K100RS 0011171 Fricka 606 29,495 miles Damn K Pox Its a Bat outta Hell No 33,600 miles
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum