BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down    Help please - sputtering. on Thu Sep 19, 2013 3:21 pm

jr

avatar
Silver member
Silver member
Just had a baby and moving soon and of course this is when my bike has its first failure.
Starts fine, idals fine (sp?), but when I give it has it gets to about 2k rpm and then just sputters and revs down. If I pump the accelerator it gives waves of small power - enough to drive the bike a little at low speeds but that's it. It spuds like minor backfiring and at times spuds very percussive like a right snare drum. My friend just suggested it might be a very dirty air filter or bad spark plugs.
It's on the street in Brooklyn at the moment. Any suggestions or thoughts? I don't have to wait for ordered parts and fix it curb side....

http://www.jrdelia.com
    

2Back to top Go down    Re: Help please - sputtering. on Thu Sep 19, 2013 3:24 pm

jr

avatar
Silver member
Silver member
When I give it GAS......
It SOUNDS like minor......
And at times SOUNDS very ...........
Like a TIGHT snare........

GO SPELLCHECK!!!!

http://www.jrdelia.com
    

3Back to top Go down    Re: Help please - sputtering. on Thu Sep 19, 2013 5:46 pm

92KK 84WW Olaf


Life time member
Life time member
Sounds like a lack of fuel. Check in following order I think. But before you start check over the pipes under the tank and also check the spark plugs are good as well as the leads (been there with that). Fuel supply, vaccuum pipes can be checked by spraying in cleaner or vapour.

1 connector under the tank to the fuel pump. It just plugs into the tank. If its loose can cause loss of fuel pressure. A wriggle of the connector while running will show this one up. I cured it by crimping up the female connectors by a small amount (Been there!)

2 fuel filter dirty and restricting fuel? Easy enough change. Do you know when last changed. But also check pipes inside tank in case leaking.

3 fuel pump.


__________________________________________________
1992 K100LT 0193214 101,000 miles
1984 K100RT 0022575 Baja Red bought 36,000 now 84,100 miles
    

4Back to top Go down    Re: Help please - sputtering. on Thu Sep 19, 2013 10:31 pm

jr

avatar
Silver member
Silver member
Thank you. Fuel filter is at least 3 years old with heavy NYC driving on it.
No idea about connector pipes, I'll check that.
Plugs replaces 2 years ago.

http://www.jrdelia.com
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum