BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Rear brake won't light Empty Rear brake won't light on Thu Oct 17, 2013 9:31 pm

alanretired '85 K100

alanretired '85 K100
active member
active member
1985 k100rs  Front brake lights OK rear brake won't . Checked continuity of switch ..OK. can't find information or whereabouts of the "bulb monitoring unit" that's in the electrical schematic. by passed the switch with a paperclip at the first connection, no light.

Any help appreciated.
thanks
Alan

    

2Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Thu Oct 17, 2013 9:43 pm

RicK G

RicK G
VIP
VIP
Lift the rear of the fuel tank and you will see a flat black piece of plastic which will lift away and reveal the relay box which is full of relays and wires etc.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1993 K1100 LT, 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki X 2 for now
    

3Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Fri Oct 18, 2013 7:37 am

TacKler

TacKler
Life time member
Life time member
Hey Alan,

I had a similar problem with my 94 K75RT.  It turned out that the rear brake light micro switch (under the rear brake pedal) connector (beneath right side panel) had a worn connector. 

Cut off the black connector housing (which contains two connectors) and spliced in two aftermarket connectors.  Problem solved. 

You have to be careful, as there is not a lot of excess wire to play with. 

Lessons learnt:

  • aftermarket connectors are cheap

  • Even a second hand micro switch loom is not cheap

  • There is not a lot of wire to play with coming out of the main loom beneath the fuel tank

  • if you remove the right side footpeg hanger plate watch the spring on the master cylinder, as it took me ages to work out exactly where it was attached to.  Only need to do this if you remove the micro switch loom for the repair

  • lots of stuffing around trying to find the problem

  • no problem with the front brake indication

  • did not even consider the bulb monitoring relay which I guess costs a bit

I hope this helps. 

Cheers, Dave.


__________________________________________________
Red 1991 K75S
    

4Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Fri Oct 18, 2013 8:32 am

charlie99

charlie99
VIP
VIP
alan we have seen some cracking of the soldered connections around the "bmu "  unit terminals

given that the two circuits ( front and back) both go through the bmu unit ....and that you have shorted the terminals leading to the loom at the connector

it might be an idea to continue on to that unit and have a close inspection

some have fixed their issues by reflowing the solder around those terminals .....the circuit board is easily dug out of the plastic cover for a good "look see "

use the "search" feature   to find some of the posts already made in here ....you will find pics of the unit ...and even circuits

good luck !


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%ORear brake won't light Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

5Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Fri Oct 18, 2013 10:57 am

Arlina

Arlina
Life time member
Life time member
alanretired wrote:1985 k100rs   by passed the switch with a paperclip at the first connection, no light.

Switch works different, no brake is switch closed, brake is switch open (no contact)
Unplug the connector near the coolanttank on the right side, now the brakelight should work.
If not, keep searching for a short circuit till the lightcontrol unit.

    

6Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Fri Oct 18, 2013 11:48 am

Inge K.

Inge K.
VIP
VIP
Wheeldigger wrote:
Switch works different, no brake is switch closed, brake is switch open (no contact)
Unplug the connector near the coolanttank on the right side, now the brakelight should work.
I'll think you have to check your brake light switch one more time.
Open switch = brake light off.
Closed switch = brake light on.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

7Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Fri Oct 18, 2013 11:53 am

duck

duck
Life time member
Life time member
Easy to diagnose if it's a BMU issue:

Remove BMU.

Short the front brake switch wire(Gray/Red) and the rear brake switch wire(Gray/Green) to the rear brake light(Gray/Yellow.)


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

8Back to top Go down   Rear brake won't light Empty BMU? on Sat Oct 19, 2013 1:34 pm

alanretired '85 K100

alanretired '85 K100
active member
active member
I took of the tank got to the bmu. Looked like a green box connected to a ton of wires total group about 3/4-1" diameter! put it back. how would I go about checking if that is the problem with my back brake pedal not lighting the bulb? Rechecked the switch and the side connector. pedal down= continuity, up = no continuity. connector= 11+- volts.
Still no pedal stop light, front ok. There is no emergency flash unit under the seat but the red triangle light has been on solid since I got the bike.  The 4 switches on the console are all duds.

Suggestions please. Don't know if I really need the light to come on with the back brake because I always use both front and back, and it lights with the front one.

Also there are a bunch of unused connections under the tank, anyone know where to find out what they are all for?

Thanks,
Alan

    

9Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Sat Oct 19, 2013 1:51 pm

duck

duck
Life time member
Life time member
The BMU is on the left side of the relay box - it's black. The green one is the flasher relay.

BMU:

Rear brake won't light K0831bulbmonrelay


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

10Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Sat Oct 19, 2013 7:59 pm

K-BIKE

avatar
Life time member
Life time member
Hi All,
Before diving into the technical stuff a few simple checks, is there power on the bulb holder at the rear, one of the common reasons for bulbs not working is the bulb holder. Is the bulb intact or faulty, are the electrical contacts to the base and the earth connection to the side of the bulb perfect, have you treated them with DeoxIT?

Then take a look at the big multi-pin connector in the rear housing that sometimes gets bad connections, after that sstart tracing back till you get to the point where the power reappears.
Regards,
K-BIKE

    

alanretired '85 K100

alanretired '85 K100
active member
active member
The blub lights up just fine with the front brake handle so it's fine, it's only the back brake pedal that it won't light up from. 

The bmu must have been relocated by a previous owner because the green thing is on the left side. I'll look at that black thing a soon as I get the tank off again.


Where is this exactly on the bike please " take a look at the big multi-pin connector in the rear housing"   
Thanks,
Alan

    

12Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Sat Oct 19, 2013 8:43 pm

the.postman

avatar
Life time member
Life time member
@K-BIKE wrote:Hi All,
Before diving into the technical stuff a few simple checks, is there power on the bulb holder at the rear, one of the common reasons for bulbs not working is the bulb holder. Is the bulb intact or faulty, are the electrical contacts to the base and the earth connection to the side of the bulb perfect, have you treated them with DeoxIT?

Regards,
K-BIKE
The front brake is working properly so the bulb/holder etc. should be ok, but you're right to say it's common fault. It was with mine, even the wrong wattage bulb could cause the BMU to register a fault.


__________________________________________________
1985 K100 RS   104EA49840092        #0081788     SILVERish (Madison) Prod. date 05/12/84
1984 srx 600
1986 cbr1000f/h
    

13Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Sun Oct 20, 2013 4:23 am

MikeP

MikeP
Life time member
Life time member
alanretired wrote:
Where is this exactly on the bike please " take a look at the big multi-pin connector in the rear housing"   
Thanks,
Alan
Remove the tail lamp unit and attached to the inside of the recess is a multi-connector (it's unplugged in this photo):

Rear brake won't light BMW%20K75S%20%28249%29a-L


__________________________________________________
1992 K1
1993 K1100R (used to be an LT)
    

14Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Sun Oct 20, 2013 6:02 am

K75cster

K75cster
Life time member
Life time member
If you used a paper clip to bridge the contacts at the connector on the right side under the r/h battery cover then that connector needs checking or cleaning and the wires from there back to the harness needs tracking, you can bend the wires as you go to ensure you have no obvious breaks in the wires, sometimes once the insulation is nicked it can cause the wire inside to corrode and go green and not allow power past that point.


__________________________________________________
Keith - 1987 K75c with r100rt replica fairing and half of a 1984 K100rt 1992 K1100LT a blue one

The Clever are adept at extricating themselves from situations that the wise would have avoided from the outset - QUOTE from david Hillel in Out of the Earth.
    

15Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Sun Oct 20, 2013 8:49 am

kfilipow

kfilipow
Silver member
Silver member
Hello Alan  Just use the search tab at top of Forum and type in 'electrical connections', select topics and you'll find comprehensive answers, diagrams and problems others have had.  THE best download is CF explanation of EFI.
Regards kf

    

16Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Mon Oct 21, 2013 2:48 am

westeng

westeng
active member
active member
I had exactly the same problem with my K100RT and I never replaced anything.  All I did was give the micro-switch on the brake pedal a good blast of CRC Marine and then rapidly work the switch.  It happened routinely, particularly after a lot of wet weather riding and this solution worked every time.

    

17Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Mon Oct 21, 2013 3:42 am

jandalboy

jandalboy
Silver member
Silver member
Yeah i second that Westeng though i've only had to do it once.


__________________________________________________
1990 k100rs low seat.
    

18Back to top Go down   Rear brake won't light Empty Fixed it! on Mon Oct 21, 2013 1:19 pm

alanretired '85 K100

alanretired '85 K100
active member
active member
Thank you all for the help! I found the BMU , was going to bypass it but could not figure out how to take the contacts out of the connector, tried but could not do it. Gave up, put it all back together, thought I'd just use the front brake always at the same time. Then I tried the back pedal and now it works! Did not do anything specific to fix it, guess I just scared it and it decided to work? Happens a lot to me.
Alan

    

19Back to top Go down   Rear brake won't light Empty Re: Rear brake won't light on Mon Oct 21, 2013 1:27 pm

duck

duck
Life time member
Life time member
All's well that ends well.

FYI: You don't need to remove the terminals for the connector to jump it.  You can just strip the ends of wires and stick them in the connector terminals.  (Not recommended for long term use.  Just for testing.)


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum