BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Error 1223 Water Temperature  Empty Error 1223 Water Temperature Wed Mar 22, 2017 8:24 pm

Old Boy

Old Boy
active member
active member
hi everybody,
I have this error from the ECU:
1223 Water Temperature. 

I tested the water temperature sensor, and i think it works because at 15 degrees it gives 3K of resistence and the resistence value goes down if i warm it with a lighter. 

The radiator fan works. It stars when the engine temperature is high!

But the arrow of the temperature water guage is in the red part (shows high temperature) when the engine is cold! As soon as i switch On the ignition!

What could be the problem?

I have a K100RS 1991. 

Thanx



Last edited by Old Boy on Thu Mar 23, 2017 2:37 am; edited 1 time in total

    

2Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 12:15 am

blaKey

avatar
Life time member
Life time member
Hi Old Boy.

It would be a big help if we knew what model and year K you have. There have been a few changes over the years.

Perhaps even add it to your signature, that way the info is always there for all to see.



Just read your intro that shows your model and year, but the info above still stands as not everyone reads the intros!



Last edited by blaKey on Thu Mar 23, 2017 12:17 am; edited 1 time in total (Reason for editing : I just get excited...)


__________________________________________________
Neil
K100RS 1986 RED!

Dress for the ride and the potential slide.
    

3Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 2:31 am

Old Boy

Old Boy
active member
active member
Sorry...K100RS 1991 😄

    

4Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 3:34 am

Point-Seven-five

Point-Seven-five
Life time member
Life time member
First of all,  Which sensor are you testing when you get 3K ohms at 15C?  Is it the one in the water pump or the one behind the radiator?

The water temperature gauge gets it's signal from the sensor on the bottom of the water pump.  Quick test is to pull the connector from the sensor.  If the gauge stays pegged in the red the problem could be the insulation has been rubbed off the wire someplace and it is shorting to the frame.  If the needle goes to the blue, then the sensor is probably bad.

Te sensor behind the radiator is a two part unit.  One part tells the fan to run, which you say is working properly.  The other part tells the Motronic engine control what the water temperature and thus the engine temperature.  The Motronic unit uses the water temperature signal to decide how much the mixture needs to be enriched.

A problem with that signal could result in an overly lean mixture for a cold engine or an overly rich mixture for a warm engine.  Lean will result in hard starting, and rich will give you black, sooty plugs and poor fuel mileage.


__________________________________________________
Present:
1994 K75RT
1991 K100RS
1988 K100RS SE

Past:
1994 BMW K75S
1992 BMW K100RS
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

5Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 6:22 am

Old Boy

Old Boy
active member
active member
Thank you very much Point Seven Five!

So...i tested the sensor behind the radiator, i will test the other sensor as you say. 

If the fan runs means that the other sensor behind the radiator is ok?
Or is it possible that one part (to the fan)works and the other part (to the Motronic) doesn't work?

I think the mixture is rich because i have poor fuel mileage and i have a bad smell coming from the exhaust...i think is fuel unburned


__________________________________________________
1991 K100RS 16V
    

6Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 7:49 am

RicK G

RicK G
admin
admin
The engine temp sensor on a 16v engine is only 1 sensor, all the things that happen are worked out by the Motronic unit.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

7Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 11:33 am

Old Boy

Old Boy
active member
active member
Ok!
I tested the sensor on the bottom of the pump:
I pulled the connector and the arrow falled down, so....bad sensor?
Also this sensor is used by the Motronic to decide the mixture need?


__________________________________________________
1991 K100RS 16V
    

8Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 8:40 pm

RicK G

RicK G
admin
admin
That sensor is used only for the gauge and plays no part in the running of the bike.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

9Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 8:54 pm

Old Boy

Old Boy
active member
active member
Thanx Rick!

My 1223 error could come from this (bottom of the pump) sensor?

If the sensor behind the radiator works properly, the Motronic receves right informations and i shouldn't have problems with:
Too high engine temperature 
Fuel/air mixture 
Fan start/stop 

Correct?


__________________________________________________
1991 K100RS 16V
    

10Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Thu Mar 23, 2017 9:57 pm

RicK G

RicK G
admin
admin
Your 1223 code can not be from that sensor as it is not connected to the motronic unit in any way.
Even if the sensor behind the radiator is good you could still get a bad reading due to poor electrical connections which the motronic unit will read as low temperature and make the mixture rich. A poor connection will not make the fan turn on as it will only turn on if the resistance of the sensor is lower than normal.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

11Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Fri Mar 24, 2017 2:42 am

Old Boy

Old Boy
active member
active member
Clear!


I think i need to test the resistence value to the Motronic connector, to understand if the eletrical connection is poor or not. 


I'm going to measure the resistance from 32 to 21 connectors of the Motronic and i should read there value:


0°= 6K
10°= 4K
20°= 2.5K
30°= 1.5K
40°= 1.2K
50°= 0.8K
60°= 0.6K
70°= 0.4K
80°= 0.33K
90°= 0.2K
100°= 0.18K



Right?


__________________________________________________
1991 K100RS 16V
    

12Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Fri Mar 24, 2017 4:33 am

charlie99

charlie99
VIP
VIP
well that may be right as a static measurement

but what happens when the engine is running wind passing and all that stuff

if the reference to the error code points to the temperature sender for the motronic ..sounds to me the motronic is seeing ..at some stage some very weird values ...perhaps there is some form of corrosion in the system , either at the sensor connections or in the loom as it reaches the motronic header plug ? or even the header plug connections to the computer ...

a mystery ? perhaps not ...when you find it ?


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OError 1223 Water Temperature  Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

13Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Fri Mar 24, 2017 4:45 am

Old Boy

Old Boy
active member
active member
So i have to check the connectors and the wires. 

Sorry Charlie, i didn't understand your question: when you find it?


__________________________________________________
1991 K100RS 16V
    

14Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Fri Mar 24, 2017 5:22 am

charlie99

charlie99
VIP
VIP
was just saying that I'm not familiar with the likely issues on a 16 valve model wiring loom and peripherals ...yet

but common experience has taught many of us that when there is a some form of connector involved ...and depending on your atmospheric conditions  the connector is the first place to look .

have you read about the many references about the product " deoxit "?

as I say, you will find it ..but it may take time ...

good luck


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OError 1223 Water Temperature  Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

15Back to top Go down   Error 1223 Water Temperature  Empty Re: Error 1223 Water Temperature Fri Mar 24, 2017 5:27 am

Old Boy

Old Boy
active member
active member
Thank you Charlie  Very Happy

Today i will check!


__________________________________________________
1991 K100RS 16V
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum