BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   K75 RT ABS : ECU error 7 Empty K75 RT ABS : ECU error 7 Sun Mar 07, 2021 2:46 pm

doktor33

doktor33
active member
active member
Hi,

I store my bike in a garage, a few km away from my home. I don't have plug to maintain the charge of my battery unfortunately. So, i decided to buy a new one with a lost of charge : a DeKa ETX 20L (12 V 17hAH).
The day I changed the battery (and before), I had not ride my bike, so I could not check if something was wrong. But, after the classic brake tests (rear and front brake on and a few meters), I noticed that the "ABS" light was still blinking. 
I read the error code : 7. (ECU default)... 
A friend of mine gave me an other ECU. But he didn't know if it was ok. I installed it but I have an other error : 6 (ABS relays). 

Of course, I reseted the ECU several times. No change with the old or the new ECU. I charged my old battery and made the same tests. No change (error 7 for my original one, 6 for my friend's). 

As I said, I can't say if the problem occured because of my new battery or if if it was a coincidence.
A few weeks earlier, I have moved wires under the tank. Could I have damage a connector ? Which one ? Everything seems right : nothing is unplugged.
I have a model with small blue ABS relays. 
If I'm right, when you turn the key on (without starting the engine), you can hear the noise of a relay (with the same rythm that the "ABS" light blinks on the dashboard). But after a while, there is quick click, coming from an other relay (for me, it should be a bigger blue relay). But I don't hear anything now. However, I tested the relays : they are ok.
So, I suppose the problem is coming from something else... but what ? 
I thought that it may come from the wire which supplies the big blue relay. But it's not easy to follow the wire and check the plug. 
Any advise is welcome !

Best regards from France !

http://k75rt.wordpress.com
    

2Back to top Go down   K75 RT ABS : ECU error 7 Empty Re: K75 RT ABS : ECU error 7 Sun Mar 07, 2021 5:11 pm

Laitch

Laitch
Life time member
Life time member
Have you been to this site?


__________________________________________________
1995 K75 81,000 miles
K75 RT ABS : ECU error 7 Usa-lo10
    

3Back to top Go down   K75 RT ABS : ECU error 7 Empty Re: K75 RT ABS : ECU error 7 Sun Mar 07, 2021 5:38 pm

doktor33

doktor33
active member
active member
Laitch wrote:Have you been to this site?
Hi,

Yes. It may be a solution if my ECU is really the cause of my problem. Of course, I can have my ECU fixed. But, if it comes from by battery... 
The best way first would be to check my second ECU is ok and test it with my old battery.

http://k75rt.wordpress.com
    

4Back to top Go down   K75 RT ABS : ECU error 7 Empty Re: K75 RT ABS : ECU error 7 Sun May 09, 2021 12:41 pm

doktor33

doktor33
active member
active member
Hi,

Did anyone use this model of battery DeKa ETX 20L (12 V 17hAH) on a K75 ?

Do u think i should open an other post about this question ?

Tx

http://k75rt.wordpress.com
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum