BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Oil / water pump  Empty Oil / water pump Wed Dec 29, 2010 1:33 pm

archie

avatar
active member
active member
Oil Water pump problem
Need a bit of advice i have just stripped my pump , and have installed a
new type seal , the problem i have - is that my impeller is a cast type
an not a pressed type as shown in my instructions . shaft fitted
carefully pulled through with bolt , washer & spacer all ok , but
after fitting my cast impeller it has pushed the inner seal down the
shaft more by 3 mm , im still able to rotate shaft with allen key but there
is an increase in tension , should i have replaced impeller with
pressed type + spacer ? or has anyone had success with cast type which
has its own spacer cast into ? i have not had chance to test on bike yet . regards archie Cool

    

2Back to top Go down   Oil / water pump  Empty Re: Oil / water pump Wed Dec 29, 2010 2:40 pm

Avenger GT

Avenger GT
Life time member
Life time member
http://k100rt.aforumfree.com/t1112-waterpump-seal-special-tool

Hi Archie.
Check out my posts in the above link. I had the same problem earlier this year.

    

3Back to top Go down   Oil / water pump  Empty Re: Oil / water pump Wed Dec 29, 2010 5:49 pm

archie

avatar
active member
active member
Thanks Avenger i wish i had found that post earlyer , it lookes like i managed to put the seal in ok then messed it up by using the old cast impeller , thus squashing the seal to tight regards Archie Wink

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum