BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   leading link  Empty leading link Sat May 14, 2022 5:39 pm

cfmckay

cfmckay
active member
active member
Finished new install of new leading link assembly on my BMWK100RS. This is a quality unit manufactured by Wasp cycles in the UK. Attempt to take my first ride resulted in an absolutely uncontrollable shimmy from start to stop. I have a shimmy dampener installed, again a quality unit specifically for sidecar use, previously installed on my bike with a stock front end. I am unsure as to where to begin, perhaps someone can suggest a direction to move in. I have informed the manufacturer but have not received a response as of yet. Suggestions would be appreciated. Thank you, Craig

    

2Back to top Go down   leading link  Empty Re: leading link Sun May 15, 2022 4:29 am

Saxon7

Saxon7
Life time member
Life time member
Hello Craig,
Maybe look at the shocks you have on the leading link and their settings. Too hard will make things skip around a bit and feel like it wants to tank slap. That might be a starting point for you.
Sean

    

3Back to top Go down   leading link  Empty Re: leading link Yesterday at 12:17 am

Rockman

avatar
Life time member
Life time member
Maybe post a picture of your forks.
I have Wasp forks on my K1100 and they are quite stable although I do have a steering damper (VW type).
Other thoughts: Are your steering head bearings ok? Also, the Wasp forks move the wheel forward a bit. You need to check the toe in and lean out are ok.

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum