BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Bike keeps cutting out Empty Bike keeps cutting out Mon Feb 21, 2011 4:33 am

stoofy

avatar
New member
New member
My 1988 k100 rt keeps cutting out, I replaced the ignition module and thought I had fixed it, rode for about 3 k's and it died again! Put a secondhand hall effect sensor but the bike wouldn't even turn over. So put the old one back on again. Same thing, kept cutting out. I tested the spark while it wouldn't start and it had spark but wouldn't fire, fuel pump runs ok, am lost for ideas other than fuel filter?

    

2Back to top Go down   Bike keeps cutting out Empty Re: Bike keeps cutting out Mon Feb 21, 2011 9:12 am

Crazy Frog

Crazy Frog
admin
admin
That reminds me the problems that my unlucky brother had with its K100.
The bike was acting the same way. When riding, the bike would cut off.
After removing the tank and checking all the connections, the bike would re-start and run for sometimes one week without any problem. Then the bike would start to act again. Having the bike towed at home would sometimes fix the problem Question
This was a pain to troubleshoot, but eventually he traced the problem to the plug under the gas tank (round plug for the fuel pump). One of the connectors was bad and a good cleaning and re-tightening the 4 female connectors was all it was needed to fix the bike.
Why troubleshooting was hard?
Each time that the bike would cut off, he would remove the gas tank (on the side of the road) to check the connections of the ignition module. when re-installing the tank, the connectors in the round plug would make again a temporary contact until he rode over a bump or simply the vibrations would slightly move the connector.
This should be the first thing that you have to check.
The Hall sensors are also known to fail when getting hot. You should remove the sensors cover, start the bike on the center stand and use a hair dryer to heat up the hall sensors. If they are bad, the bike will stall when they start acting up (It's unlikely that both are going at the same time).
You should test your set of spare sensors using the method explain in the EFI troubleshooting page

Bert



Last edited by Crazy Frog on Mon Feb 21, 2011 8:12 pm; edited 1 time in total


__________________________________________________
Bike keeps cutting out Frog15Bike keeps cutting out Logo2101986 k75, 1985 K100rt, 1985 K100rt/EML GT2 sidecar, 1999 K1200lt/Hannigan Astro Sport sidecar.
    

3Back to top Go down   Bike keeps cutting out Empty Re: Bike keeps cutting out Mon Feb 21, 2011 6:06 pm

Guest

avatar
Guest
I am in agreement with Bert about the four pin connector often being a culprit. It's just to the right hand side, clipped to the 'computer' in front of the battery. I was getting a slight cut-out that felt soft like fuel not hard like ignition, as well as the fuel gage jumping round a bit like it was losing connection. I traced it to this plug, and it was all after I had removed the tank and fairing panels to do another bit of maintenance work. Upon closer inspection I spotted that two of the 'female' connectors were too large to make proper contact with their 'male' counterparts. To test them I popped a sliver of tin foil into the two connectors whilst at the side of the highway where I was stopped. Voila! So upon getting home I cleaned all four connectors, pinched the female connectors down a bit and the problem was solved, never (so far - four weeks) to reoccur. Then I went inside and had a coldie. It was, afterall, a hot day and a reward is a reward. Wink

    

4Back to top Go down   Bike keeps cutting out Empty Re: Bike keeps cutting out Mon Feb 21, 2011 8:15 pm

Crazy Frog

Crazy Frog
admin
admin
Another culprit could be the large plug of the EFI computer. If you had recently removed your battery, it may be some chances that the plug is not totally clipped in.


__________________________________________________
Bike keeps cutting out Frog15Bike keeps cutting out Logo2101986 k75, 1985 K100rt, 1985 K100rt/EML GT2 sidecar, 1999 K1200lt/Hannigan Astro Sport sidecar.
    

5Back to top Go down   Bike keeps cutting out Empty Re: Bike keeps cutting out Mon Feb 21, 2011 8:32 pm

japuentes

japuentes
Life time member
Life time member
Hi there, take a look at the HT coil primary connections. Dirty on the coil tabs may cause the cut off.
Best regards
JAP

    

6Back to top Go down   Bike keeps cutting out Empty Re: Bike keeps cutting out Mon Apr 25, 2011 2:41 am

harrowbmw

avatar
active member
active member
Greetings, do you hear the fuel pump whiring away constantly. My fuel pump died and the sudden silence is a big indicator... Goodluck

    

7Back to top Go down   Bike keeps cutting out Empty Re: Bike keeps cutting out Tue Apr 26, 2011 4:11 am

K-BIKE

avatar
Life time member
Life time member
Hi stoofy,
If you had spark and fuel pressure and as long as you have compression and injection it should run.

When you have been trying to start it with ignition sparks and fuel pump running are the spark plugs wet with fuel when you stop or are they dry. If they are dry that means you are not getting injection whilst it is turning over even though you have pump running and sparks.

If they are wet you will need to dry them and blow out the excess fuel from the cylinders. Bert has a good method using a small propane torch which very effectively clears the cylinders and can also heat the plugs plus even has an excitement factor as well!

Look forward to hearing about the plugs.
Regards,
K-BIKE

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum