BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   K100 not starting up Empty K100 not starting up Mon Sep 12, 2011 5:28 am

chronostorm

avatar
active member
active member
hi guys,

Still trying to fix my K100 here and I've hit a wall.

Here's the situation: my fuel system should be working. I replaced the pump and filter with same-specced parts from a Mustang, and I got the injectors to click again, and fuel is coming out of them. I checked my spark plugs today, and it seems that they're working just fine as well.

Starter should be working fine, since I hear the sound and see the rear tire move when I use it if I'm in first gear and not holding down the clutch.

Any idea what could be the problem?

Once again, thanks so much. Without you guys, I wouldn't be able to even begin fixing my bike!

    

2Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 7:32 am

Guest

avatar
Guest
Is there a previous post you've made concerning this non-start issue that would help eliminate some basic questions, that might have already been asked, so we can get to the bottom of this problem?

You have spark (is it sufficient), you have fuel (how's the pressure), do you have air (a seriously clogged filter)? You'd also want to look to see if there's an air leak in the entire intake system somewhere. How's the engine's compression? Has it had a valve clearance check and shim change lately? Tight valves cause low compression which cause hard or no starting. Just some of the simple things which might be contributing to your troubles.

    

3Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 9:22 am

charlie99

charlie99
VIP
VIP
only thing i can contribute is ........is the plug wires wired up correctly meaning is number 1 going to number 1 etc.... should be easy to follow as the coils have the numbers on them ...

just a thought


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OK100 not starting up Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

4Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 12:28 pm

chronostorm

avatar
active member
active member
I just double checked, and I'm pretty sure the plug wires are connected right Smile


so, after taking stuff apart again and looking, I think my injectors aren't flowing enough fuel.

I can get them refurbed, buy new ones (way too much money :c ), or get a refurbed set for another vehicle that has the same ratings, right?

Any idea on where would be a good place to do either the first or last choice?

Thanks guys.

    

5Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 12:36 pm

Guest

avatar
Guest
There's a bloke in Idaho on eBay (a business) selling sets of refurbished Ford/Bosch injectors that fit our motorbikes for about a hunnerd US dollars. I don't have the link but that's a good deal.

Would they all fail at the same time? Measure into a glass beaker what each one squirts out after say, a minute.

    

6Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 12:56 pm

chronostorm

avatar
active member
active member
@Two Wheels Better wrote:There's a bloke in Idaho on eBay (a business) selling sets of refurbished Ford/Bosch injectors that fit our motorbikes for about a hunnerd US dollars. I don't have the link but that's a good deal.

Would they all fail at the same time? Measure into a glass beaker what each one squirts out after say, a minute.


I think I found the ebay seller. Unfortunately, they're out of injectors for the K100. Sad

I tried looking at their selection of Ford car fuel injectors, since I read that some of them might work, but the set closest to the k100 one has too much impedance so no good. :/

    

7Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 6:06 pm

pjjms

avatar
Silver member
Silver member
Assuming the problem is just the bike not starting, why would all the injectors fail at the same time. Does it start at all even running rough?

Did you replace the fuel pump because it failed?

    

8Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 12, 2011 6:25 pm

ReneZ

ReneZ
Life time member
Life time member
I think you have more (electrical) problems; It should not be possible to start the bike in gear.
Look back from basics: you need air, fuel and ignition (spark) at the right time. Understanding the block turns over on the starter - measure compression. Clean all electrical connectors, also ground on frame and don't forget the ones under the coils.
Check that the plug for the ECU is properly seated.
Let us know what you've done/checked meantime. You hear the fuel pump running and fuel returns to the tank?


__________________________________________________
Greetings from Florida! Having a 'new' K  :cyclops:    Surprised-o: 

Rene


BMW K100 - 1985 (0030029) K100 not starting up Rain
BMW K1200GT - 2003 (ZK01223)
    

9Back to top Go down   K100 not starting up Empty Re: K100 not starting up Tue Sep 13, 2011 7:19 am

chronostorm

avatar
active member
active member
When I got the bike, there was a lot of gunk all over the inside of the tank. I replaced the pump and fuel filter because of this. The pump was completely clogged and looked like it came out of Bioshock. This is probably why all the injectors are messed up. Sorry for not providing some context in my post.

The pump is definitely running, since I can feel and hear it, and fuel returns to the tank. I get a little bit of fuel coming out of the injectors, but definitely not a clean spray.

To ReneZ, as for starting the bike in gear, I had put it into 1st while on the centerstand and trying to start it that way, the rear wheel turns a bit. I usually have it on neutral when I'm doing stuff.

    


11Back to top Go down   K100 not starting up Empty Re: K100 not starting up Wed Sep 14, 2011 12:25 am

club_c

club_c
Life time member
Life time member
Both my K's had clogged injectors that were non-repairable (by me at least). First one I got a set of the refurbs, and second one, just got a used set from ebay for $40 shipped. Both worked fine. So you are saying that each injector is squirting some fuel, though a weak spit? Have you been able to confirm fuel pressure?


__________________________________________________
"There's never enough time to do it right, but there's always time to do it over."

1988 K100RS SE VIN 01477554
    

12Back to top Go down   K100 not starting up Empty Re: K100 not starting up Wed Sep 14, 2011 10:54 am

chronostorm

avatar
active member
active member
@club_c wrote:Both my K's had clogged injectors that were non-repairable (by me at least). First one I got a set of the refurbs, and second one, just got a used set from ebay for $40 shipped. Both worked fine. So you are saying that each injector is squirting some fuel, though a weak spit? Have you been able to confirm fuel pressure?

What's a good way to check fuel pressure?

    

13Back to top Go down   K100 not starting up Empty Re: K100 not starting up Wed Sep 14, 2011 4:45 pm

charlie99

charlie99
VIP
VIP
get another short piece of hose ....insert t barb along the line ,,,the t section should connect to a presure guage capable of measuring up to maybe 50 lbs (3 bar) should be abour 32 odd lbs ....or go to someone that can measure it..... is safest and cheeper long term if you dont have the tools

    

14Back to top Go down   K100 not starting up Empty Re: K100 not starting up Wed Sep 14, 2011 8:13 pm

Guest

avatar
Guest
Chronostorm said "I think I found the ebay seller. Unfortunately, they're out of injectors for the K100. Sad"

He's got more...this is the best deal I've seen on reco injectors, unless he places a fee against the old ones and wants 'em sent to him to refund your 'core' charge.
http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=200652684948

    

15Back to top Go down   K100 not starting up Empty Re: K100 not starting up Sun Sep 18, 2011 3:30 am

ReneZ

ReneZ
Life time member
Life time member
A crude test of the fuel pressure regulator is with a bike tyre pump. Connect it to the fuel line to the FPR and pump it, pressure should be at about 2.5 bar (those gauges on those pumps are normally not to precise). At least gives you an indication.


__________________________________________________
Greetings from Florida! Having a 'new' K  :cyclops:    Surprised-o: 

Rene


BMW K100 - 1985 (0030029) K100 not starting up Rain
BMW K1200GT - 2003 (ZK01223)
    

16Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 19, 2011 11:22 am

chronostorm

avatar
active member
active member
sorry guys, I've been super busy lately, and trying to get the K100 fixing in when I have free time, which isn't much right now Sad

I did look at some of the links, and finding the US version of a link two wheels better posted, there's a sale right now on new injectors:

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=150635548261#ht_2308wt_939

    

17Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 19, 2011 1:20 pm

club_c

club_c
Life time member
Life time member
That's a good deal, esp for new, as long as it's the right numbering...


__________________________________________________
"There's never enough time to do it right, but there's always time to do it over."

1988 K100RS SE VIN 01477554
    

18Back to top Go down   K100 not starting up Empty Re: K100 not starting up Mon Sep 19, 2011 1:23 pm

Guest

avatar
Guest
This is the best deal I've seen. These are the correct Ford part number for the Bosch type injector that fits our bikes (K75 & K100 8V). He's reduced the price substantially too, but it ends sixteen hours from NOW, which is 1.25PM Monday, Australian Eastern Standard Time.

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum