BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Help indicators etc. Empty Help indicators etc. Wed Feb 15, 2012 3:16 am

Ajays

Ajays
Life time member
Life time member
When I got it back on the road, the RH indicator was not working....no power to the socket. (loose wire in housing I suspect) Then it was laid up again for 6 weeks while I sourced a less expensive battery which I found. Back on the road but indicators not working at all (Fuse OK and I cleaned all fuse connectors) and weeks later, the right indicator comes on when you press left button but does not stay on unless you hold the button down. All indicators come on when rH button is held down.
I don't believe its the new battery, as the Amp/hr rating was slightly less than the original. 18 i/o 20, if I remember correctly.
I suspect a bad connection to the indicator relay and will check that out. Any thoughts? Maybe a find on the Forum could pinpoint the cause.

This is from an old associate in South Africa and he has asked for a few pointers.

Any suggestions?

His email address is fijardine@gmail.com any answers here I will pass on.

Come on you Sparks experts.
Ajays


__________________________________________________
Help indicators etc. Th_Kengine_gif

AJAYS
    

2Back to top Go down   Help indicators etc. Empty Re: Help indicators etc. Wed Feb 15, 2012 3:56 am

charlie99

charlie99
VIP
VIP
personally never heard of that before ajays

but as the topic suggests i recon i has to be a corrosion issue ,,,possibly at the relay itself ...but i wouldnt be surprised if it in fact was an earth issue ....

my thoughts are .....that possibly the earth strap ...moved whilst changing the battery ...might not be getting full contact under load whilst running and charging ....

the switching technique is to ground the appropriate contacts ...for left right and cancel ....ima thinking ..w have seen issues with head bearings before and wonder if the earth contact to the control (handlebars) has become intermittent as well

to prove the loose contacts ...maybe a jumper cable could be utilized from the battery negative directly to the handle bars ...maybe ?...and see if this resolves some of the issues ...of corse it could infact be a corrosion between the cancel button and earth (leakage) affecting the whole operation ...

just some thoughts ....

    

3Back to top Go down   Help indicators etc. Empty Re: Help indicators etc. Wed Feb 15, 2012 5:39 am

RicK G

RicK G
admin
admin
Check all the fuses. I have seen this before and one of the fuses was open circuit but not showing up as blown. Also check the starter brushes are good.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

4Back to top Go down   Help indicators etc. Empty Re: Help indicators etc. Wed Feb 15, 2012 5:50 am

charlie99

charlie99
VIP
VIP
ah ! yes good reminder kf ......the ground path throught the starter always is a fickle thang ..causing all sorts of issues throughout the system


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OHelp indicators etc. Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

5Back to top Go down   Help indicators etc. Empty Re: Help indicators etc. Wed Feb 15, 2012 3:40 pm

Inge K.

Inge K.
VIP
VIP
I`ll guess it`s more than one issue which causing this.
It`s sounds like.....as KF allready have mentioned.....bad earth at the LSR.
Which also would give strange and erratic behaviour at headlight, brakelight,
horn and fan.
A easy way to verify this is to connect a jumper cable between the starter
terminal and ground, and stay far away from the starter button.

A bad connection at fuse #7 would give about same symptoms, except headlight.

And as flasher that only functions (but abnormal) when buttons is held down, points to the cancel switch is shorted to ground.

And Charlie, you must be in a hurry mode this day?
Grounding the handlebar won`t make any difference, as both switch assys is
isolated from the handlebar and each of them got it`s own ground wire down
to the multiconnectors.

Inge K.

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum