BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   1985 k100RS turbocharged Empty 1985 k100RS turbocharged Wed Mar 14, 2012 1:29 pm

banditdog

avatar
active member
active member
i have a1985 k100rs turbocharged from the dealer when it was new. The plugs foul out when trying to start it after it sits for 8 hours or more after riding it.The bike has only 29,000 miles and had the 30,000 mile service at 26,000 miles. I have checked the wiring under the tank,computer and cleaned all connections and grounds.I also have checked the temperature sensor and it has the proper ohms .The fuel pump,regulator are also new. After it does get running it will idle at 1000 rmp and go to 1200 to 900 rpm ,up and down. It will not idle steady but rev up ok.I changed out the ecm with one from spare parts.This bike ran good and has not been abused and regular maintenance has always been done.Dielectric grease has been also applied to connections.Air filer is also new, it will start if i use starting fluid when cold and then when warm i think it runs a bit too rich. The gas flows back into the tank with no restriction. I do not see any cracked rubber manifold problems. Could an air leak cause the up and down idle and fouling plugs? thank you i need all the help i can find. This is about to drive me crazy trying to trouble shoot this problem!

    

2Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Wed Mar 14, 2012 1:50 pm

charlie99

charlie99
VIP
VIP
we dont recomend dielectric grease in here ....i think we have found a winner in the "deoxit" product for cleaning all electrical connections .

we have also found that the throttle body rubbers ...like all rubber in the fuel system perishes ....the cracks are not always visible imediatly and there are a few teqniques for finding the issue (but i think this is more likely to affect running mixtures but could be a contributing factor )..

a couple of things we have also found and could well be pertinent in your case ....the pipe that goes from the crankcase to the throttle bodies (enters the plenum near number 4 and hiding behind the ignition coils) often is found to be cracked and requires replacement this tends to affect idle for sure .

fails to start after a few hours sitting...??? could the injectors require cleaning ? it might be a good idea to see if there is leakage from them (whilst presure is in the system ) if all things are good the presure should hold up for some time

we have also seen some fuel presure regulator issues , which may affect the injection process and loss of presure as above

lots of threads in the forum about these issues, try using the search feature ...(works well )

hope these observations help some ....good luck and welcome aboard !!

    

3Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Wed Mar 14, 2012 7:07 pm

banditdog

avatar
active member
active member
Thank you very much i will look at all posts and maybe fix this problem! Thank you again Jon PS will keep site informed to my success!

    

4Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Wed Mar 14, 2012 11:53 pm

Halo

Halo
Life time member
Life time member
Got any pics? I would love to see what it looks like:D


__________________________________________________
84 K100RS 0014803
93 FZR1000 EXUP
    

5Back to top Go down   1985 k100RS turbocharged Empty k 100 running problems Fri Mar 23, 2012 5:58 pm

banditdog

avatar
active member
active member
HI : I have learned a lot on this site in the short time i have been a member. I checked out my intake rubbers and they were split under the clamps ,so they are all now new along with the manifolds too. The bike runs great except that it will just die at 6000 rpms. It makes no sense because it will rev to 8500+ rpm on the center stand all day long. I then ride it and under load it will just cut out at 6000 rpm and if i cut back on the throttle a bit and give it more throttle it will go to 7500 rpm and more but slowly.The fuel pressure is 36 to 38 psi,new fuel pump-filter-regulator- injectors-cleaned all electrical connections-air cleaner new-set throttle bodies with a morgan carbtune -vacuum lines have been checked and are ok. what am i missing i am a mechanic and this thing has me stumped. I hope in the future to add some good advice to help others on this site too.After all the advice from people on here and then working on my bike it started up idled great reved up to 8500+ rpms so i took a ride and it ran better now than the last five years i have owned it except after 6000 rpm.thanks again for the help JON i will post pics of my bike soon.

    

6Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Fri Mar 23, 2012 7:14 pm

charlie99

charlie99
VIP
VIP
good to hear about the rubbers jon ...

the dieing at 6000 sounds weird to me ..... almost sounds like it is leaning out, way too early

hmmm havent seen this sort of issue before .

2 things i have thought of

could you check the afm (air flow meter) to see if the movement is free all they way through its moovement ? kinda sounds like its not letting the flap fully open ....this would not affect the flow at low loads , like on the stand but certainly might at real load conditions

have you checked the ignition timing ?, if it was too advanced this may cause a similar issue as the electronics applies timing to the spark process .

just some thoughts


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O1985 k100RS turbocharged Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

7Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Fri Mar 23, 2012 7:22 pm

RicK G

RicK G
admin
admin
It is running lean. I won't even try to give a diagnosis as I have no knollege of the setup but that pick up when you back off the throttle is lean and if it is as pronounced as you say then you would be in danger of melting a hole in the pistons so caution is needed.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

8Back to top Go down   1985 k100RS turbocharged Empty k 100 running problem Fri Mar 23, 2012 7:34 pm

banditdog

avatar
active member
active member
Hi guys: I will check the air flow meter and the timing. I checked the timing when i set the valves last summer and it was ok then. I have another air flow meter and will switch them out and see what happens.The air flow meter on the bike looks like someone in the past took off the cover and then did a bad job of gluing it back on.I will try this in a few days and keep all informed to my progress. Thank you all again . Jon

    

9Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Fri Mar 23, 2012 8:04 pm

Inge K.

Inge K.
VIP
VIP
This link might become useful.

Inge K.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

10Back to top Go down   1985 k100RS turbocharged Empty Re: 1985 k100RS turbocharged Fri Mar 23, 2012 10:29 pm

charlie99

charlie99
VIP
VIP
good link inge ...

now if i can just get it translated ....giggle


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%O1985 k100RS turbocharged Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

banditdog

avatar
active member
active member
HI : Update on my problem with the k100 rs turbocharged motorcycle cutting out at 6000 rpms + .I switched the mass air flow meter with one that i know was good. It still would cut out at high rpms, so i took off the tube that ran from the turbo inter cooler and rode the bike! WOW it ran great all the way to 9000 rpm. i decided to check the gate valve or pull off valve on the turbo charger with a hand held vacuum pump. Well to my astonishment there was no vacuum as i pumped the hand held pump at the gate valve.This turbo was one of the first twenty Luftmeister units built by RB Racing in 1985 and was dealer instaled at that time. I have contacted RB RACING in California but they said they are too busy at this time . They are moving but will help me with matter in the future.It looks like the gate valve needs rebuilt or replaced. I think the turbo produced way too much boost with out the gate valve working and the motor could not hand it and shut down. I guess that was better than just blowing up . I have read many posts on this site and they have all helped me very much. thank you and will post later JON

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum