BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


mack8882

mack8882
active member
active member
Hello all,

Thank you all for your help and advice w/ the starter issues I was having. Myself and the gent who sold me the bike recently (he was kind enough to come help) replaced the starter brushes and it fired right up after we reassembled everything.

BUT, unfortunately I now have a serious oil leak after taking the bike out for a short ride and I was hoping for some advice as to what this leak might be. I'm not sure if we caused from disassembling/reassembling, but if someone knows the cause, please let me know. Links to pictures of the leak are below.

https://i.servimg.com/u/f40/17/60/61/94/oil_le11.jpg
https://i.servimg.com/u/f40/17/60/61/94/oil_le12.jpg
https://i.servimg.com/u/f40/17/60/61/94/oil_le13.jpg
https://i.servimg.com/u/f40/17/60/61/94/oil_le14.jpg


Thanks
Craig

    

88

88
Life time member
Life time member
From those photos it looks like the Oil is leaking from the little breather hole at the front of the engine which leads to the void between the oil and water seals in the pump. If I'm correct in this it looks like its the pump oil seal that has let go. Not related to the starter, plenty of really good pictorial threads on how to repair. Use the google function on the poratal page to find them and start reading up.

88KE


__________________________________________________
Starter brushes replaced and bike starts right away, BUT new oil leak Ir-log11 88....May contain nuts!Starter brushes replaced and bike starts right away, BUT new oil leak Ir-log11

"The world is a book and those who do not travel read only one page." - St. Augustine from 1600 years ago & still true!

K1100LT 1992 - AKA Big Red
K1100RS - 1995. AKA Rudolf Von Schmurf (in a million bits)
K1/RS - AKA Titan (unique hybrid by Andreas Esterhammer)
    

mack8882

mack8882
active member
active member
Thanks 88KE for the quick reply.

Would this be the appropriate tutorial for fixing my oil leak?

http://hrsbstaff.ednet.ns.ca/bvogel/K100/oil_pump/oil-pump-seals-replacement.htm

    

Crazy Frog

Crazy Frog
admin
admin
@mack8882 wrote:Thanks 88KE for the quick reply.

Would this be the appropriate tutorial for fixing my oil leak?

http://hrsbstaff.ednet.ns.ca/bvogel/K100/oil_pump/oil-pump-seals-replacement.htm

Yes this is it.

CF


__________________________________________________
Starter brushes replaced and bike starts right away, BUT new oil leak Frog15Starter brushes replaced and bike starts right away, BUT new oil leak Logo2101986 k75, 1985 K100rt, 1985 K100rt/EML GT2 sidecar, 1999 K1200lt/Hannigan Astro Sport sidecar.
    

nino

avatar
Life time member
Life time member
Hello Craig, it could be only a faulty seal, but could be impeller shaft too after long sitting of bike. Full service kit you can order from www.motorworks.co.uk or www.motobins.co.uk but best way is to buy overhauled pump unit like I did. Any how dont forget good high temp. resist. sealant.

Its easy to fix, you ll need two hours

Regards

    

mack8882

mack8882
active member
active member
I hope its only the seal. When we recently replaced the starter motor, it took some elbow grease to get the starter motor out away from the gear box. Do you think that could have caused the oil leak?

And any suggestions on best place to buy the seal? Is it readily available? I'm in Ohio and would like to try to buy it locally.

Thanks
Craig

    

nino

avatar
Life time member
Life time member
Ask for seal in BMW dealership (probably) in Columbus, but both british supplier are reliable, fast and cheaper than german dealers.

I dont believe grease could cause leak. Did your bike sit for some period?

    

mack8882

mack8882
active member
active member
Ok thanks.

I think it sat only for a week or so before the starter motor brush was fixed.

    

captaink

captaink
Silver member
Silver member


__________________________________________________
1989 k 100rs
    

mack8882

mack8882
active member
active member
Just to clarify, do I have to buy a kit or do I need just one specific seal? Any part #'s would be really helpful!

Thanks again for everyone's quick assistance!

    

charlie99

charlie99
VIP
VIP
mack ....to replace the oil seal ..unfortunatly you first have to remove the old water seal as well

the kit is hightly recommended as it has all the right bits ,,,dont forget that impeller as well

this is what i did

http://k100rt.aforumfree.com/t1833p250-85-rt-resto-my-attempt-hey-im-not-into-making-a-show-bike#34154


go to motobins website k100 / water- oil pump .


hope it helps


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OStarter brushes replaced and bike starts right away, BUT new oil leak Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum