BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


KJB

KJB
active member
active member
Hi,
I have just restored my BMW K100RS (1984) and since the rebuild and changing a rather damaged looking power saver relay for a second hand unit, the bike runs but won't switch off by the key (kill switch only).

Does anyone know if the power saver relay has a part to play in this?

Any help would be greatly received-Kim Beresford

    

RicK G

RicK G
admin
admin
Hi Kim welcome to the forum
The only thing that could do that is a crook ignition switch one of the guys here did a write up on how to get them apart and do a fix. If you do a search in the electricals section I'm sure you will find it as it's only been a few days since I saw someone else posting in it.
Here http://k100rt.aforumfree.com/t2391-ignition-switch


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

Inge K.

Inge K.
VIP
VIP
Welcome Kim!
Another possibility is if terminal 86 & 87 are shorted on the LSR,
then the contacts would stay closed until you push the starter button.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

KJB

KJB
active member
active member
Hi guys,

this is an odd one, so i've ordered a new power saver relay. What's wierd is the ignition will switch on and off as normal, but once the engine is actually running the igniton switch doesn't operate at all regardless of what position it's in.

I don't know if that will fail the MOT test as it is so for £10 i'll try a new relay.

I think you might be right Inge K!

I'll let you know what happens when it arrives on thursday!

Kim

    

Inge K.

Inge K.
VIP
VIP
Does your light turn off with the ignition?
If not, it`s caused by the previously mentioned possible short.

Welded contacts on the LSR would give similar symptoms,
but then pushing the starter button won`t make any difference.
(and your light would stay on).

You could also swap the horn relay and the LSR, as they are similar.
(but the the short could also be in the wiring, close by)


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

Inge K.

Inge K.
VIP
VIP
@Inge K. wrote:then the contacts would stay closed until you push the starter button.
Senior moment............forget this one.
If engine is running above 710 rpm, the starter relay won`t close the contacts.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum