BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   air flow sensor readings ? Empty air flow sensor readings ? Mon Jul 30, 2012 8:20 am

sven k100

sven k100
active member
active member
I've recently cured the slow starting problem on my 1987 k100 by renewing the fuel regulator with an aftermarket one, adjustable for pressure, with a dial on the side.Bike now keeps fuel pressure overnight , result, instant starting. The problem with slightly surging at tickover (1000 revs), and snatchy initial acceleration from a closed throttle still exists, so, i've been checking the operation of the airflow sensor. Visibly, the needle and track look ok, but with the ohmeter across, the readings are all over the place. This still happens when slight pressure is applied to the needle, and when the track was cleaned. On mine the track has about 5 divisions, or markers in the track , and the ohmeter needle goes to infinity when it crosses them. Is this normal ?. when running, the engine's performance does'nt jump as these divisions are crossed, it's only jumpy rolling on from a shut throttle.. Also, my air sensor does not have the temp sensing element in it's throat , although i can see the device wired in next to the printed circuit. any ideas gratefully received !.

    

2Back to top Go down   air flow sensor readings ? Empty Re: air flow sensor readings ? Wed Aug 01, 2012 4:27 am

Inge K.

Inge K.
VIP
VIP
@sven k100 wrote:Also, my air sensor does not have the temp sensing element in it's throat , although i can see the device wired in next to the printed circuit. any ideas gratefully received !.

Non genuine unit, or removed sensor?

air flow sensor readings ? Temp_f10

http://www.flyingbrick.de/pdf/Luftmengenmesser.pdf


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

3Back to top Go down   air flow sensor readings ? Empty airflow Thu Aug 02, 2012 8:41 am

sven k100

sven k100
active member
active member
that would certainly explain why the engine seems to run rougher as it warms up !

    

4Back to top Go down   air flow sensor readings ? Empty Re: air flow sensor readings ? Thu Aug 02, 2012 9:21 am

charlie99

charlie99
VIP
VIP
good explanation and research on the issue sven...we have seen a simlilar but different issue recently ....with a sticking (apparently ) air flow sensor , as you explain . the jumpy result of a the sweep that you are experiencing may need a new device ...(or good second hand item ) to fix .....unless you can repair the carbon track .....or reposition the wiper across the track (hard ) ?


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%Oair flow sensor readings ? Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum