BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   ABS woes Empty ABS woes Fri Nov 09, 2012 12:34 pm

MT350Explorer

MT350Explorer
Life time member
Life time member
Hi Guys

I had ABS fault lights both flashing and after discussing with Tosi (who supplied a recon brain about a year ago) have put a new battery in the bike, ridden 100km after charging it and my ABS is still showing two blinking fault lights. Ahhgh! I wonder if I being dense but when I read the error codes from the ABS plus centre pin I should get a certain number of dips which indicates a particular problem. However - and this is my first question; I am getting continuous dips with no break not 4, 5, 8 or whatever dips (followed by a pause I presume?). I have had this sequence of never ending dips before and found resetting the ABS cured the problem but not this time despite repeated attempts. Any ideas?

One possibility could be not enough charge from the alternator or a struggling reg/rec? Would that make sense and if so how would I test them? Lights and so on work fine but perhaps their demand is less than ABS.

I have a digital and anologue meters but my understanding of electrics is rudimentary.

If I can't fix it I think it's back to relay removal and ABS brain diconnection!

Thanks for any help
Dave


__________________________________________________
1991 K100 RS 16 valve
    

2Back to top Go down   ABS woes Empty Re: ABS woes Fri Nov 09, 2012 1:07 pm

charlie99

charlie99
VIP
VIP
now that the battery is fully charged dave ...have you thought to disconnect it , and then connect again

i have a feeling that these abs systems are a pluky lot ...and would like to go through the start sequence with everything being "just right "

did i read somewhere that the abs is connected at all times ?

just a suggestion


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OABS woes Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

3Back to top Go down   ABS woes Empty Re: ABS woes Fri Nov 09, 2012 1:13 pm

MT350Explorer

MT350Explorer
Life time member
Life time member
Thanks Charlie - I'll give it a go!


__________________________________________________
1991 K100 RS 16 valve
    

4Back to top Go down   ABS woes Empty Re: ABS woes Fri Nov 09, 2012 7:49 pm

GerryP

GerryP
Silver member
Silver member
Its next to impossible to read the code using a digital meter, but an analogue meter should give about 10 Volts steady if things are good and after the ABS controller has gone through its startup sequence. The startup sequence takes about ten seconds to finish.

After that if there's an error code in the memory you should see a sequence of about one dip per second with a two second gap between sequences. If your sequence is about one dip per two seconds then you've probably got error code one (Front Pressure Modulator). This can look like a continuous sequence.

Best is to use a small 12 Volt LED for the count.

Note that the Modulators are different for the ABO1.5 and ABO2.5 controllers.

I'm in the middle of going through all this myself having just received my ABS controller back from Tosi.

Best of luck Shocked



Last edited by GerryP on Fri Nov 09, 2012 7:59 pm; edited 1 time in total (Reason for editing : dyslexic fingers)


__________________________________________________
Safe riding Cool,
Gerry Parnham


K1100LT (1993) in Silk Blue/Cream
http://gerryparnham.com
    

5Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 2:40 am

MT350Explorer

MT350Explorer
Life time member
Life time member
Hi Gerry

Thanks that's great information - the frequency between the dips might be the key to my midsunderstanding. It is dipping every 2-3 seconds. Tosi has also kindly replied and given me a further test or two so off to lift the tank and have a poke about.

Good luck - by way of encouragement mine did work well for a few months once I had the recon brain from Tosi Very Happy

Cheers
Dave


__________________________________________________
1991 K100 RS 16 valve
    

6Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 9:29 am

MT350Explorer

MT350Explorer
Life time member
Life time member
Well I'm embarrassed to admit the fault seems to have been down to a dodgy electrical connection Embarassed. Now before anyone condemns me to death in a bath of Deoxit I will say I applied this marvellous chemical to all of the connections under the tank and made/unamde the connections as well as the ABS brain connection less than a year ago so assumed they were OK. However, Tosi recommended I try Deoxit so I had another go - no visible corrrosion but what the hell. This time I used an old toothbrush as well and Hey presto - no flashing lights. Cheers again to Tosi for his patient problem solving Very Happy.

Still good news it's working and even better news I won't have to try and change a modultaor and attempt bleeding the system - which looks like a challenge.

Cheers
Dave


__________________________________________________
1991 K100 RS 16 valve
    

7Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 9:40 am

GerryP

GerryP
Silver member
Silver member
Congratulations Dave Very Happy

I do recommend you put some sort of water-repellant on the connections after cleaning them. WD40 is good. Vaseline is better, if you've got the patience.
I'm still waiting for it to stop raining down here. ABS woes 178468


__________________________________________________
Safe riding Cool,
Gerry Parnham


K1100LT (1993) in Silk Blue/Cream
http://gerryparnham.com
    

8Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 9:58 am

MT350Explorer

MT350Explorer
Life time member
Life time member
Cheers Gerry. It's interesting I was just looking through old paperwork and back in 2008 the bike was in to BMW for an ABS fault test - guess what - front modulator - the same as the latest error. I think the ABS brain was removed at this point - it didn't have one when I got the bike, I suspect there may be one connection that plays up now and again that is the root cause of this repeated fault code. Could be unrelated events but seems unlikely.

Cheers
Dave


__________________________________________________
1991 K100 RS 16 valve
    

9Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 10:01 am

charlie99

charlie99
VIP
VIP
a great result dave ...cheers !

you do know about the other deoxit too huh ? the one that protects ?


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OABS woes Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

10Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 10:11 am

MT350Explorer

MT350Explorer
Life time member
Life time member
Thanks Charlie!

Are you trying to bankrupt me? Very Happy I could buy a house for the price of a tin of that stuff.

Joking aside - no I didn't know - seem to recall it was pretty hard finding a UK source for the spray - a high end hi-fi store supplied in the end.

BTW do you know if all rear brake pedals are the same - including 16v?

Dave


__________________________________________________
1991 K100 RS 16 valve
    

11Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 10:22 am

charlie99

charlie99
VIP
VIP
tin ? i just use the small nail varnish sized bottles ...what are you guys doing over there ? dousing the whole bike ? giggles ...yes we certainly have a different envioment out here ...suposedly far less wet stuff for most of the year ....i can only imagine what troubles you have season to season

wouldn't it be easy to allocate a tooth brush for cleaning the terminals and then keeping it wraped up in glad wrap or something for similar jobs ?

i believe that jaycar has an outlet in uk somewhere ....or at least a distribution network

about the brake pedal ...no mate hadn't even thought about it ...i had surmised that there weren't many rear brake options at all ...so imagined that they would be perty much mostly the same ....hey but always willing to lean new stuff . (besides the rear set modifications which would be kinda special stuff )

the only thing i can think of is that there were different types of switches used for the brake light activation ...which might see a design change in the brake pedal bits - bumps and bolts to activate ?



Last edited by charlie99 on Sat Nov 10, 2012 10:38 am; edited 1 time in total


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OABS woes Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

12Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 10:37 am

MT350Explorer

MT350Explorer
Life time member
Life time member
Not dousing in Deoxit but I do intend to in ACF50!

Just looked on Eaby - loads of the Deoxit stuff now. Weird I thought it was rare as hens teeth.

This is what I use:

http://www.ebay.co.uk/itm/CAIG-DEOXIT-D5-CONTACT-CLEANER-SPRAY-/350621875175?pt=UK_Sound_Vision_Audio_Cable_Terminations&hash=item51a2b13be7

Thanks I'll need to look at the brake pedal - it's quite corroded underneath - flaking away gradually.

Thanks mate
Dave


__________________________________________________
1991 K100 RS 16 valve
    

13Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 10:43 am

charlie99

charlie99
VIP
VIP
motobins or motoworks for a second hand unit maybe ?

then before you fit it ...the magic paint that halo uses ? kbs or something ?

thats a ton of stuff in a can dave ...should last a lifetime in weight ...but we all know how wasteful preasure packs can be ...eh ?


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OABS woes Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

14Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 10:48 am

MT350Explorer

MT350Explorer
Life time member
Life time member
Yeah no worries thanks Charlie - there's a heap of them on Ebay and I'm sure from the the 'Bins and 'Works as well. Will need to just check the fitting and will look in to the magic paint!

Cheers
Dave


__________________________________________________
1991 K100 RS 16 valve
    

15Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 11:26 am

Inge K.

Inge K.
VIP
VIP
The same pedal is used on all models, when the new switch came (09/86)
...the footrest bridge was changed.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

16Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 12:02 pm

charlie99

charlie99
VIP
VIP
thanks inge ...! always good to know ....cheers mate !


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OABS woes Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

17Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 12:41 pm

MT350Explorer

MT350Explorer
Life time member
Life time member
Cheers Inge, thanks!


__________________________________________________
1991 K100 RS 16 valve
    

18Back to top Go down   ABS woes Empty Re: ABS woes Sat Nov 10, 2012 4:51 pm

sidecar paul

sidecar paul
Life time member
Life time member
The rear brake levers seem to disintegrate alarmingly, I've got through several............but I've never seen any corrosion on the gear lever scratch

(Is it a different alloy?)

Paul.


__________________________________________________
'84 K100RS (0014643) (owned since '85), 86 K100RS (0018891) with Martello sidecar (built as an outfit in '88),
'51 Vincent (since '67),'72 Montesa Cota (from new), '87 Honda RS125R NF4 (bought 2015) 
....No CARS never ever!
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum