BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Headlight main beam not on. Empty Headlight main beam not on. Tue Jan 01, 2013 12:58 pm

BooG

BooG
Platinum member
Platinum member
Just bringing the K75 back to life after being rained on for 2 weeks over Christmas....battery flat, so on charge....replaced some instrument cluster bulbs.
I have noticed that the main headlight is not functioning. the high beam position works off the right hand switch, as does the high beam flash switch on the left. I changed the headlight bulb, but there was no difference. Can anyone point me to the next port of call??
Thanks....and happy new year!!

    

2Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Tue Jan 01, 2013 2:28 pm

Inge K.

Inge K.
VIP
VIP
A quite common problem at our K's, which most of the time is related to the LHS switch assy, which must be dismantled and cleaned/repaired if possible.

Have a look at this link.

Could also be the connector under the tank for this switch assy, but that isn't that much likely.

When you get it to function again, install headlight relays, to avoid this problem.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

3Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Tue Jan 01, 2013 2:51 pm

K-BIKE

avatar
Life time member
Life time member
Could not agree with Inge more strongly about using relays because when you look at the switch innards the first thought is you cannot be serious, what useless swine designed this? Call those contacts I would only rate them for a torch bulb. Sadly that is not a problem unique to K's all bikes and cars are designed down to the lowest fraction of a cent. Using a relay set will make the lighting much more reliable, the easiest way is to use a relay kit from Jim at Eastern Beaver they are very reasonably priced and he does heavy duty waterproof relay kits with ceramic bulb connectors to allow higher wattage bulbs to be used. His kit is really simple to install and leaves the original wiring unchanged because the drive from the relay coils comes off the socket that was used for the bulb. A new heavy duty power cable runs from the relays to the battery via a fuse which is part of the kit he supplies. Installation is a no brainer and very quick, delivery is quick too. The web address is http://www.easternbeaver.com/Main/main.html
Regards,
K-BIKE

    

4Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Tue Jan 01, 2013 4:01 pm

BooG

BooG
Platinum member
Platinum member
Tremendous info!! I'll have a bash at the switch tomorrow and see what occurs.
Thanks alot! Very Happy

    

5Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Tue Jan 01, 2013 4:10 pm

Inge K.

Inge K.
VIP
VIP
It would be a smart idea to disconnect the switch from the bike,
and dismantle/open it at the kitchen table......when SWMBO is out of the door.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

6Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Wed Jan 02, 2013 5:59 am

BooG

BooG
Platinum member
Platinum member
Am I greasing the contact points on re-assembly? What is best to use?

    

7Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Wed Jan 02, 2013 6:37 am

klompy the grey brick

klompy the grey brick
VIP
VIP
Hiya BooG;

Here is another hint...as these bikes are really "mature" age now what is the chance the electrics have lasted this long and now have given up the ghost....check to see if you already have relays fitted and see if these have fuses...and if these fuses are ok.....personal experience talking here.Embarassed


__________________________________________________
KKlompy Headlight main beam not on. 2854237993
"Grace" 1984 K100RS Silver VIN 0019026 Mitt eine Staintune Zorst.
"Olivia" 1997 K1100LT Dark Grey VIN WB1052600W0237453.









Chassis number0019026
Vehicle code0503
SeriesK589
ModelK 100 RS 83 (0502 ( 0503 )
Body typeK 100 RS 83 (0502
Catalog modelECE
Production date1984 / 07
Engine0513)

Headlight main beam not on. Au-log10


    

8Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Wed Jan 02, 2013 6:40 am

twincarb

twincarb
Life time member
Life time member
I decided not to in the end as I didn't want to risk attracting more dirt in there... What I did to was use Deoxit to assist with the cleaning and left a coating of it in place....

If you wanted to use a specific type grease to prevent water ingress and something like Maplins silicon dielectric grease would do the trick...

Maplin Grease


__________________________________________________
BMW K100LT 1988 Matt Black Peugeot Electra Blue (ELX) Colour is now confirmed...
Yamaha Thundercat
Triumph Spitfire (not a bike but hell it's British chaps)
Headlight main beam not on. 169042 Headlight main beam not on. 169034
    

9Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Wed Jan 02, 2013 7:07 am

BooG

BooG
Platinum member
Platinum member
Thanks guys! I will do the same regarding the contacts and will explore the relay situation also. I am cleaning it all up on the kitchen table as we speak.

    

10Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Wed Jan 02, 2013 5:57 pm

K-BIKE

avatar
Life time member
Life time member
Just don't get the silicone grease on the contacts.
Regards,
K-BIKE

    

11Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Wed Jan 02, 2013 8:41 pm

Inge K.

Inge K.
VIP
VIP
+1.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

12Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Sat Mar 02, 2013 6:17 pm

mr grumpy

mr grumpy
Silver member
Silver member
I have a rather alarming delay, i.e. no light at all for a second or two, when switching from dip to main beam, and I suspect that this topic may have already supplied an answer. I recall that my R75/6 had a headlight relay 35 years ago so why do the K bikes not use this obvious expedient?


__________________________________________________
K100RS 16v
    

13Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Sat Mar 02, 2013 7:28 pm

Ed

Ed
Life time member
Life time member
Mr Grumpy,have you checked your switch contact.
mine lost contact, still gave me low beam, but no high.
good luck with it.


__________________________________________________
1993 K1100RS  0194321         Colour #690 Silk Blue  aka " Smurfette"
2018 Kart upgrade.
Headlight main beam not on. 10_x_110
    

14Back to top Go down   Headlight main beam not on. Empty Re: Headlight main beam not on. Sun Mar 03, 2013 12:27 pm

AJ.Valente

AJ.Valente
Life time member
Life time member
Been there, done that. Most likely from lack of use the light switch becomes hard to move and sticks in-between positions.
Consider removing the switch and putting a drop (one drop) of super oil on each of the switch hinges, then work the switch until it moves freely. Should work just fine thereafter. :bball:

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum