BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Fuel pump or relays ? Empty Fuel pump or relays ? Thu Jan 31, 2013 2:49 am

ausbrick

ausbrick
Silver member
Silver member
Hi all . I have had trouble with my latest family member (86 k 75 c )on my first long run it conked after350 ks of a very enjoyable days testing , I decided it was the fuel filter clogged up and did a flush of the tank and new filter which seemed to sort things out until recently it cut out again. Wondering if any one has had trouble with relays after the pump has cut out due to overheating from a blocked filter , can this sort of epiode damage the relays. My friend has had a similar problem with his 85 k100 rs both these bikes had been parked for extended periods and stopped after several hundred ks now they cut out intermitantly usually after running for an hour. (lesson always flush tank and install a new filter on a long time unused k). any ideas on the cause as its made me a bit hesitant on using it for long runs .pity as its a really pleasant little bike to ride.Cheers Brick

    

2Back to top Go down   Fuel pump or relays ? Empty Re: Fuel pump or relays ? Thu Jan 31, 2013 3:35 am

charlie99

charlie99
VIP
VIP
hmm

a few things we find brick ....

have a look a the tank connector , its a four pin connector at the back of the tank ..., the connection sits just under the seat on the drivers right hand side ..

we have seen quite a few of these become corroded ...or loose ....the socket part of the connector expands ...you may have to pinch it together somewhat

the fuses and holders sometimes become intermitent also ...i believe fuse 7 (bottom one ) is what your looking for

take the fuse out and inspect it ....perhaps replace ....keep in mind that the fuse carrier often corrode up also ....

we have found that DEOXIT is a great corrosion fighting fluid for all things electrical look at jaycar for this item

of corse the fuel pump being a roller cell is also prone to fail ....but ill leave that for others ...there are lots of posts about hat in the forum

try using the "search " feature

hope that helps



Last edited by charlie99 on Thu Jan 31, 2013 3:37 am; edited 1 time in total


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OFuel pump or relays ? Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

3Back to top Go down   Fuel pump or relays ? Empty Re: Fuel pump or relays ? Thu Jan 31, 2013 3:36 am

RicK G

RicK G
admin
admin
Good chance it's a fuel pump they are noted for playing up after an extended lay of.
Now what ever you do don't buy an OEM pump. Any of the pumps that run a Bosch FI system from that era will do the job, all that is needed is the right pressure and volume. I am currently using a pump from an ED ford falcon sedan with a sleeve around it so that it fits into the rubber vibration damper, you will also need to change the electrical connectors to the spade type.
I have done this a few times and I know of others that have done it and it works well. I buy a generic pump on fleabay for around $60


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

4Back to top Go down   Fuel pump or relays ? Empty Re: Fuel pump or relays ? Thu Jan 31, 2013 3:26 pm

sidecar paul

sidecar paul
Life time member
Life time member
+1 for the pump connector.

Also the ignition switch could need some attention.

Paul.


__________________________________________________
'84 K100RS (0014643) (owned since '85), 86 K100RS (0018891) with Martello sidecar (built as an outfit in '88),
'51 Vincent (since '67),'72 Montesa Cota (from new), '87 Honda RS125R NF4 (bought 2015) 
....No CARS never ever!
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum