BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   I replaced the battery now will not start Empty I replaced the battery now will not start on Thu Apr 25, 2013 9:47 pm

10-ring

10-ring
Silver member
Silver member
Hi
Three weeks ago had to jump start the K went for a short ride all was right with the world. 2 Weeks of rain and cold
Last weekend tried to start with out jumping dead battery. Found a battery (it was a 1/2 in taller had to make a new tie down braket) Went to start but nooo won't start. now I have a little gas dripping from exhaust. I think it's flooded
Please tell me what todo next?
I was going to pull the plugs but now it's dark.
Thanks I know you will get me back on the road.

    

RicK G

RicK G
VIP
VIP
Check the plug on the ECU (computer) is seated home properly, its a common problem after having it out. Dry the plugs with a flame, the Ks are a bit prone to being grumpy when the plugs get wet.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1993 K1100 LT, 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki X 2 for now
    

ibjman

ibjman
Life time member
Life time member
I don't want to sound overly stupid but........is everything else working correctly? I assume the starter is working ok?
I have been known in my past to actually install the battery wrong way around (polarity incorrect).
Lets hope the 1st suggestion above is the one that works. As stated there, inplug the Jetronic computer and reconnect it "firmly" to make sure the metal retaining clip clicks in.
Please keep us up to date on what you find.

    

10-ring

10-ring
Silver member
Silver member
No such thing as stupid question's But yes starter is spinning it's trying to come to life.
By the way I think the cardinals got a good gard in the draft tonight

    

10-ring

10-ring
Silver member
Silver member
It's alive
After pulling plugs cleaning them
putting freash gas making sure all conections are tight
checking anything I could think of
turn the key and after a couple turns VROOOOOM the old gril came to life
Thanks for all the help
Now I see she needs new shoes (tires) the back one looks a little square but went for a short run anyway.
Thanks

    

Crazy Frog

Crazy Frog
admin
admin
@10-ring wrote:It's alive
After pulling plugs cleaning them
putting freash gas making sure all conections are tight
checking anything I could think of
turn the key and after a couple turns VROOOOOM the old gril came to life
Thanks for all the help
Now I see she needs new shoes (tires) the back one looks a little square but went for a short run anyway.
Thanks

If after replacing the battery the starter turns but the bike doesn't start and get flooded, in 99.9% of the time, this is because the FI computer plug (under the tool box) is not seated correctly.

CF


__________________________________________________
I replaced the battery now will not start Frog15I replaced the battery now will not start Logo2101986 k75, 1985 K100rt, 1985 K100rt/EML GT2 sidecar, 1999 K1200lt/Hannigan Astro Sport sidecar.
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum