BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Happy blinkers Empty Happy blinkers on Sat Jun 07, 2014 4:55 pm

ReneZ

ReneZ
Life time member
Life time member
I have an interesting one (I think :-) ). My right indicator works OK, the left as well, but when I use the left one the right one comes on every other 'blink'. I have already cleaned up the ground/earth/mass points and haven't found my spare blinker relay yet to try a swap. Bike has 40K miles, so doubt the starter motor, but will have a dig and a clean-out there as well. Any ideas?


__________________________________________________
Greetings from Florida! Having a 'new' K  :cyclops:    Surprised-o: 

Rene


BMW K100 - 1985 (0030029) Happy blinkers Rain
BMW K1200GT - 2003 (ZK01223)
    

2Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Mon Jun 09, 2014 12:29 pm

k75RT Keith

k75RT Keith
Silver member
Silver member
Mine had the same problem.  Cleaned the starter, grounds and the combination switch connectors under the tank.  Seems to have resolved the problem

    

3Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Tue Jun 10, 2014 4:28 am

RicK G

RicK G
VIP
VIP
Replace the #7 fuse as if they are a bit sus you get those problems


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

4Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Tue Jun 10, 2014 3:17 pm

orforester

orforester
Silver member
Silver member
I agree, clean the starter, or in my case I installed new brushes, cured the whole issue.  It is weird K bike thing, but lots of strange electrical issues develop from the starter.

Mine was the blinkers coming on when I pushed the starter button, and when I went from ignition to "park" at the switch.   Another time I forgot to tighten down the starter bolts and it wiggled just a little with vibration, making the brake light come on and off, or not at all when I applied the brakes.

Weird stuff, again, order new brushes, they are cheap and end the electrical gremlins.


__________________________________________________
89 K 100 RS se
85 K 100 RT
    

5Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Sat Jun 21, 2014 8:37 am

BooG

BooG
Platinum member
Platinum member
I have a similar issue with the signals on y K75S. Left works no prob. Right works at very low tickover, but when the revs come up, right behaves like hazzard warning! Have done brushes in starter and cleaned connections...no change! still looking!!!

    

6Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Sun Jun 22, 2014 6:55 am

RicK G

RicK G
VIP
VIP
Having a bad #7 fuse can do much the same things. Replace it even if it looks good they corrode internaly and go open circuit without being blown.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

7Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Wed Aug 06, 2014 5:05 pm

Snod Blatter

Snod Blatter
Life time member
Life time member
Last week I suddenly had a strange issue where the indicators wouldn't work at low revs but would sort of work at above 3K RPM, only they indicated mostly the wrong way or gave me hazards no matter which direction I pressed, or even the cancel button. I took the tank off and cleaned all the connector blocks underneath as well as cleaning up the earth point with the stud and a nut. The indicators stayed the same after all that.. But a quick look on here brought this thread up and lo and behold #7 fuse was blown. Thank you, Rick G. Now, how often do these fuses blow.. The one I just replaced looked disturbingly new!


__________________________________________________
1989 K100RS SE ABS 8v  VIN: 0149214
Others: 1.5 x Honda CBX250RS-E, '94 CB250, '95 TRX850, '16 Z250SL
http://justbikethings.blogspot.co.uk/
    

8Back to top Go down   Happy blinkers Empty Re: Happy blinkers on Wed Aug 06, 2014 7:47 pm

ReneZ

ReneZ
Life time member
Life time member
I replaced the relays and the problem was over. Luckily I had a spare laying around as they can be a bit expensive....


__________________________________________________
Greetings from Florida! Having a 'new' K  :cyclops:    Surprised-o: 

Rene


BMW K100 - 1985 (0030029) Happy blinkers Rain
BMW K1200GT - 2003 (ZK01223)
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum