BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Eratic right signal Empty Eratic right signal Sat Jun 21, 2014 9:51 am

BooG

BooG
Platinum member
Platinum member
Left is fine. Right only functions at very low revs, and then goes into hazzard warning mode when revs pick up.
Have done the starter brushes.
Could it be a relay fault? 
Wouldn't that affect the left signal as well?
Why is the flasher relay so expensive compared to the others?
Gonna look at the fuses next....
So many questions........!!!

    

2Back to top Go down   Eratic right signal Empty Re: Eratic right signal Sat Jun 21, 2014 10:11 am

Inge K.

Inge K.
VIP
VIP
@BooG wrote: Could it be a relay fault? 
Not impossible.

@BooG wrote: Wouldn't that affect the left signal as well?
Separate output circuits, with own contact sets and coils.

@BooG wrote: Why is the flasher relay so expensive compared to the others?
It's a rather advanced little bugger.

@BooG wrote: Gonna look at the fuses next....
Pay especially attention to # 3 and 7.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

3Back to top Go down   Eratic right signal Empty Re: Eratic right signal Sat Jun 21, 2014 2:07 pm

BooG

BooG
Platinum member
Platinum member
Thanks for answers!
All checks done...fuses done etc.
I've noticed that as revs increase, firstly the signals both flash out of phase, and when revs reach a certain amount, then the signals gradually flash closer together, finally in phase (as if hazzards). 
A bad earth wouldn't behave like that?
Voltage increase makes prob worse, but only on right side.
So: relay has separate circuits internally. Is it possible to open and investigate it? Any diagrams?
Any one else got any pointers??

    

4Back to top Go down   Eratic right signal Empty Re: Eratic right signal Sat Jun 21, 2014 4:20 pm

Inge K.

Inge K.
VIP
VIP
@BooG wrote: A bad earth wouldn't behave like that?
The most common problem is that one of the input power sources is missing,
and the strange behaviour starts.
But very strange things also happens when electronic circuits have bad ground, so........
You have of course checked the relay terminals and socket....

@BooG wrote:Voltage increase makes prob worse, but only on right side.
Long shot: do you got a early hazard switch with three wires, the power to the
pilot bulb in the switch is routed from the right hand side output.

@BooG wrote:Is it possible to open and investigate it?
Yes, you could check for bad solder points.


@BooG wrote:Any diagrams?
https://www.k100-forum.com/t4129-flasher-relay-circuit-wiring-diagram


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

5Back to top Go down   Eratic right signal Empty Re: Eratic right signal Sat Jun 21, 2014 5:55 pm

BooG

BooG
Platinum member
Platinum member
I'll soldier on!!
Thanks for the pointers...you rock my world!

    

6Back to top Go down   Eratic right signal Empty Re: Eratic right signal Mon Jun 23, 2014 4:33 pm

two66mhz

two66mhz
active member
active member
I will confirm shady ground with high resistance will cause all sorts of messed up things to happen. (I had a lot of fun in automotive school creating problems for other students to fix, shared ground by far create the most entertaining issues).

I would also recommend to double check your Voltage Regulation. I.E. Idle Voltage at Battery and when under load. Use "Powered Bike Off" as a "Control" Voltage. I have seen power regulations cause similar issues.

If all else checks out good, there could be the possibility of wires being worn and are shorting. Finding these is time consuming. If my K-Bike is any testament it is a very strong possibility.

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum