BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   K75S misfiring when cold Empty K75S misfiring when cold on Sun Aug 17, 2014 9:54 am

john dorman

john dorman
New member
New member
I have a 93 K75S that is misfiring when cold,once I coax it over 3th revs it runs better. Have checked the fuel & air filters ( cleaned out the mouse nest in airbox ) but still runs poorly  when cold . Any suggestions on what to check would be appreciated. JD

    

2Back to top Go down   K75S misfiring when cold Empty Re: K75S misfiring when cold on Sun Aug 17, 2014 10:02 am

RicK G

RicK G
VIP
VIP
Make sure all the electrical connections on the ignition are good, pull the plug caps and check the little bobbins are on the top of the plugs and that the leads are connecting, white powdery stuff is a give away to a bad connection on the high voltage side. Even replace the plugs.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1993 K1100 LT, 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki X 2 for now
    

3Back to top Go down   K75S misfiring when cold Empty Re: K75S misfiring when cold on Sun Aug 17, 2014 11:51 am

charlie99

charlie99
VIP
VIP
aye +1 on that


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OK75S misfiring when cold Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

4Back to top Go down   K75S misfiring when cold Empty K75S misfiring on Thu Aug 21, 2014 9:10 am

john dorman

john dorman
New member
New member
Put a set of new plugs in and she's running like new!

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum