BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   K100 RS 1987 Running/Reving problem! Empty K100 RS 1987 Running/Reving problem! Mon May 25, 2015 6:15 pm

Jecht

Jecht
New member
New member
Hi everyone!, 

Looking for some decent diagnostic advice, or solution if anyone knows how!

I just built a cafe racer, gone to start for the first time and the bike is revving up full throttle on its own accord!!! throttle cable and choke cable are free, and i have tried removing the throttle position sensor and turning it to see if it makes a difference but its still the same!

i have replaced the fuel filter,(along with fuel pump vibration damper) replaced fuel lines and air filter, and o rings on the injectors

just thought id let you all know what i have touched/ disturbed! 

Im trying to think of ways to fix this, im thinking maybe the fuel pressure regulator, or maybe the MAF sensor is at fault, im certainly hoping its not the E.c.u

im happy to supply pictures if needed to aid this repair!

many thanks 

Jecht! K100 RS 1987 Running/Reving problem! 212902

    

Dai

Dai
Life time member
Life time member
Go down to the lower end of the throttle cable to where the cable quadrant is (the quarter- or half- circle bit that the throttle cable runs over). Check that the quadrant is not fouling on one of the throttlebodies. This is a common problem where the original clamps have been replaced by worm drives (jubilee clips). Also check that the throttle stop screw is not wound out and stopping the throttles from closing.


__________________________________________________
1983 K100 upgraded to K100RS spec, 1987 K100RT
Others...
1978 Moto Guzzi 850-T3, 1979 Moto Guzzi 850-T3 California,1993 Moto Guzzi 1100ie California
2020 Royal Enfield Bullet 500
    

Jecht

Jecht
New member
New member
Thanks for your reply Dai, excuse my newbness but where on the throttle body is the stop screw? I can move the throttle arm up and down using my finger or the throttle but I will double check the cable quadrant

    

Dai

Dai
Life time member
Life time member
What you call the 'throttle arm' and what I've referred to as the 'quadrant' (because of its shape) are most likely the same thing - the bit where you loop the bottom end of the throttle cable inner over. The throttle stop screw is item 20 on this diagram:

http://www.realoem.com/bmw/enUS/showparts?id=0511-USA-03-1984-K589-BMW-K_100_83_0501,0511_&diagId=13_0515

When the throttle is closed there should be no gap under that screw. If there is, something is fouling one or more of the throttle body actuating arms somewhere.


__________________________________________________
1983 K100 upgraded to K100RS spec, 1987 K100RT
Others...
1978 Moto Guzzi 850-T3, 1979 Moto Guzzi 850-T3 California,1993 Moto Guzzi 1100ie California
2020 Royal Enfield Bullet 500
    

Cleverbee

Cleverbee
active member
active member
Just had the same with my LT running like a dog that lost the will to live.  After replacing the MAF, coils, HT leads, TPU - turned out to be dodgy Water Temp Sensor  Embarassed Embarassed Embarassed Embarassed

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum