BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


Dai

Dai
Life time member
Life time member
A checklist to add to all the others. Assumption: the battery is good and the starter relay is not welded together.

Symptoms:

1. Turn on - the coolant light, oil light and generator light might come on. The main lights (headlight etc.) don't work.
2. If those three lights are on, hitting the starter button activates the starter relay and those three lights go out. No engine turnover. The fuel pump only runs as long as the starter button is pressed and stops as soon as the button is released.
3. Pulling fuse no.1 allows the main lights to work again but of course, no starter circuit.

Your killswitch has corrosion in it and is only making intermittant contact. Two unrecoverable hours to find that little smurf.

[Edit] An additional symptom is that you may get your coolant temperature light coming on for no reason when the headlights are on and you switch to main beam. I didn't originally list this because I wasn't sure if it was connected or not, but since I cleaned the killswitch that bit of irritation has also gone away.



Last edited by Dai on Wed Jan 09, 2019 6:04 pm; edited 2 times in total


__________________________________________________
'83 K100 upgraded to K100RS spec
Others...
'78 Moto Guzzi 850-T3, '79 Moto Guzzi 850-T3 California,'93 Moto Guzzi 1100ie California,
'03 Suzuki Blandit GSF600SK3 (NFS any more because wifey has claimed it)
    

chris846

chris846
Life time member
Life time member
2 hours?

You did good


__________________________________________________
The Longest Lunch
    

duck

duck
Life time member
Life time member
Suggestion: Add "Start Kill Switch" to the title so people can find it when searching.

Starter motor doesn't work - problem solved start kill switch killswitch TdI7xEr


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
http://www.ClassicKBikes.com
    

Dai

Dai
Life time member
Life time member
Duck: good idea - done.

Chris: that involved swapping out all the relays (including the starter relay), FICU and ICU to eliminate those before having to dig into the wiring. Having got that far with no results, I pulled, cleaned and reseated the connector block, after which the bike fired up once and refused again. I looked at it, figured out that of course I'd disturbed the wiring to the handlebar switch and so it had to be the killswitch: thus it proved to be.


__________________________________________________
'83 K100 upgraded to K100RS spec
Others...
'78 Moto Guzzi 850-T3, '79 Moto Guzzi 850-T3 California,'93 Moto Guzzi 1100ie California,
'03 Suzuki Blandit GSF600SK3 (NFS any more because wifey has claimed it)
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum