BMW K bikes (Bricks)

  • View posts since last visit
  • View your posts

Logged in as Anonymous. Your last visit was on

You are not connected. Please login or register

Go to page : 1, 2, 3 ... 15 ... 30  Next

Topics [0]

TopicsRepliesViewsLast Posts
No new posts   

87 K100 elec. gremlins

   by Jerry001
 Power only to tail light
3146avatarYesterday at 4:51 am by Inge K. View latest post
No new posts   

Help to identify connectors and more

   by ERasberg
 K100RS '88
23298avataron Fri Oct 20, 2017 2:55 pm by KiwiK100 View latest post
No new posts   

Ignition switch

   by captaink
111692avataron Wed Oct 18, 2017 7:43 pm by Ace Handler View latest post
No new posts   

Anyone have a picture of the instrument cluster connector? (PFA)

   by boostd4
9228avataron Wed Oct 18, 2017 5:59 am by 92KK 84WW Olaf View latest post
No new posts   

How to get a cheap eBay Speedo to work

   by Jacod
 All of it works but the TGPI To hopefully save any future tin bums some time I have explained below how I managed to get the speedo to work.
163926avataron Tue Oct 17, 2017 2:32 pm by Gr-Racing View latest post
No new posts   

My "latest and greatest" LED brake and tail lighting - simple and dirt cheap to boot!

   by duck
7228avataron Sat Oct 14, 2017 9:00 pm by Laitch View latest post
No new posts   

Battery keeps dying on me

   by AndrewP
 Starts the bike but eventually dies
15450avataron Mon Oct 09, 2017 5:17 am by charlie99 View latest post
No new posts   

turn signals

   by BooG
21388avataron Sun Oct 08, 2017 5:50 pm by BooG View latest post
No new posts   

Ignition switch replacement wiring - Which wires do I need?

   by Snod Blatter
14173avataron Sun Oct 08, 2017 3:30 pm by Snod Blatter View latest post
No new posts   

GEAR INDICATOR - LCD

   by WINGLESS
 Display faint
21358avataron Sat Oct 07, 2017 7:02 am by Laitch View latest post
No new posts   

throttle balance - bike won't go again...

   by Cablebeacher
 throttle balance - bike won't go again...
12190avataron Fri Oct 06, 2017 1:15 am by Point-Seven-five View latest post
No new posts   

Immobiliser/Alarm

   by DBRMN
590avataron Thu Oct 05, 2017 5:21 am by 92KK 84WW Olaf View latest post
No new posts   

Opening the Motronic Box

   by Bonzo
10189avataron Mon Oct 02, 2017 3:31 pm by Motorbike Mike View latest post
No new posts   

AGM battery capacity

   by nino
13328avataron Sat Sep 30, 2017 12:36 pm by Vitamin K View latest post
No new posts   

Headlight assembly removal

   by nino
15260avataron Sat Sep 30, 2017 11:47 am by Ace Handler View latest post
No new posts   

Motronic pin number identification

   by KiwiK100
19340avataron Fri Sep 29, 2017 3:33 am by KiwiK100 View latest post
No new posts   

Fuel level sender wiring brittle/broken

   by Bergman
294avataron Thu Sep 28, 2017 8:14 am by Bergman View latest post
No new posts   

Alternator fix

   by Phil63
11539avataron Tue Sep 26, 2017 10:42 pm by AndrewP View latest post
No new posts   

Indicator stuck on-anyone else had this issue?

   by Motorbike Mike
11139avataron Tue Sep 26, 2017 6:19 am by Garyk100 View latest post
No new posts   

SPEEDO NEEDLE DROPPED BELOW 0 - HELP NEEDED PLEASE:)

   by Tarlin
4191avataron Sun Sep 24, 2017 3:08 pm by Tarlin View latest post
No new posts   

Wiring Diagram for Alarm Unit

   by Loner0831
277281avataron Sun Sep 24, 2017 9:39 am by geharper View latest post
No new posts   

Fuel tank Electrical

   by DaleRT
592avataron Sun Sep 24, 2017 9:12 am by charlie99 View latest post
No new posts   

Odometer and Speedometer Repair

   by flyinglow
 Recomendations on places to repair this assembly
4138avataron Fri Sep 22, 2017 12:50 pm by Laitch View latest post
No new posts   

Fuel level lights

   by timo27
089avataron Wed Sep 20, 2017 1:55 am by timo27 View latest post
No new posts   

Fuel pump not priming

   by audibob
9185avataron Sun Sep 17, 2017 2:25 am by uhoh7 View latest post
No new posts   

odometer doesn't work (,speedometer ok)

   by mquadro
8323avataron Fri Sep 15, 2017 6:53 am by Dai View latest post
No new posts   

What is this lock for?

   by Bucky
 There is a lock on the side of the fuse box?
13507avataron Tue Sep 12, 2017 9:44 pm by Bucky View latest post
No new posts   

An alternative way to get the Gear Position Indicator to work on an aftermarket speedo

   by Jacod
7657avataron Sun Sep 10, 2017 3:44 pm by KevinGuy View latest post
No new posts   

Please help! Maybe bad CDI or other??

   by 53cr3t5quirr31
 I need some expert advice with trouble shooting
15231avataron Thu Sep 07, 2017 8:56 am by duck View latest post
No new posts   

Battery help

   by floyd
 Let me clean the egg of my face first
15326avataron Wed Sep 06, 2017 6:55 am by MartinW View latest post
No new posts   

Rear brake light problem

   by Daytonadave
361814avataron Wed Sep 06, 2017 5:12 am by critter View latest post
No new posts   

Turn signal woes

   by Woodie
15589avataron Tue Sep 05, 2017 9:24 pm by Woodie View latest post
No new posts   

Speedometer weirdness!

   by Brickboy
 K1 speedo displaying strange readings.
4164avataron Tue Sep 05, 2017 9:49 am by RicK G View latest post
No new posts   

ABS issue on 91 K100RS

   by Overkill
 ABS problem
194avataron Mon Sep 04, 2017 9:57 pm by duck View latest post
No new posts   

Motogadget M-Unit Blue Install

   by FreyZI
391154avataron Thu Aug 31, 2017 10:58 pm by FreyZI View latest post
No new posts   

Cluster removal how to?

   by SniperX
9204avataron Thu Aug 31, 2017 8:31 am by 92KK 84WW Olaf View latest post
No new posts   

Cluster removal led neutral light

   by timo27
6161avataron Tue Aug 29, 2017 4:09 pm by robmack View latest post
No new posts   

86 K100 - bouncy tach needle

   by duck
5252avataron Sun Aug 27, 2017 10:34 pm by duck View latest post
No new posts   

Oil pressure light

   by timo27
7190avataron Sat Aug 26, 2017 10:03 am by Corkboy View latest post
No new posts   

Indicator brings on hazard lights

   by Fliggy
 RHS indicator = Hazards
251136avataron Wed Aug 23, 2017 5:15 pm by sidecar paul View latest post
No new posts   

'85 K100RT

   by ibwillis
 Need help
7202avataron Wed Aug 23, 2017 12:35 pm by 92KK 84WW Olaf View latest post
No new posts   

Fuel sending unit ideas?

   by KJustin
9524avataron Wed Aug 16, 2017 6:34 am by charlie99 View latest post
No new posts   

Karamba speedometer calibration program

 [ 1, 2, 3 ] by robmack
1336992avataron Sat Aug 12, 2017 2:41 pm by Ace Handler View latest post
No new posts   

Starting without original speedometer

   by Laapottij
 start working engine turning but not starting
13307avataron Thu Aug 10, 2017 8:28 pm by 92KK 84WW Olaf View latest post
No new posts   

Solid non-flashing ABS light in cluster (K1100 ABS I)

   by duck
197avataron Thu Aug 10, 2017 12:40 pm by Point-Seven-five View latest post
No new posts   

A shout to the Irish!

   by club_c
3202avataron Tue Aug 08, 2017 6:09 am by 92KK 84WW Olaf View latest post
No new posts   

Do all K models have self canceling turn singals?

   by boostd4
1169avataron Sat Aug 05, 2017 3:28 pm by duck View latest post
No new posts   

Sudden no start with starter button, where to check next? [RESOLVED]

   by boostd4
22377avataron Sat Aug 05, 2017 2:54 am by RicK G View latest post
No new posts   

Help needed - sudden troubles with starter motor, front light & instruments lights

   by ffbikersa
 Engine won't start, lights go off
7132avataron Fri Aug 04, 2017 5:46 pm by ffbikersa View latest post
No new posts   

gearshift decoding for aftermarket instruments

   by charlie99
344025avataron Fri Jul 28, 2017 3:11 am by maz_dede View latest post

Topics [50]

  Back to top

Go to page : 1, 2, 3 ... 15 ... 30  Next

Moderators : Admin, K-BIKE, Crazy Frog, Moderators

Users browsing this forum: None

Permissions in this forum:
You cannot post new topics in this forum
You cannot reply to topics in this forum

  • No new posts No new posts
  • New posts New posts
  • New posts[ Popular ] New posts[ Popular ]
  • New posts[ Locked ] New posts[ Locked ]