BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Fuel pump not pumping Empty Fuel pump not pumping Thu Jul 28, 2022 10:18 pm

BendK100

BendK100
active member
active member
I'm almost done rebuilding a 1985 K100 and the fuel pump is making noise but nothing is getting to the fuel rail. Before I tore it apart and rebuilt it, it was working fine. The tank sat empty for about 5 months so not sure if that could cause it. There was a lot of gunk in the tank when I first emptied it.

    

2Back to top Go down   Fuel pump not pumping Empty Fuel pump not pumping. Fri Jul 29, 2022 12:41 am

daveyson

daveyson
Life time member
Life time member
Can you give more details and how you came to your conclusion, cause there are a few possibilities. For example maybe the pump is pumping but simply a hose in the tank has popped off. Hopefully it's something simple like that.


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

3Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Fri Jul 29, 2022 3:16 pm

BendK100

BendK100
active member
active member
I rewired the bike using a mo.unit and bypassed the fuel injection relay for the pump power supply. So, when I switch on the ignition, the fuel pump is given power and I can hear it run (hard to miss the loud hum). The bike would not start, so I began to diagnose what it could be. I saw that the plugs were sparking so next I disconnected the fuel rail and saw the injectors were not firing. Instead of dig into their wiring, I checked if there was fuel and that was the problem.

I disconnected the fuel line from the rail and aimed it into an empty gas can and nothing came out when I ran the fuel pump. I just changed the fuel filter yesterday but that did not change anything. The small tube connecting the filter was pretty deteriorated but had no leaks (I replaced it). the other lines all looked good and connected.

Not sure if this means anything, but I have about a half tank in there when testing and I don't see any ripples or movement on the surface when the pump runs.

In summary, I can hear the pump making noise but nothing is coming out of the hose.

    

4Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Fri Jul 29, 2022 4:40 pm

Laitch

Laitch
Life time member
Life time member
BendK100 wrote:This is my first time doing more than basic maintenance on a bike - I was going to go with a simpler 80's Honda for a first try, but I found this 85 k100 in my town and couldn't say no.
If there was gunk in the tank, there is likely to be gunk in the fuel pump and gunk in the fuel injectors that has become semi-solid in the last five months and is obstructing fuel flow.

The small hose from the pump filter basket to the tank ceiling has no effect on fuel flow from a properly working pump in a tank with a couple of gallons of fuel, but a deteriorated screen in that filter could allow gunk to clog the pump. That screen is the pump and injector components' first line of defense against contaminated fuel.

This might seem like an old-fashioned idea but you should read through this entire troubleshooting guide from beginning to end. It, and many other helpful guides, are found in the Tech Page accessed in this site's Portal. It is possible that it will give you an understanding of how each component works and interacts with the others.

Right now, your description of the starting sequence is unlike how an unmodified Brick works.


__________________________________________________
1995 K75 81,000 miles
Fuel pump not pumping Usa-lo10
    

5Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Sun Jul 31, 2022 4:21 am

BendK100

BendK100
active member
active member
Thanks for posting that extensive electrical/starting trouble shooting guide. I gave it a quick read before but I just intensively re-read the whole thing. Unfortunately, it didn't get me further on the fuel pump issue.
Fuel pump not pumping Screen10

I'm at this step of the troubleshooting chart. I have an 85 which did not come with a fuel pump relief valve - and it was working before without so I doubt that is the issue.

Fuel pump not pumping Img_4311

I removed the fuel pump, and while there was a little gunk on the mesh filter, it was definitely clean enough for enough gas to pass through. While it was out, I also tested that it was indeed pumping when connected to an external battery. All internal fuel lines where also replaced and I ran a wire through the metal lines to ensure there was no blockage there. After cleaning and reinstalling, it still did not push any fuel to rail. I removed the tube directly connected to the pump and nothing came out even though it was running. From my understanding, the intake is just sitting fuel in the tank, so I don't see why is would pump outside the tank by not in. My last guess is that the power is not enough, but if it's making noise I would assume it has enough power to at least get a trickle out of the top while disconnected from the fuel filter tube.

    

6Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Mon Aug 01, 2022 6:21 am

Laitch

Laitch
Life time member
Life time member
BendK100 wrote:I have an 85 which did not come with a fuel pump relief valve.
Are you referring to #1 in the first drawing or the vacuum switch in the second drawing.
Fuel pump not pumping Scree196Fuel pump not pumping Scree197
Are you certain the pump was immersed enough in fuel when it was in the tank? The pump-side of the tank can be fuel-starved when fuel is at a low level. It wouldn't be the first time that detail was overlooked. Smile 

An unregulated pump should be delivering ≥1 qt. per minute. Was that the volume produced when you bench-tested the pump with 12V? If it was—and the fuel level in the tank is high enough—then the voltage is too low in the pump wiring from the fuel level sender to operate the pump sufficiently to develop pressure and the reason requires investigation. Does your Brick have a float-type fuel level sender?


__________________________________________________
1995 K75 81,000 miles
Fuel pump not pumping Usa-lo10
    

7Back to top Go down   Fuel pump not pumping Empty Pump not pumping Mon Aug 01, 2022 11:21 am

daveyson

daveyson
Life time member
Life time member
Is the hose from the front barb of the fuel rail connected to the rear barb of the tank? It should be. If the hoses are connected the other way around, and the fuel pressure regulator is blocked with gunk, fuel won't be able to get to the rail. In that case, you want to try to clean the regulator without damaging the rubber diaphragm inside it.



Last edited by daveyson on Mon Aug 01, 2022 12:06 pm; edited 2 times in total


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

8Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Tue Aug 02, 2022 7:16 pm

BendK100

BendK100
active member
active member
Update. I had my father-in-law (electrical engineer) come over and confirm the wiring was fine. We ran the pump and confirmed 12v was getting to it while it was sitting in a container of fuel without pumping anything but making noise. So, the theory now is that the something internal in the pump is broken. Either something clogged it while it sat dry for a few months or I fried something while re-connecting the first time. Replacement is in the mail - I'll post an update in a few days to see if that fixes it.

    

9Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Wed Aug 03, 2022 6:07 pm

BendK100

BendK100
active member
active member
Solved!!! Somehow the positive and negative wires switched. I checked with the multimeter and somehow the ground wire was positive. I did some gerryrigging to switch them on the pump due to the different sizes and it worked perfectly.

I traced the fuel tank plug wires back to their sources and confirmed they are connected correctly. So, something in the sender must have mysteriously switched. 

I even got the engine to chug a tiny bit (first movement in 6 months)! Still not starting, but at least I have the pump figured out and have a list of solvable issues to troubleshoot.

    

10Back to top Go down   Fuel pump not pumping Empty Re: Fuel pump not pumping Wed Aug 03, 2022 11:14 pm

Laitch

Laitch
Life time member
Life time member
BendK100 wrote:So, something in the sender must have mysteriously switched.
The fault is not in our senders,
But in ourselves.
                       W. Shakespeare, SAE Master Technician
                       Globe Garage, London


__________________________________________________
1995 K75 81,000 miles
Fuel pump not pumping Usa-lo10
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum