BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


leon83

leon83
active member
active member
Hello,

I'm rebuilding my K100rs. After completely cutting of the cockpit and trying to rewire everything I found out that my gear position indicator was broken. After removing the swing-arm I found it (my first bike ever to work on). Opened it and found out that the springs (2 of 3) were broken. 

I only need a Neutral light, I'm not going to have a gear indicator. So my fix:

- I removed the two outer pins and springs
- Put 2 component resin on the inner circle, only the part for Neutral I left open
- Hooked up the Yellow / Blue cable to the Neutral light

Neutral Light Gear Position Switch fix Scherm10

Maybe not as fancy as a complete PLC with relays. But it does the job.

http://www.leonvanzanten.nl
    

thestza

thestza
active member
active member
this is a super clever fix. i'm experiencing an issue with a potentially busted TGPI switch and might go this route if i can't get the switch repaired.

    

Jibe

Jibe
active member
active member
I'm rewired mine to motogadget. I didn't have much luck with the original switch to knocked this up using a waterproof micro switch. Seems to be working out okNeutral Light Gear Position Switch fix Img_2021

    

thestza

thestza
active member
active member
Jibe, that also sounds like a cool fix. do you have any other info related to how you built it / wired it? i'm also trying to get mine working with a motogagdet motosign mini...

    

robmack

robmack
Life time member
Life time member
It looks like @Jibe used a cam of some sort to actuate the switch when the gear indicator shaft was in neutral.

If you choose this route, select a microswitch that is related for IP65 at least.  You want it to endure harsh conditions since it will be exposed to the elements.


__________________________________________________
Robert
1987 K75 @k75retro.blogspot.ca
http://k75retro.blogspot.ca/
    

Jibe

Jibe
active member
active member
@thestza wrote:Jibe, that also sounds like a cool fix. do you have any other info related to how you built it / wired it? i'm also trying to get mine working with a motogagdet motosign mini...
The shaft has a machined flat on it from the factory, so I just measured the foot print of the stock switch and made a plate up, the switch is waterproof ip68 they are cheap to buy on ebay. Mine has been fitted for about a year now with no false neutrals. With regards to the wiring one side is connected to earth and the other to the motogadget breakout box in my case. I've got the m unit Blue with the basic breakout and the pro as my clock. If you need any further information give me a hola 👍

    

RicK G

RicK G
admin
admin
Now that is a fine bit of thinking. Big thumb


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum