BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Fuel pump fuse blows Empty Fuel pump fuse blows on Sat Dec 12, 2020 3:36 pm

brianpen

brianpen
active member
active member
I've searched many threads to no avail. Here's my tale: My K75 was doing just fine. Decided to remove tank to paint it. Noticed that the plastic connector for the under tank wires was broken. Since I had previously eliminated the fuel level sender, I decided I only needed to install a new connector of the two wires needed for the pump. Connected green/white to green of tank lead, and brown to black of tank lead. (snipped and taped the other two wires).
Now when I hit the starter button, #6 fuse blows. Even when the connection to the tank lead is disconnected. Measured volts at fuse block when pushing the button and get a jump of 10 to as high as 18 volts. Looked at ground wire at frame, which is good. 
As has been the case with most of my K bike experiences (I have 2 k100's as well) it usually tends to be a simple rather than complicated fix. But I can't figure this one out. Thanks in advance.

    

2Back to top Go down   Fuel pump fuse blows Empty Re: Fuel pump fuse blows on Sat Dec 12, 2020 4:31 pm

robmack

robmack
Life time member
Life time member
I think you've wired things improperly.  The ground return on the tank is Brown, not Black.  Grounds are never Black on a BMW K-bike; always Brown.  So that's a mistake that needs to be cleared up.

The only Black wire associated with the start circuit is Black/Yellow from the start switch itself.  This is a power lead.  I'd reverse your wiring changes as well as keep the tank disconnected for this test.  Try the starter and see if the fuse continues to blow. If it doesn't your problem is your wiring choices.  If it continues to blow, disconnect the under-seat ECU and try again.


__________________________________________________
Robert
1987 K75 @k75retro.blogspot.ca
http://k75retro.blogspot.ca/
    

3Back to top Go down   Fuel pump fuse blows Empty Re: Fuel pump fuse blows on Sat Dec 12, 2020 5:50 pm

brianpen

brianpen
active member
active member
It was brown to brown (and green/white to green). Sorry I was fuzzy after reading threads. (the black wire appears inside the tank as the ground).
The fuse blows without the new wiring even connected. 
What would a disconnected ECU indicate if it blows or not? 
Would it be typical that the fuse would blow if no connection to the tank is made? Doesn't seem right, but I'm out of ideas.

    

4Back to top Go down   Fuel pump fuse blows Empty Pump fuse blows on Sat Dec 12, 2020 6:04 pm

daveyson

daveyson
Life time member
Life time member
Another option, unplug the temperature sensing unit (and pump plug) and replace fuse 6 with a voltmeter. While cranking you should read 0 Volts, if you read 12V there is a short in the wiring. If you can separate the gren/white wires from fuse 6, that could help to isolate the problem. If no luck the additional instruments connector might be worth a look.


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

5Back to top Go down   Fuel pump fuse blows Empty Re: Fuel pump fuse blows on Sat Dec 12, 2020 6:53 pm

brianpen

brianpen
active member
active member
Turns out even with soldering and shrink wrapping apparently one wild hair of a wire punctured the other wire. All good now. Except for the spill of gasoline on the new paint. Where do I apply for moron of the year? Very Happy
Thanks all.

    

6Back to top Go down   Fuel pump fuse blows Empty Pump fuse blows on Sat Dec 12, 2020 7:05 pm

daveyson

daveyson
Life time member
Life time member
Thanks for posting the fix, I spose you mean between the green/white and brown wires on the loom side of the plug.

Instead of a moron award you get credits from me for stating the uncomfortable truth, not everyone does that.


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

7Back to top Go down   Fuel pump fuse blows Empty Re: Fuel pump fuse blows on Sun Dec 13, 2020 9:18 am

moriarti

moriarti
Life time member
Life time member
Ditto #6.Easyer to fix a cockup than a technological nightmare Fuel pump fuse blows 723598


__________________________________________________
1984 k100 rs red/black VIN  0004449
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum