BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   K75 No power to fuel pump No spark Empty K75 No power to fuel pump No spark Wed Oct 13, 2021 10:49 pm

jjefferies

jjefferies
Gold member
Gold member
Hi, title says it all. My K75 has been having intermittent issues and now has decided to be dead. Testing described below was with power on and cranking the engine. The starter does work correctly. Checked the power to the fuel pump at the connector just outside the tank. No power. Just to confirm believe this was the Yellow and brown lines. Though none of the lines showed power. Checked that there was no spark by two methods. 1.) pulled the spark plug connected the spark line and grounded the side of the spark plug, then cranked the engine. 2.)use of a timing light. Hooked the timing light over #3 spark wire and cranked the engine while pressing on the timing light's switch. Both methods indicated no spark.

So I've been going through Bert's diagnostic flow chart but haven't seen what would cause both the fuel pump and spark plug to malfunction.

Any suggestions?

best regards
JJefferies

P.S. I've been assuming that Bert's notes on K100 also apply to the K75.

    

2Back to top Go down   K75 No power to fuel pump No spark Empty Re: K75 No power to fuel pump No spark Thu Oct 14, 2021 12:54 am

RicK G

RicK G
admin
admin
Check all the ground points,1 under the tank and the one on the transmission. make sure the ICU plug is in tight and also the ECU plug.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki
    

jjefferies

jjefferies
Gold member
Gold member
@RicK G wrote:Check all the ground points,1 under the tank and the one on the transmission. make sure the ICU plug is in tight and also the ECU plug.
Ground points yes. ECU and ICU. ECU is the box under the tank up by the steering fork. The box under the tool kit is what you refer to as the ICU?

    

Laitch

Laitch
Life time member
Life time member
The fuel injection control unit is under the seat. The ignition control unit is forward under the tank.


__________________________________________________
1995 K75 81,000 miles
K75 No power to fuel pump No spark Usa-lo10
    

92KK 84WW Olaf

avatar
Life time member
Life time member
Absence of power to both fuel pump AND spark is telling. Usually its one of the 2. 

Is everything else working ok?

Kill switch fail can cause this. Also check you have either neutral light or clutch pulled in [switch can and does go faulty].

But first check the ICU and FICU connectors as said. Clean all the connections. Also, the fuel pump only works if the start button is pressed or if the engine is running.


__________________________________________________
1992 K100LT 0193214 Bertha Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 106,950 miles Deceased.
1983 K100RS 0011171 Fricka 606 Alaska Blue 29,495 miles Damn K Pox Its a Bat outta Hell Now 40,490 miles. 
1996 K1100LT 0233004 Lohengrin Mystic Red 38,000 miles currently 42,640 miles.

Past:
1968 Yamaha 80 YG1
1971 Yamaha 125 YAS-1
1968 Honda 125 SS
1970 Honda CD 175
1973 Honda CB500-4
Honda CX 500
    

6Back to top Go down   K75 No power to fuel pump No spark Empty Re: K75 No power to fuel pump No spark Thu Oct 14, 2021 10:14 pm

jjefferies

jjefferies
Gold member
Gold member
Ok, thanks guys. I took the ground wires off, wire brushed the bolt, the area around it and the 5 wire ends, pulled the connectors for the ECU and ICU and sprayed them with cleaner and re-inserted. With the tank off I thought to try the starter and see if I had a spark. I have an electronic timing light that you clamp over the spark plug wires which would show if there was any spark. Engine fired right up even without the gas tank. Must have had some residual fuel. Shut it down and spent an hour or so putting everything back together. Took it outside and tried again. Fired up and ran satisfactorily. Makes me wonder if the loose connection was the gremlin I've been chasing.

thanks again.
J.

    

Arlina

Arlina
Moderator
Moderator
Good job Smile

With every service I check all connectors and earthlines, to prevent these kinds of bugs.


__________________________________________________
K75 No power to fuel pump No spark Eu-log10  K1100RS/LT - R1200RT - R1100RS (RIP) - Cagiva SST 350 Ala Verde - K75LT project - K75 Schurgers - K75S
    

8Back to top Go down   K75 No power to fuel pump No spark Empty Re: K75 No power to fuel pump No spark Fri Oct 15, 2021 10:40 am

yamaguzzi

yamaguzzi
Life time member
Life time member
First thing I look at when I have a problem like this is fuses and connections. 9 out of 10 times that's it even on my low tech bikes


__________________________________________________
1988 K 100RS ,1975 Moto Guzzi 850-T , 1971 BMW R60/5 , 1971 Yamaha R5B,1969 Yamaha DS6C ,1966 Yamaha YM1 , 1965 Yamaha YDS3
https://motoguzzi850t.blogspot.com/
    

9Back to top Go down   K75 No power to fuel pump No spark Empty Re: K75 No power to fuel pump No spark Fri Oct 15, 2021 11:49 am

92KK 84WW Olaf

avatar
Life time member
Life time member
@yamaguzzi wrote:First thing I look at when I have a problem like this is fuses and connections. 9 out of 10 times that's it even on my low tech bikes
Its the place to start. Service and deep polishing can include this same routine and prevents a lot of problems.


__________________________________________________
1992 K100LT 0193214 Bertha Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 106,950 miles Deceased.
1983 K100RS 0011171 Fricka 606 Alaska Blue 29,495 miles Damn K Pox Its a Bat outta Hell Now 40,490 miles. 
1996 K1100LT 0233004 Lohengrin Mystic Red 38,000 miles currently 42,640 miles.

Past:
1968 Yamaha 80 YG1
1971 Yamaha 125 YAS-1
1968 Honda 125 SS
1970 Honda CD 175
1973 Honda CB500-4
Honda CX 500
    

10Back to top Go down   K75 No power to fuel pump No spark Empty Re: K75 No power to fuel pump No spark Fri Oct 15, 2021 2:38 pm

Point-Seven-five

Point-Seven-five
Life time member
Life time member
@92KK 84WW Olaf wrote:Its the place to start. Service and deep polishing can include this same routine and prevents a lot of problems.
+1

I recall reading somewhere(possibly in the BMW rider's manual) that a good cleaning on a regular basis results in a better running, more reliable bike because it forces you to look closely at the condition of your machine.  Having gotten into the habit back in my misspent youth when I was competing in enduros and reliability trials, I know it works because I've found several potential problems with my street bikes over the years.


__________________________________________________
Present:
1994 K75RT
1991 K100RS
1988 K100RS SE

Past:
1994 BMW K75S
1992 BMW K100RS
1982 Honda FT500
1979 Honda XR185
1977 Honda XL125
1974 Honda XL125
1972 OSSA Pioneer 250
1968 Kawasaki 175
    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum