BMW K bikes (Bricks)


You are not connected. Please login or register

Go to page : Previous  1, 2

View previous topic View next topic Go down  Message [Page 2 of 2]


51Back to top Go down   I need help please start  - Page 2 Empty Re: I need help please start Wed Mar 13, 2024 5:42 am

Ribi


active member
active member
Any suggestions for me please I am back on it now ! Many thank

    

52Back to top Go down   I need help please start  - Page 2 Empty Re: I need help please start Wed Mar 13, 2024 8:35 am

92KK 84WW Olaf

avatar
Life time member
Life time member
Thefuel pump for your bike should pump at 4 Bar, about 60psi. The fuel pressure regulator [FPR] allows 36psi to the injector rail, the rest is returned to the tank.

I have no idea what pressure that Toyota pump pumps at but it may be too high.

The K bike fuel pump is a very common Bosch fuel pump used also in VW Audi Seat Fiat Peugeot Citroen cars in the 80s and is easy to get on eBay for small money.

You also need to be sure your fuel lines are correctly connected, if you do it wrong you could be sending fuel to the injectors at 60psi.


__________________________________________________
1992 K100LT 0193214 Bertha Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 106,950 miles Deceased.
1983 K100RS 0011157 Fricka 606 Alaska Blue 29,495 miles Damn K Pox Its a Bat outta Hell Now 58,200 miles. 
1996 K1100LT 0233004 Lohengrin Mystic Red 38,000 miles currently 48,061 miles.
1983 K100RS 0004449 Odette R100 colours 58,000 miles. Sprint fairing now 61,190 miles

Past:
1968 Yamaha 80 YG1
1971 Yamaha 125 YAS-1
1968 Honda 125 SS
1970 Honda CD 175
1973 Honda CB500-4
Honda CX 500
    

53Back to top Go down   I need help please start  - Page 2 Empty Re: I need help please start Thu Mar 28, 2024 1:40 am

Ribi

Ribi
active member
active member
Ok olaf many thanks.. I've only ever had the Toyota fuel pump in the bike so I do trust it. But I will double check my connections on the pipework

    

54Back to top Go down   I need help please start  - Page 2 Empty Help Sun Mar 31, 2024 12:35 am

daveyson

daveyson
Life time member
Life time member
I think I know what the problem is. It seems to me that you have verified the suggestion from point seven five that the fuel injection computer is sending constant earth to the injectors, when it should actually be intermittent. In that case replacing the computer is probably the best way to go.

Another way to verify this as the problem is with a computer safe test light, it's a simple easy test. With the test light clamp on battery positive and the probe on the injectors harness plug earth pin, the test light should flash on and off repeatedly while cranking, as in the photo below. If it remains constantly on, that's a problem. If it's idling it would be flashing much more quickly, close to looking constant. With the probe touching the other pin, the light should remain off (positive to positive)

I need help please start  - Page 2 Img_2120


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

Sponsored content


    

View previous topic View next topic Back to top  Message [Page 2 of 2]

Go to page : Previous  1, 2

Permissions in this forum:
You cannot reply to topics in this forum