BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Gremlins again Empty Gremlins again Sun Apr 13, 2014 12:46 pm

nino

avatar
Life time member
Life time member
Help please I have a situation:

cold engine runs well, but when get hot it begin to drang drang - and rpms goes up and down a bit:

I checked coils, changed water temp sensor, changed FI, changed spark plugs and nothing. ..

Finally started to test injector plugs (connectors) and found that hot engine runs the best way with cylinder 2 and 3 injectors unplugged. I cant believe that bike runs relatively smooth (on idle of course) only with injectors 1 and 4.

What is it? What to check?

    

2Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 1:01 pm

Inge K.

Inge K.
VIP
VIP
Drang drang........hmm......this is a tricky one.




I would guess a faulty hall sensor, have you checked that you got a steady pulse
from the rearmost coil....when the engine is at operating temp.


__________________________________________________
Inge K.
K100RS -86. (first owner), K1100LTSE -94.
    

3Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 2:35 pm

ReneZ

ReneZ
Life time member
Life time member
The injection module is working the injectors twice per cycle (once per revolution) and all injectors open and close at the same time (IIRC). Further cyl 1 and 4 are 'linked' over the first injection coil and cyl 2 and 3 over the second. There is something wrong when you unplug two injectors and the bike runs better (but you already knew that). It sounds as if the bike is badly adjusted mechanically or through sensor issues.

Do you know the history of the bike. What did you do or have happen that is is suddenly running so bad?

I would go back to zero. Check signal wires and then start the bike adjustment fresh. Check valve clearance and fuel pressure, check working of injectors and if all spark plugs work, check the tb rack in moving freely, if right than check timing, check no air leaks in the rubber bits, which includes making sure the rubber elbow between plenum and air filter box is properly fitted (air leakes sometimes can sound like a bonking noise), then synchronize the bike.


__________________________________________________
Greetings from Florida Australia! Having a 'new' K     Surprised-o: 

Rene


BMW K100 - 1985 (0030029) Scotland Gremlins again Rain
BMW K1200GT - 2003 (ZK01223) Florida
BMW K1200GT - 2004 (ZK27240) Australia
    

4Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 3:03 pm

nino

avatar
Life time member
Life time member
Thanks Rene, everything was good for years, maybe 30 - 40 tkm. I adjusted valves few months ago. It started with strange noise from fuel pump which continued and bike started to run erraticaly on idle. I changed pump, changed water temp sensor, changed hall sensor, FI computer, I have a new pair of coils ready to change.
Could it be box under the tank, near the head of frame?

    

5Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 4:19 pm

Crazy Frog

Crazy Frog
admin
admin
nino wrote:found that hot engine runs the best way with cylinder 2 and 3 injectors unplugged.
ReneZ wrote:cyl 1 and 4 are 'linked' over the first injection coil and cyl 2 and 3 over the second.
ReneZ, I believe your are talking about the ignition coils because the 4 injector coils are linked together.
Gremlins again Coils10             Gremlins again Coils_10
Nino, Do you see a pattern there?
I would say a bad coil or yes the ignition module in front of the fame.
A quick test for the coils would be to reverse them. (You have to physically switch them as I believe the wires will not be long enough)
After the switching, If the engine runs better with cylinder 1 and 4 unplugged, you have a problem with a coil. Otherwise, I would look at the ignition module or at the Hall sensors.


__________________________________________________
Gremlins again Frog15Gremlins again Logo2101986 k75, 1985 K100rt, 1985 K100rt/EML GT2 sidecar, 1999 K1200lt/Hannigan Astro Sport sidecar.
    

6Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 4:41 pm

nino

avatar
Life time member
Life time member
Thanks Bert, I changed the hall sensor and nothing happened. On cold engine everything sound very well, even hot on higher revs sound normal except high consumption. Could it be dirty contact on water temp sensor? I found that contact full of oil and try to clean but think isnt clean still. Is it possible that sensor because of dirty contact sends wrong signal to engine management?

    

7Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 4:53 pm

92KK 84WW Olaf

avatar
Life time member
Life time member
Two cylinders together, as in1/4 or 2/3 points to coil, condenser or anything on the circuit because each coil serves two cylinders.

Swap coils, its easy and if the problem moves to the other two cylinders 1/4 then your coil is problem. If the problem disappears you can figure it was a bad connection. If it remains and doesn't move to 1/4 suspect the wiring and/or connections to the 2/3 coil but also make sure the connections and grounds are good.

The ECU unit at the front of the frame may need to have the contacts cleaned off. But go for coils first because they do tend to fail with age and can damage the ECU at the front of the frame if left in poor condition.


__________________________________________________
1992 K100LT 0193214 Bertha Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 106,950 miles Deceased.
1983 K100RS 0011157 Fricka 606 Alaska Blue 29,495 miles Damn K Pox Its a Bat outta Hell Now 54,800 miles. 
1996 K1100LT 0233004 Lohengrin Mystic Red 38,000 miles currently 42,640 miles.
1983 K100RS 0004449 Odette 55,000 miles. Sprint fairing

Past:
1968 Yamaha 80 YG1
1971 Yamaha 125 YAS-1
1968 Honda 125 SS
1970 Honda CD 175
1973 Honda CB500-4
Honda CX 500
    

8Back to top Go down   Gremlins again Empty Re: Gremlins again Sun Apr 13, 2014 6:50 pm

Rick G

Rick G
admin
admin
Don't read too much into unplugging the injectors as these bikes will often idle with injectors disconnected because the manifold vacuum will drag enough fuel through the open pintle valve to let them idle. Not all the injectors but 1 or 2.
You say the temperature sensor was full of oil, which sensor did you remove, if you removed the sensor on the oil/water pump you may have removed the oil light switch.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1986 K75 GS.
    

9Back to top Go down   Gremlins again Empty Re: Gremlins again Mon Apr 14, 2014 12:18 am

nino

avatar
Life time member
Life time member
if you removed the sensor on the oil/water pump you may have removed the oil light switch.


No, it was a water temp sensor, but somehow the plug under the radiator was oily

    

10Back to top Go down   Gremlins again Empty Re: Gremlins again Mon Apr 14, 2014 1:04 am

Rick G

Rick G
admin
admin
Gee that is a bit odd maybe the cam chain cover was leaking a bit. It's the only place I can think it could come from there.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT 1998 K1100 LT, 1986 K75 GS.
    

11Back to top Go down   Gremlins again Empty Re: Gremlins again Mon Apr 14, 2014 1:15 am

nino

avatar
Life time member
Life time member
Thanks Rick, this afternon I ll swap coils. I have one spare pair with me. I hope its not ECU because spare was from swiss bike with limiter on 6500 rpm

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum