BMW K bikes (Bricks)

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   Speedo Intermittent Empty Speedo Intermittent on Sun Aug 09, 2015 6:36 am

Rickmeister

Rickmeister
Life time member
Life time member
I've bitten the bullet and pulled my dodgy ignition switch apart to be cleaned and De-Oxitted. (Fairing off, tank off etc). While its in this state, I will replace the oil/water pump seals.

Also, over the last 12 months or so, the speedo has been behaving erratically, esp in the summer, after several hours in the saddle. It works fine for at least 2 hours, then the needle wanders down and up and all over the shop. Is it the sensor/pick-up at the final drive or in the bowels of the instrument cluster? It seems to be heat related. Before I pull the thing apart, I thought I would post, with a view that if anyone had experienced this before, what to look for. Fore warned is fore armed, as they say in the classics. I thought that it would be a good opportunity to try and get this sorted. I have access to an oscilloscope, variable power supply and audio sig gen (sine only)

Thanx, Rickmeister.


__________________________________________________
Assumption is the root of all stuff-ups!
    

2Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Sun Aug 09, 2015 6:47 am

charlie99

charlie99
VIP
VIP
sine will do uli

probably several places to look along the path from the rear end though....including buildup of metal shavings in the rear bevel drive affecting the coil core

do you have a magnetic sump plug in there ?  many do .



good luck mate


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OSpeedo Intermittent Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

3Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Sun Aug 09, 2015 8:38 am

Stan

Stan
Life time member
Life time member
Could it be connected to your loss of that suspension a couple of years ago? Remember that the sender unit was not that far away from the broken stud. I also had the speedo needle everywhere on the orange bike. I pulled the instruments apart, replaced dead, broken cogs and cleaned bits and pieces..no problems since....fixed the trip/odo and needle.


__________________________________________________
1983 K100 basic vin 0003960 colour red  GONE
1987 K100RT vin 0094685 colour, orange peel, sorry, pearl..GONE
F800R black
    

4Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Sun Aug 09, 2015 9:56 am

Corkboy

Corkboy
Life time member
Life time member
common problem is the three-pin connection in the instrument cluster.  
http://www.ibmwr.org/ktech/speedo-repair2.shtml

http://www.motobrick.com/index.php?topic=449.0

https://www.k100-forum.com/t4936-speedo-and-instrument-connections

Another check is to hold a soldering iron (not touch), the sensor on the bevel box.  The AC mains signal from the soldering iron should give a constant reading at the speedo. Pretty weird to see your bike in the garage showing it moving on the speedo.

http://www.motobrick.com/index.php?topic=599.0

If that shows constant, it is another indication that the trouble is the three pin connector, which is losing connection due to a bad contact when you ride.

By the way, this has happened to me, and a resolder of the three pin/PCB solved the problem.


__________________________________________________
Regards,

Corkboy '87 K100RS SE (The black one - one of the two bikes I'm sorry I sold)
             '87 K100RS 0140995 (Gone)
             '97 K1100LT 0188024 (Gone)
             '08 K1200GT Wedge - but still a K
             '08 Transalp 700
    

5Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Sun Aug 09, 2015 8:13 pm

indian036

indian036
Life time member
Life time member
As Charlie and Corkboy say, basic check at the back end first because it's easy.  

Mine does a similar thing sometimes, and a sharp tap on the instrument housing often fixes it, so the connection inside is a strong suspect. When I get time, I'll be dismantling that bit and checking. 

Bill


__________________________________________________
1985 K100RT  VIN 0028991  My original Very Happy   (Historic rego)
1985 K100RT  VIN 0029036  BOB the Blue Old Bike  (Historic rego)
1990 K100LT  VIN 0190452  Work in progress
1984 K100RT  VIN 0023022  Work needing lots of progress

1986 K100RT  VIN 0090542  Work needing lots and lots of progress
1993 K1100LT  VIN 0183046  Work in progress
1993 K75S  VIN 0213045  Newest toy, slightly non-original
    

6Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Sun Aug 09, 2015 10:29 pm

duck

duck
Life time member
Life time member
@charlie99 wrote:
do you have a magnetic sump plug in there ?  many do .


Pretty sure they all have magnetic drain plugs on both trans and FD.  Every K I've ever seen has.

I vote pins in the back of the cluster.  If your odo isn't being flaky too then it's not a bad signal.

If you odo is wonky too then it's upstream of the cluster.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

7Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Sun Aug 09, 2015 11:43 pm

Rickmeister

Rickmeister
Life time member
Life time member
Thanks, Lads! I have just now removed the instrument cluster from the bike...its now on the bench.

Several times over the past few months I've tried the soldering iron at the pickup at the FD. (except, of course, when I've been out on the road when the thing goes wonky...!) All OK.

The sensor has been replaced after I fixed the the shock mounting stud.

The drain plug is magnetic, and when I drained the FD oil. the plug was free of metal debris.

It all points to the bowels of the instrument cluster.

Will read/ print out Corky's links to the repair sites. Will also investigate, while its on the bench, to set up a test jig, with my 12V PS and audio sig gen (I guess that 100Hz is about 120Km/hr)

Will keep you informed as to progress.

Thanks again.


__________________________________________________
Assumption is the root of all stuff-ups!
    

8Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 12:39 am

Stan

Stan
Life time member
Life time member
Remember...no speeding on the bench!


__________________________________________________
1983 K100 basic vin 0003960 colour red  GONE
1987 K100RT vin 0094685 colour, orange peel, sorry, pearl..GONE
F800R black
    

9Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 12:45 am

duck

duck
Life time member
Life time member
Not to be nitpicky but my calculations show that 97 Hz from the sensor should read 120kph. (With minor variations for tire circumference.)

Also make sure that whatever signal generator you use has adequate amplitude. I tried it with my netbook a few years ago and it did not have adequate amplitude to read properly.

I've found the same thing to be true with soldering irons. I have several that won't even register while others put out a significant magnetic field and work well for speedo calibration.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

10Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 1:30 am

Rickmeister

Rickmeister
Life time member
Life time member
Finally got the back off and the three pin plug thing removed.

Speedo Intermittent Dscf2010

Whereabouts is the dodgy connection supposed to be? At the bottom of the socket where the long prongs go?

Is it worthwhile to try and re-solder the pins where they attach to the PCB film?

Paralysed with indecision!!


__________________________________________________
Assumption is the root of all stuff-ups!
    

11Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 1:57 am

duck

duck
Life time member
Life time member
As fer as I know, the problem is with the pins maintaining a consistent connection with their sockets, not a soldering issue. What has worked for me in the past several times is cleaning up the pins with steel wool to remove any corrosion and then twisting them 5-10 degrees with needlenose pliers.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT (x2)
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

12Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 3:41 am

charlie99

charlie99
VIP
VIP
yep that's a pretty good description of some of the issues that we suffer  duck

I resurfaced the instrument input pins  with pretty good results

also cleaned up the pins that uli has now released from their home

and bridged the connections on the film connections from the input to the electronics board ...then to the meter drive subassembly the uli has released ....resoldering can do some nasty things to the film ...unless you have a good iron

note do not try and use the new high tin content solder that is becoming industry standard now days

ive sent some images to him just now

hope it helps


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OSpeedo Intermittent Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

13Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 4:27 am

Stan

Stan
Life time member
Life time member
Charlie...could it be the pins in my instruments that have caused the speedo working altogether?


__________________________________________________
1983 K100 basic vin 0003960 colour red  GONE
1987 K100RT vin 0094685 colour, orange peel, sorry, pearl..GONE
F800R black
    

14Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 5:20 am

charlie99

charlie99
VIP
VIP
could be stan

the motor drive wiring is the suspect area that im looking at

Speedo Intermittent 20150810

Speedo Intermittent 20150811

the rest looks not too bad

Speedo Intermittent 20150812

Speedo Intermittent 20150813


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OSpeedo Intermittent Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

15Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 5:27 am

Stan

Stan
Life time member
Life time member
I have a big hammer which could be used....Uli can use it as well.
Does the motor drive both the speedo and the odo/trip?



Last edited by ainsjac on Mon Aug 10, 2015 5:31 am; edited 1 time in total (Reason for editing : question)


__________________________________________________
1983 K100 basic vin 0003960 colour red  GONE
1987 K100RT vin 0094685 colour, orange peel, sorry, pearl..GONE
F800R black
    

16Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 6:20 am

charlie99

charlie99
VIP
VIP
have a look at the circuit stan

maybe complicated for lay people ....but looks like 2 motors to me ( I x motor ...1x guage )  but if the pins etc give intermittent operation

who knows ...  there are usually other contributing reasons why circuits stop working properly

Speedo Intermittent Tachos10


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OSpeedo Intermittent Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

17Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 8:09 am

Stan

Stan
Life time member
Life time member
With our climate..heat, vibration etc..no wonder problems appear with our instruments. The circuit diagram seems to mean something to you...thank goodness...but I am a lay person. Just as question...are there different diagrams for pre and post 85..when they changed the fuel lights and sender units?


__________________________________________________
1983 K100 basic vin 0003960 colour red  GONE
1987 K100RT vin 0094685 colour, orange peel, sorry, pearl..GONE
F800R black
    

18Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Mon Aug 10, 2015 11:50 am

charlie99

charlie99
VIP
VIP
yes different board and circuit ...but its found on the other side beside the tacho stan


__________________________________________________
cheezy grin whilst riding, kinda bloke ....oh the joy !!!! ...... ( brick aviator )

'86 K100 RT..#0090401 ..."Gerty" ( Gertrude Von Clickandshift ) --------O%OSpeedo Intermittent Au-log10

'86 k100 rs.. #######..  "Fred " (f(rame) red ) ( Fredrick leichtundschnell ) - -
bits and pieces from many kind friends across the k100 world ...with many thanks ..
    

19Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Tue Aug 11, 2015 7:03 am

Rickmeister

Rickmeister
Life time member
Life time member
Lads, have had a bit of success with the bench test set-up of the speedo unit.

Pin 6: +12V
Pin 13: -12V
Pins 22 - 23: Audio Sig Gen. (I/P from FD sensor)

Wound the AF up and down in frequency and the speedo followed accordingly.
Wound the level of the signal down (at 80Km/hr) until the indication became unstable. This is around 60mV pk-pk.

Left it on the bench tonight at about 80mV pk-pk at 80Km/hr (didn't want to rack up the miles too much going nowhere!)

Looking forward to looking at it tomorrow.

I didn't clean any contacts and left the two tiny retaining screws out of the of the 3 pin ribbon connector to the speedo.

Speedo Intermittent Dscf2011


Speedo Intermittent Dscf2012

Speedo Intermittent Dscf2013


__________________________________________________
Assumption is the root of all stuff-ups!
    

20Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Tue Aug 11, 2015 5:49 pm

Stan

Stan
Life time member
Life time member
Looks like one of those life support machines......you will have to make that decison at some stage.


__________________________________________________
1983 K100 basic vin 0003960 colour red  GONE
1987 K100RT vin 0094685 colour, orange peel, sorry, pearl..GONE
F800R black
    

21Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Tue Aug 11, 2015 7:00 pm

Rickmeister

Rickmeister
Life time member
Life time member
After 1061Km on the bench overnight, the speedo was still rock solid. Admittedly, it was a cold night, no vibrations etc...but nevertheless, I'm leaning towards external, ie, the sensor and intermediate plugs/sockets.

Rickmeister


__________________________________________________
Assumption is the root of all stuff-ups!
    

22Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Tue Aug 11, 2015 7:13 pm

indian036

indian036
Life time member
Life time member
For the next bit of electronic trickery, get it to wind back 1061 km like the old technology odometers. I don't think an electric drill will quite cut it!  Razz

Bill


__________________________________________________
1985 K100RT  VIN 0028991  My original Very Happy   (Historic rego)
1985 K100RT  VIN 0029036  BOB the Blue Old Bike  (Historic rego)
1990 K100LT  VIN 0190452  Work in progress
1984 K100RT  VIN 0023022  Work needing lots of progress

1986 K100RT  VIN 0090542  Work needing lots and lots of progress
1993 K1100LT  VIN 0183046  Work in progress
1993 K75S  VIN 0213045  Newest toy, slightly non-original
    

23Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Tue Aug 11, 2015 9:50 pm

RicK G

RicK G
VIP
VIP
Amazing how far you can go in one night when there's no traffic to contend with.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 1993 K1100 LT, 1998 K1100 LT, 1993 K75 RT, 1996 K75RT, 1986 K75 GS, 1979 Z1300 Kawasaki X 2 for now
    

24Back to top Go down   Speedo Intermittent Empty Re: Speedo Intermittent on Wed Aug 12, 2015 12:33 am

DaleRT

DaleRT
Silver member
Silver member
To overcome my speedo working intermittently, i followed all suggestions in the Forum with some success. So i tried this - 
Speedo Intermittent Imag0014
Speedo Intermittent Imag0015
- not pretty - but has worked for nearly 2yrs. It was to be temporary, something i had on hand, but the speedo behaves so i'll leave well-enough alone. 

There was a couple of mm movement of the board in its housing so inserted the rubber tube.
It looks like there is a lot of stress applied [first image] but not so, there is a slot cut along its length, just enough not to separate it, the slot fits over the board so it would'nt vibrate out [and it has'nt]

Also a bit of rubber tube over the three prongs to keep them mated.

Might be of help



Last edited by DaleRT on Wed Aug 12, 2015 7:24 pm; edited 1 time in total (Reason for editing : phone did'nt want to give me the 2nd image)

    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum