BMW K bikes (Bricks)

  • View posts since last visit
  • View your posts

Logged in as Anonymous. Your last visit was on

You are not connected. Please login or register

Go to page : 1, 2, 3 ... 20 ... 39  Next

Topics [0]

TopicsRepliesViewsLast Posts
No new posts   

1985 K100RT Starter Sprag Clutch Replacement

   by Bipolar
134avatarToday at 6:19 pm by 92KK 84WW Olaf View latest post
No new posts   

Sprag Clutch issue?

   by fox1486
 Where are the holes!?!?
352155avatarToday at 6:16 pm by 92KK 84WW Olaf View latest post
No new posts   

Final Drive Disassembly Help

   by dwnhillskater
255Engine and transmission 4780-36Today at 3:04 pm by Laitch View latest post
No new posts   

Water pump seals

   by Rockman
272015Engine and transmission 7226-24Today at 2:13 pm by Gergely View latest post
No new posts   

Bike wont idle, where to start

   by mynameisrodney
26697Engine and transmission Avatar10Yesterday at 6:11 pm by mynameisrodney View latest post
No new posts   

[1995 K75 Standard] Any good substitute for these Bosch ignition coils?

   by roach374
374Engine and transmission 1061-14Fri Feb 26, 2021 1:47 am by RicK G View latest post
No new posts   

Water Pipes

   by egredos
 Installation of temp Sensor
6144Engine and transmission 5422-6Wed Feb 24, 2021 8:37 am by chris846 View latest post
No new posts   

The famous smoke start

   by CCFallse
36498Engine and transmission 4780-36Tue Feb 23, 2021 2:16 pm by Laitch View latest post
No new posts   

Replacement original KEY

   by moriarti
283Engine and transmission Avatar10Mon Feb 22, 2021 5:03 pm by moriarti View latest post
No new posts   

K75 Ignition Cables / leads

   by roach374
11189avatarFri Feb 19, 2021 6:53 am by 92KK 84WW Olaf View latest post
No new posts   

Water pump leak

   by mritz
10371Engine and transmission 1061-14Tue Feb 16, 2021 7:25 pm by RicK G View latest post
No new posts   

Rebuilding/cleaning K100 throttle bodies

   by Fentible
72273Engine and transmission 5422-6Tue Feb 16, 2021 3:14 am by chris846 View latest post
No new posts   

85 K100RS Oil/Waterpump parts confusion

   by redman
104318Engine and transmission 5342-69Mon Feb 01, 2021 6:45 pm by ERasberg View latest post
No new posts   

Quick question about the monolever final drive

   by Tommy2305
2244Engine and transmission 5972-93Thu Jan 28, 2021 1:00 pm by Tommy2305 View latest post
No new posts   

Engine number location (asking for a friend) ;-)

   by Beemer Wheeler
5239Engine and transmission 4780-36Sun Jan 17, 2021 11:37 am by Laitch View latest post
No new posts   

Oil Pressure Light - Always On

 [ 1, 2 ] by dallasf
74876Engine and transmission 6032-16Wed Jan 13, 2021 6:17 pm by daveyson View latest post
No new posts   

This... after 8 miles ? Flogging a sick horse or something like...

   by V11POW
 Spark plugs showing me something's not right.
24929Engine and transmission 1606-55Sun Jan 10, 2021 2:55 pm by Two Wheels Better View latest post
No new posts   

Valve lapping on a K1100

   by mike d
 Valves
9323Engine and transmission 4473-85Mon Jan 04, 2021 1:49 am by jbt View latest post
No new posts   

Dynatek Coils

   by cycleman
 Dynatek Coils
3290Engine and transmission Avatar10Fri Jan 01, 2021 6:09 pm by cycleman View latest post
No new posts   

Anti-Freeze in Intake Port?

   by AUBIEBMW
 Help diagnosing why there would be antifreze in intake port
15375Engine and transmission 1606-55Fri Dec 25, 2020 7:27 pm by Two Wheels Better View latest post
No new posts   

Removed the 'oil pan' before the oil plug

   by dallasf
7252Engine and transmission Avatar10Sun Dec 13, 2020 4:43 am by dallasf View latest post
No new posts   

Oil/water pump

   by mritz
8303Engine and transmission 3608-23Mon Nov 30, 2020 8:08 pm by Dai View latest post
No new posts   

Getting "European horsepower" out of a US K75?

   by roach374
 Looking for advice on improving performance
22438Engine and transmission 3608-23Mon Nov 30, 2020 8:07 pm by Dai View latest post
No new posts   

weird running issue

   by wilbo
 bike idles perfect on side stand only
11232Engine and transmission 3479-77Fri Nov 27, 2020 12:09 am by Point-Seven-five View latest post
No new posts   

What's the problem here

   by mritz
25515Engine and transmission 3608-23Thu Nov 26, 2020 7:06 am by Dai View latest post
No new posts   

Idle & Sounds

   by George_Pap
14903Engine and transmission Avatar10Wed Nov 25, 2020 7:47 pm by stanthomas View latest post
No new posts   

How whirr-ey is your gearbox

   by stanthomas
27883Engine and transmission Avatar10Wed Nov 25, 2020 7:37 pm by stanthomas View latest post
No new posts   

Sprag clutch fixed... engine starts but is sick.. what have I done?

   by V11POW
 Engine barely runs. Won't idle. Revs okay-ish, but keeps trying to stall
17394Engine and transmission 3479-77Wed Nov 25, 2020 3:52 pm by Point-Seven-five View latest post
No new posts   

Broken exhaust manifold

   by Holister
291111Engine and transmission 6960-68Mon Nov 23, 2020 8:07 pm by costellon View latest post
No new posts   

Cylinder scoring

   by charlesosprey
 Acceptable scoring
1150Engine and transmission 4473-85Mon Nov 23, 2020 4:04 pm by jbt View latest post
No new posts   

K100 trouble removing shims

   by allemande
 K100 trouble removing shims
7179Engine and transmission 3371-22Mon Nov 23, 2020 8:50 am by Holister View latest post
No new posts   

Waterpump seal: Special Tool?

 [ 1, 2 ] by Diver
9810006Engine and transmission Avatar10Fri Nov 20, 2020 4:42 pm by Zisco View latest post
No new posts   

Final Drive Pinion Tool

   by dwnhillskater
3217Engine and transmission 1624-74Mon Nov 16, 2020 5:27 pm by sidecar paul View latest post
No new posts   

Ebay Aluminum Radiator Thoughts

   by dwnhillskater
21711Engine and transmission 4780-36Mon Nov 16, 2020 1:21 pm by Laitch View latest post
No new posts   

Another K100 running lean

   by Michael Sydney
19714avatarMon Nov 16, 2020 7:04 am by 92KK 84WW Olaf View latest post
No new posts   

K100 shim removal

   by allemande
 Can I remove all shims?
6254Engine and transmission 3479-77Sun Nov 15, 2020 12:42 am by Point-Seven-five View latest post
No new posts   

85 K instrument reading

   by arbalest
33678Engine and transmission 6032-16Sun Nov 01, 2020 1:38 am by daveyson View latest post
No new posts   

K100 oil/water pump cavitation near seal

   by Johnk100lt
9339Engine and transmission 3608-23Mon Oct 19, 2020 5:14 am by Dai View latest post
No new posts   

K75 Engine squeak on idle when hot

   by -mek-
5403Engine and transmission 5939-49Fri Oct 16, 2020 2:35 am by -mek- View latest post
No new posts   

In Gear Won't Drive

   by tjh1985
 In Gear Won't Drive
30883Engine and transmission Images10Wed Oct 14, 2020 1:23 am by JR_K100RS View latest post
No new posts   

breather hose at the front of the engine

   by svenok
 Location location location
8332Engine and transmission Avatar10Thu Oct 08, 2020 5:28 pm by svenok View latest post
No new posts   

Tranny fluid leak

   by zaubertuba
5383Engine and transmission 1606-55Sun Sep 27, 2020 4:28 pm by Two Wheels Better View latest post
No new posts   

Change in sound of the engine in an RPM range

   by ssk75rt
 Rotational sound of the engine changes at 3500RPM
7299Engine and transmission 4780-36Sat Sep 26, 2020 4:36 pm by Laitch View latest post
No new posts   

Problemas ???

   by César Santos
10461Engine and transmission 6032-16Sat Sep 19, 2020 9:43 pm by daveyson View latest post
No new posts   

Faulty Fuel pressure regulator

   by warmshed
17525Engine and transmission Avatar10Wed Sep 16, 2020 5:03 am by Packo View latest post
No new posts   

Oil Filter has become my sworn enemy

   by commonsenseman
31664Engine and transmission 4780-36Sun Sep 13, 2020 11:38 am by Laitch View latest post
No new posts   

Fuel pump on the way out??

   by Bonzo
32900Engine and transmission 5085-80Sun Sep 13, 2020 8:11 am by Michael Sydney View latest post
No new posts   

Anyone know why this is running so rough?

   by timz10000
24772Engine and transmission 6347-71Sat Sep 12, 2020 5:09 am by warmshed View latest post
No new posts   

Transfer Shaft - Engine Replacement

   by tjh1985
 In Gear Won't Drive
6259Engine and transmission 5765-46Wed Sep 09, 2020 2:07 pm by tinyspuds View latest post
No new posts   

K1100 RS starter problem

 [ 1, 2 ] by Danish biker
 Starter søns but sprang clutch doesn’t turn engine
851197avatarFri Sep 04, 2020 2:29 pm by 92KK 84WW Olaf View latest post

Topics [50]

  Back to top

Go to page : 1, 2, 3 ... 20 ... 39  Next

Permissions in this forum:
You cannot post new topics in this forum
You cannot reply to topics in this forum

  • No new posts No new posts
  • New posts New posts
  • New posts [ Popular ] New posts [ Popular ]
  • New posts [ Locked ] New posts [ Locked ]