BMW K bikes (Bricks)


You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]


1Back to top Go down   1985 K100rs no Injector Pulse Empty 1985 K100rs no Injector Pulse Sun Feb 26, 2023 7:02 pm

Zacdonov

Zacdonov
active member
active member
Went to start my k100rs and found no fuel is spraying from all 4 injectors. 

Fuel pump is new and audibly primes.

New fuel filter

Sent in to service all 4 injectors professionally and flow rates are good injectors open and close. 

I have fuel pressure at the fuel rail.

Using a multimeter i found 12 volts on both terminals to all 4 injector connectors when grounding to the frame. But when putting both multimeter probes to both terminals on each connector there is no power or pulse when pressing the starter. 

Following Crazy Frogs troubleshooting guide how should i test for a grounding pulse when measuring at the Injection ECU?

    

2Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Sun Feb 26, 2023 7:52 pm

duck

duck
Life time member
Life time member
On a 2V K100RS Pin 12 of the L-Jetronic sends a ground pulse to fire the injectors. (Yellow/Gray wire.)


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

3Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Sun Feb 26, 2023 7:59 pm

duck

duck
Life time member
Life time member
1985 K100rs no Injector Pulse Ddtrtsf


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

4Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Sun Feb 26, 2023 8:19 pm

Zacdonov

Zacdonov
active member
active member
Duck, thanks for the quick reply I'm a novice when it comes to electrical and picked up my first multimeter the other day. Could you explain in greater detail exactly how this test can be performed using a multimeter? What values am i looking for? I've also read elsewhere the test can be performed using an LED?

    

5Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 12:06 am

duck

duck
Life time member
Life time member
Where are you in WA?

Analog or digital multimeter? Analog multimeters have a needle and might be better for something like this.

Example:
1985 K100rs no Injector Pulse 81+WjTO6v2L._AC_SX679_


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

6Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 12:12 am

duck

duck
Life time member
Life time member
LED: I've never tried it but it might be possible with a 12V LED.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

7Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 2:17 am

Rick G

Rick G
admin
admin
You can also use a 1.5 volt LED and put a 470 ohm resistor in series with it.


__________________________________________________
"Man sacrifices his health in order to make money.
Then he sacrifices money to recuperate his health.
And then he is so anxious about the future that he does not enjoy the present; the result being that he does not live in the present or the future; he lives as if he is never going to die, and then dies having never really lived."   Dalai Lama


Bikes 2004 K1200GT (crashed I lived it died) 1999 K1100 LT.
    

8Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 2:20 am

duck

duck
Life time member
Life time member
Rick G wrote:You can also use a 1.5 volt LED and put a 470 ohm resistor in series with it.

That's old school from back when 12V LEDs weren't as cheap and readily available as they are now. Twisted Evil


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

9Back to top Go down   1985 K100rs no Injector Pulse Empty No pulse Mon Feb 27, 2023 3:10 am

daveyson

daveyson
Life time member
Life time member
With the start button pressed the injectors should be getting constant power and a pulsing earth. I think one of these is missing.

With a 12V LED test light clamped to battery positive and probe to one of the injector plug terminals, the light should pulse, that would be the negative terminal. On the other probe (edit: terminal) the light should remain off (positive to positive)

 With clamp to battery negative and probe to the positive terminal, the light should be constantly on. 

I've posted a photo of this showing which is positive and negative, but can't remember how to send it to this thread. The thread is called:  Troubleshooting a 1985 K100 that won't start/stay running
it's on page 2, post 91.



Last edited by daveyson on Mon Feb 27, 2023 3:46 pm; edited 2 times in total


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

10Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 10:25 am

92KK 84WW Olaf

avatar
Life time member
Life time member
Zacdonov wrote:Went to start my k100rs and found no fuel is spraying from all 4 injectors. 

Fuel pump is new and audibly primes.

New fuel filter

Sent in to service all 4 injectors professionally and flow rates are good injectors open and close. 

I have fuel pressure at the fuel rail.

Using a multimeter i found 12 volts on both terminals to all 4 injector connectors when grounding to the frame. But when putting both multimeter probes to both terminals on each connector there is no power or pulse when pressing the starter. 

Following Crazy Frogs troubleshooting guide how should i test for a grounding pulse when measuring at the Injection ECU?
Isit 2v or 4v RS? Maybe put year and typoe and VIN on your signature.


__________________________________________________
1992 K100LT 0193214 Bertha Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 106,950 miles Deceased.
1983 K100RS 0011157 Fricka 606 Alaska Blue 29,495 miles Damn K Pox Its a Bat outta Hell Now 58,200 miles. 
1996 K1100LT 0233004 Lohengrin Mystic Red 38,000 miles currently 48,061 miles.
1983 K100RS 0004449 Odette R100 colours 58,000 miles. Sprint fairing now 61,190 miles

Past:
1968 Yamaha 80 YG1
1971 Yamaha 125 YAS-1
1968 Honda 125 SS
1970 Honda CD 175
1973 Honda CB500-4
Honda CX 500
    

11Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 4:53 pm

duck

duck
Life time member
Life time member
2V

It says 1985 in the thread title.


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

12Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 7:06 pm

92KK 84WW Olaf

avatar
Life time member
Life time member
duck wrote:2V

It says 1985 in the thread title.
I didnt go back to look up there.


__________________________________________________
1992 K100LT 0193214 Bertha Blue 101,000 miles
1984 K100RT 0022575 Brutus Baja Red 578 bought 36,000 now 89,150 miles
1997 K1100LT 0188024 Wotan Mystic Red 689 58,645 now 106,950 miles Deceased.
1983 K100RS 0011157 Fricka 606 Alaska Blue 29,495 miles Damn K Pox Its a Bat outta Hell Now 58,200 miles. 
1996 K1100LT 0233004 Lohengrin Mystic Red 38,000 miles currently 48,061 miles.
1983 K100RS 0004449 Odette R100 colours 58,000 miles. Sprint fairing now 61,190 miles

Past:
1968 Yamaha 80 YG1
1971 Yamaha 125 YAS-1
1968 Honda 125 SS
1970 Honda CD 175
1973 Honda CB500-4
Honda CX 500
    

13Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 7:24 pm

Zacdonov

Zacdonov
active member
active member
I purchased a 12v LED test light today and after clamping to battery POSITIVE the light was not flashing on either injector connector terminal when pressing the starter. When clamping to battery NEGATIVE i was getting a pulse on both injector connector terminals while pressing the starter.

    

14Back to top Go down   1985 K100rs no Injector Pulse Empty No pulse Mon Feb 27, 2023 8:00 pm

daveyson

daveyson
Life time member
Life time member
What it looks like to me, the first test proves you have no earth, you need to fix that or else the injectors will never open.

The second test shows the wiring is seriously messed up. If you have done electrical modifications, check them over, especially any done before this no go situation.

The fuel injection computer sends a pulsing earth signal. You should have constant power from the fuel relay but your getting a pulsing signal, that makes it look like the computer is involved. Have a good look at the plug for the fuel injection computer.

Maybe it's the computer, there's a test in Bert's guide, or if possible check if the symptoms are the same with your computer in another brick.


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

15Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 10:01 pm

Zacdonov

Zacdonov
active member
active member
I have a spare ICU when swapped i get the same conditions. The injection ecu gets signal on pin 1 from pin 8 on the icu. Using a multimeter I measured from both ends and found continuity. Can we think of any other reasons why the bike would not be getting a grounding signal to the injectors? I’ve ordered a new ecu, airflow sensor, temp sensor, injection harness as well as a main wiring harness. I will not rest until I’ve narrowed this issue haha

    

16Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Mon Feb 27, 2023 10:30 pm

duck

duck
Life time member
Life time member
Note that there are early and late versions of the wiring harnesses. As an 85, your bike probably has the 61111459520 fuel harness and 61111459037 main harness..


__________________________________________________
Current stable:
86 Custom K100 (standard fairing, K75 Belly pan, Ceramic chromed engine covers, paralever)
K75 Frankenbrick (Paralever, K11 front end, hybrid ABS, K1100RS fairing, radial tires)
86 K75C Turbo w/ paralever
94 K1100RS
93 K1100LT
91 K1
93 K75S (K11 front end)
91 K75S (K1 front end)
14 Yamaha WR250R
98 Taxi Cab K1200RS
14 K1600GT
http://www.ClassicKBikes.com
    

17Back to top Go down   1985 K100rs no Injector Pulse Empty No pulse Mon Feb 27, 2023 11:10 pm

daveyson

daveyson
Life time member
Life time member
Probably better to find the problem first before spending money. I was thinking swap the fuel injection computer rather than the ICU. 

I'm thinking the fuel injection computer can't supply earth if it's not getting earth, I think that's near the injector rail. I think there might be a photo of that as well in the thread I mentioned, if you found that thread. But the second test results were a real doozy.


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

18Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Tue Feb 28, 2023 12:01 am

Laitch

Laitch
Life time member
Life time member
Zacdonov wrote:I will not rest until I’ve narrowed this issue haha
Especially if you stay on the parts-buying binge. The piper will be paid. Smile 

Are you using the site's troubleshooting guide flowchart with the black print text, the one with the colored text and boxes, or both? Are you using the Level 2 LE Jetronic manual to help sort this out, also?


__________________________________________________
1995 K75 90,000 miles
    

19Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Tue Feb 28, 2023 1:03 am

Zacdonov

Zacdonov
active member
active member
My 3rd test was to clamp my test light to battery positive and measure pin 12 on the female connector to the injection ecu for a ground pulse and found nothing when pressing the starter. But with my clamp on battery negative i have 12v and a pulse.

Following Crazy frogs guide I'm supposed to find a pulsing negative on pin 12? What does pulsing negative even mean and is my 3rd test another doozy?

    

20Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Tue Feb 28, 2023 2:26 am

Laitch

Laitch
Life time member
Life time member
Zacdonov wrote:What does pulsing negative even mean . . .
A pulsed negative is a negative ground connection switched on then off repeatedly. This switching is what opens and closes each fuel injector to fuel each cylinder during operation. The fuel injection control unit controls the duration the injector is open.

Maybe watching this video will help. Imagine it's a Brick engine. It could help you fall asleep if nothing else. Smile


__________________________________________________
1995 K75 90,000 miles
    

21Back to top Go down   1985 K100rs no Injector Pulse Empty No pulse Tue Feb 28, 2023 4:28 am

daveyson

daveyson
Life time member
Life time member
Find a photo which shows which side of the plug for the injector is positive. With the injection ECU unplugged and the start button pressed, you should have constant power on the positive terminal.
of the plug for the injector. If so and it becomes pulsing with the computer plugged back in, that's not looking good for the computer. But you still want to check that the computer is getting earth. 

The computer has many inputs, but only one output, pulsing earth to the injectors. Your tests at the plug are good for checking inputs, but I think the reason you didn't get a reading for the output was because the  computer was unplugged. 

The injection ECU should get earth from plug terminals 5 and 13. With test light clip on battery positive and probe to terminal 5, the light should glow. Same for 13.

It's also good to give these connections a clean with the help of some dioxide (Edit: deoxit)



Last edited by daveyson on Wed Mar 01, 2023 7:50 am; edited 1 time in total


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

22Back to top Go down   1985 K100rs no Injector Pulse Empty Re: 1985 K100rs no Injector Pulse Wed Mar 01, 2023 2:55 am

Zacdonov

Zacdonov
active member
active member
Measured pins 5 and 13 clamped to battery positive and both have ground. My new used Injection wiring harness was the first to show up in the mail and immediately i got to work. The new injection harness immediately provided pulsing ground to each injector connector and i was able to start the bike for the first time in over 6 months! Now what to do with all the extra parts i ordered haha

    

23Back to top Go down   1985 K100rs no Injector Pulse Empty No pulse Wed Mar 01, 2023 3:36 pm

daveyson

daveyson
Life time member
Life time member
Bonus, well done.

Just a point about the pulse, even at idle speed, the light is turning on and off so many times, there's not a really big difference between it pulsing and constantly on. The computer should be receiving constant earth and provides a pulsing earth and duration based on its inputs.

In this photo the positive is on the right.
1985 K100rs no Injector Pulse Img_2102


Test light on the negative terminal.
1985 K100rs no Injector Pulse Img_2104


__________________________________________________
11/1985 bmw k100rt (late model)  Vin. 0090567
 ~120,000 km
    

Sponsored content


    

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum